Jump to content

Strm files with rtsp stream specified don't play on Android client.


pwhodges
 Share

Go to solution Solved by pwhodges,

Recommended Posts

I thought I'd made a thread for this here already, but apparently not!  Perhaps I wanted to do more tests first and then forgot.

Anyway, I have a couple of STRM files specifying RTSP streams from webcams (they have very different URL structures).  These work as expected and display in all the clients I have tried (web, theatre, iOS), with the single exception of the Android mobile client.  I have tried with both the default player and another player selected, which makes no difference.  It works in the web client running on the same device.

The Android client is quite an important part of my intended use of this feature, so it would be nice to resolve this.

I am running current betas of both server and client; the Android being tried is either a Huawei MediaPad or a Huawei P20 Pro phone.

Paul

Link to comment
Share on other sites

Oops, yes.  Here.

I let the client try for about a minute in case it was just slow getting going, so it's right at the end of this log.  No ffmpeg log was generated.

Paul

embyserver.txt

Edited by pwhodges
Link to comment
Share on other sites

  • 3 weeks later...

I would like to echo this experience. Tried viewing an rtsp stream. Worked fine in web client v4.4.3.0 and iOS v1.9.7, but no luck with Android v3.1.23. This was with a webcam set to H264. I can provide more details about the camera settings if needed. See attached for server log. 

embyserver.txt

Link to comment
Share on other sites

Have you guys tried using the IPTV Plugin instead of strm files?

I run my web cams this way and they work in Android.

  • Thanks 1
Link to comment
Share on other sites

I may try that.  However (1) the behaviour is still a fault to be rectified, and (2) I try to avoid additional plugins because of the frequency with which I see the advice to remove them as part of debugging other issues!

EDIT:  Well, thanks for that, because it does work for me as well :) .  I was surprised that when I installed it there was already an old setting for one of my webcams - I suppose I must have tried it before and forgotten all about it.  Whatever... the old setting didn't work, and I couldn't find out why because the plugin appears to provide no facility to view or edit existing settings; but new settings using the URLs from my strm files worked straight off.

Paul

Edited by pwhodges
Link to comment
Share on other sites

Is it written anywhere that STRM files support rtsp in Emby?

The IPTV Plugin on the other hand does support rtsp.

Link to comment
Share on other sites

Well I guess that covers that. :)

Right now it's only the Android Client having an issue with rtsp and strm files?

Link to comment
Share on other sites

It's OK in Web (including on an Android), both Windows clients, Roku, and iOS - the only client I have a problem with is Android Mobile.

Paul

Link to comment
Share on other sites

4 hours ago, cayars said:

Right now it's only the Android Client having an issue with rtsp and strm files?

@ebr Can you take a look at this?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...