Jump to content

Emby Connect using indirect routing


Recommended Posts

I am running emby server at home and all devices can connect via the Lan.  We are planning to visit family overseas and would like to access the server, either via the web client, iPad or via a Shield TV.  I know that Emby Connect on my mobile phone (android) works as I can test this by disabling the wifi connection and just using mobile data.  What I would like to do is test Connect on the laptop, iPad (no modem) and Shield before we travel (rather than attempt to troubleshoot after we arrive).

Current restrictions make accessing another network difficult and so I am trying to test by adding the devices onto a separate subnet (192.168.xx.xx rather than the default 10.xx.xx.xx) so as to connect via the external interface of the router.  After some editing of the settings I was able to run checks for Plex on the laptop, but am having no success with Emby (I have tried disabling the laptop firewall, but it did not help).  

  • I can login to my Emby connect account on the web. 
  • When logged in I can see the my emby server but cannot connect
  • if I enter external address of the router (either as DDNS or IP) I cannot connect
  • I know that the laptop can see the external address, as running ping or tracert on the DDNS name gives the (current) external ip of the router.
  • When I try to connect there is nothing showing in the server log files.

Is there anything else I can try, as noted before I can connect to plex 'remotely', but not emby.

 

 

Link to post
Share on other sites
cmacfarlane93

If using emby connect on your phone's data works in your previous setup worked then I would go back to that. It should not make any difference what device you connect from(By this I mean if you could connect on your phone without the wifi, you should be able to connect from any of your devices). If you want you can PM the external address and I can try to connect.

 

Edit or you could also trying using your phone's data as a hotspot for your shield or laptop and try connecting to the external address.

Edited by cmacfarlane93
another idea.
Link to post
Share on other sites
rbjtech

Both 192.168.x.x and 10.x.x.x are 'private' networks and not WAN routable.  The best advice is above - if you simply turn on your mobiles hotspot (which turns off the LAN side wifi), connect your laptop to it - then you will be using the 4G WAN address and it should connect exactly the same as if you had used the mobile directly via 4G.     Remember if you are connecting directly to use the correct port after the url - ie http:\\myserver.com:8096  or https:\\myserver.com:8920 

Link to post
Share on other sites

Hi.  Connect is just a convenience for not having to know your server's address.  If you have a domain or know your public IP address you can also just test using that.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...