Jump to content

EmbyCon for Kodi 19 Matrix


TeamB
 Share

Recommended Posts

I just finished merging and releasing the latest beta build for Kodi 19 Matrix.

This is the latest Python3 version with all the latest changes from the current version.

To install it you can use the beta repository and using the power of magic it will automatically install the correct version when you are using the latest nightly builds of Kodi 19 matrix.

For testing grab the latest nightly build of Kodi 19 from:
http://mirrors.kodi.tv/nightlies/windows/win64/master/

And install the Beta repo, then install EmbyCon (1.10.4):
http://kodi.emby.tv/

Report bugs, have fun.

 

 

Link to comment
Share on other sites

Apologies if I'm missing something very obvious as this is my first attempt in 2 years at using Kodi and I'm not well versed at installing add-ons, making sure my repos are correct etc.

I've done a fresh install of the most recent nightly build of Kodi using your link above.  I then add http://kodi.emby.tv as a source, then get the beta repo from there.  When I go to the beta repo the only version of EmbyCon I find is 1.10.3.  This does install but once I go to connect to my Emby server, the addon crashes without logs (guessing this is due to old version and Kodi requiring Python 3 addons, thus this update).  

Can you steer me in the right direction here, by chance?

Link to comment
Share on other sites

I saw that the dependencies need to be installed before install some add-ons in the Kodi 19 and some Python 3 based new add-ons

Just for your records

Link to comment
Share on other sites

2 hours ago, EricGRIT09 said:

Apologies if I'm missing something very obvious as this is my first attempt in 2 years at using Kodi and I'm not well versed at installing add-ons, making sure my repos are correct etc.

I've done a fresh install of the most recent nightly build of Kodi using your link above.  I then add http://kodi.emby.tv as a source, then get the beta repo from there.  When I go to the beta repo the only version of EmbyCon I find is 1.10.3.  This does install but once I go to connect to my Emby server, the addon crashes without logs (guessing this is due to old version and Kodi requiring Python 3 addons, thus this update).  

Can you steer me in the right direction here, by chance?

All the Kodi 19 versions are 1.10.x so you have the correct repo installed just not the latest version of the add-on for some reason, I will check the repo to make sure it uploaded correctly.

When you say it crashed, do you mean Kofi crashed or the add-on threw an error?

Link to comment
Share on other sites

1 hour ago, Riggs said:

I saw that the dependencies need to be installed before install some add-ons in the Kodi 19 and some Python 3 based new add-ons

Just for your records

I will test this today and see if this the case for EmbyCon

Link to comment
Share on other sites

Just now, TeamB said:

All the Kodi 19 versions are 1.10.x so you have the correct repo installed just not the latest version of the add-on for some reason, I will check the repo to make sure it uploaded correctly.

When you say it crashed, do you mean Kofi crashed or the add-on threw an error?

The add-on threw an error, then nothing in logs.  Same thing has happened when I try to install other unrelated add-ons which aren't designed for Python 3/Matrix.

Link to comment
Share on other sites

the 1.10.4 version should be available now, there was an issue caused by the recent Emby Web server updates that stopped the add-ons being correctly indexed.

Try 1.10.4 now and see if it helps.

  • Like 1
Link to comment
Share on other sites

23 hours ago, TeamB said:

the 1.10.4 version should be available now, there was an issue caused by the recent Emby Web server updates that stopped the add-ons being correctly indexed.

Try 1.10.4 now and see if it helps.

Works like a charm now - thanks a lot!

Link to comment
Share on other sites

Hello,

I installed on my Kodi 18 9.2.1 the repository.beta.emby.kodi-1.0.9.zip repository.emby.kodi-1.0.6.zip, then embycon 1.9.82. Since today I also get the update 1.0.1.4 for Kodi 19 which I can't install because of python 3. Normally this should only be displayed under Kodi 19 ?

 

Link to comment
Share on other sites

Looking into this now, I think something got released to the stable dir that should not have.

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...
  • 1 month later...

Hello and thank you for EmbyCon for Kodi 19 Matrix.

I installed everything several times, Emy sees my NAS server, after logging in, but nothing happens....
My movies from the server are NOT scanned and entered.

Under Kodi 18.9 everything runs smoothly.

Am I making a mistake somewhere?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...