Jump to content
plaidstallion

Cast & Crew Tumbnails Missing for Some Actors

Recommended Posts

plaidstallion

Hello,

 

I recently did a server hardware upgrade and moved my Docker compose and config folder to the new system. Everything works mostly as expected but some of the Cast & Crew thumbnails are not found and they are shown as black boxes. If I manually go into the actor entry and search for an image it will be downloaded. When I leave and come back into the movie entry, the actor thumbnail will be there. The problem is I am not sure of where to edit this globally to do a re-scan or something.

 

Here is an example of the process I need to go through for manually downloading the thumbnail for each missing actor right now. 

 

I have looked through the settings but have, so far, not come up with a place to force a re-scan. I am also not sure why some actor thumbnails show up and some not. It seems like they would all be stored in on place and when I transitioned to the new server they should have either all come over or none of them would have. Any insight/assistance would be useful.

 

Side question: I am assuming the actor entries where there is only text on a colored background is simply due to the fact of there being no image available to download for that actor?

 

Thanks!

 

Share this post


Link to post
Share on other sites
Luke

Hi, regarding the colored boxes, yes that is correct. You may want to check moviedb and tvdb to see that they have because that's where they come from. Please let us know if this helps. Thanks.

Share this post


Link to post
Share on other sites
plaidstallion

Hi, regarding the colored boxes, yes that is correct. You may want to check moviedb and tvdb to see that they have because that's where they come from. Please let us know if this helps. Thanks.

 

I'm sorry, I don't quite understand what that means in this context. Do you mean I should check somewhere in the server config that they are selected as metadata providers? I know that under the individual library entries I have both providers selected already.

Share this post


Link to post
Share on other sites
plaidstallion
Posted (edited)

Pretty sure you are talking about the know People issue that TMDB created when they were/are doing maintenance deleting a lot of images.

 

https://emby.media/community/index.php?/topic/85934-corrupte-images

 But I can still get the images manually...

 

Edit: Yep same issue. Hmmm. Doesn't seem to be a fix in that thread, quickly scanning through. Except to wipe the install or database and start over. No thanks.

Edited by plaidstallion

Share this post


Link to post
Share on other sites
Happy2Play

Yes, manually pulls a different image id from provider.  The issue as discussed in other topic is Emby will only pull a providerid from provider and only download image once you enter the person details.  So since TMDB has deleted the initial id image and Emby has that id in the database you get the blank place holder.

 

So in the end there has to be a complete purge of all corrupt TMDB people images, but that is not a simple task.

Share this post


Link to post
Share on other sites
plaidstallion
Posted (edited)

Yes, manually pulls a different image id from provider.  The issue as discussed in other topic is Emby will only pull a providerid from provider and only download image once you enter the person details.  So since TMDB has deleted the initial id image and Emby has that id in the database you get the blank place holder.

 

So in the end there has to be a complete purge of all corrupt TMDB people images, but that is not a simple task.

 

Is it detailed in the other thread what the task entails? Even though it's not necessarily Emby's fault, is there any sort of fix planned? Surely this feature would be useful in the future for when something like this inevitably happens again?

 

Edit: I am trying to run the script now. It says in the logs that the plugin is running but I don't think it has grabbed any images so far.

 

I keep getting entries like this for missing thumbs:

2020-05-27 17:18:21.219 Info FixerService: --- NEW SCAN --------------------------------------------------------------------------------------
2020-05-27 17:18:21.219 Info FixerService: GUID dab982ca96a24b0e8df7b62f6563eba4
2020-05-27 17:18:21.219 Info FixerService: Platform is LINUX
2020-05-27 17:18:21.219 Info FixerService: Metadir: /config/metadata/library/da/dab982ca96a24b0e8df7b62f6563eba4
2020-05-27 17:18:21.219 Info FixerService: --------------------------------------------------------------------------------------------------
2020-05-27 17:18:21.219 Info FixerService: ------ Scanning Actor '3' from ' Enemy at the Gates '- (383 People in 476) Movie/Series Records ----
2020-05-27 17:18:21.219 Info FixerService: --------------------------------------------------------------------------------------------------
2020-05-27 17:18:21.219 Info FixerService: People in this Movie/Series: 17
2020-05-27 17:18:21.219 Info FixerService: Name : Ed Harris
2020-05-27 17:18:21.219 Info FixerService: Index : 630
2020-05-27 17:18:21.219 Info FixerService: Primary image Path : https://image.tmdb.org/t/p/original/atzm7ZGRFSWJHQT6qKmzjmNQ9GA.jpg
2020-05-27 17:18:21.871 Info FixerService: Trying Remote Website 1  !
2020-05-27 17:18:21.882 Info FixerService: Nothing Here!
2020-05-27 17:18:21.882 Info FixerService: Trying Remote Website 2  !
2020-05-27 17:18:21.893 Info FixerService: Trying Remote Website 3  !
2020-05-27 17:18:21.904 Info FixerService: Trying Remote Website 4  !
2020-05-27 17:18:21.916 Info FixerService: Trying Remote Website 5  !
2020-05-27 17:18:22.036 Info FixerService: Nothing Here!
Edited by plaidstallion

Share this post


Link to post
Share on other sites
Luke

I'm sorry, I don't quite understand what that means in this context. Do you mean I should check somewhere in the server config that they are selected as metadata providers? I know that under the individual library entries I have both providers selected already.

No I'm saying you may want to check those websites to see if they even have an image for the actor.

Share this post


Link to post
Share on other sites
plaidstallion
Posted (edited)

No I'm saying you may want to check those websites to see if they even have an image for the actor.

 

I mean I assume they do as when I go in and manually search in Emby, an image is found that I can download...

Edited by plaidstallion

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...