Jump to content
Rohanaj

Emby for iOS 1.9.7 Freezing on older iPads

Recommended Posts

Rohanaj

Morning guys,

 

Emby for iOS was continuing to have an issue with pausing and resuming content on older iPads (I have both an iPad 3 and iPad 4 that it would happen on) for quite a while, but the app was still playing content fine as long as you fully backed out of the playback and then resumed that way rather than with the pause button.

 

However, after updating Emby on my iPad 4 (which maxed out at iOS 10.3.3 for operating system and can't upgrade beyond that), attempting to play any type of video content (.mp4, .m4v, .mkv at least are the three I have consistently in my library) results in a start of the video for a second or two and then it pauses the playback on the screen.  Tapping the play button on the screen at that point has the same resume glitch that has been there for a while.

 

So, unfortunately, it seems version 1.9.7 is now stopping at the initial playback even, which has made the app unusable on older iPads.

 

I'll send a server log and two ffmpeg transcode logs to @@Luke in a message so he can get them to any other developer that wants to see them, or I can forward them on additionally if anyone else lets me know they need them as well.

 

-Roh

Share this post


Link to post
Share on other sites
Luke

Hi, is it only when transcoding is needed?

Share this post


Link to post
Share on other sites
Rohanaj

Hi Luke,

 

No, it behaves the same way whether transcoding is needed or direct playing.  I'm messaging you a short server log from just a few minutes ago when I just tried a direct playing attempt as well, in case that helps.

 

-Roh

Share this post


Link to post
Share on other sites
Luke

Ok thanks for the info.

Share this post


Link to post
Share on other sites
RavenDK

Hi,

 

Just wanted to share, that I also have the same issue descripted by Rohanaj.

 

I'm using a Ipad 4 running firmware 10.3.3.

Share this post


Link to post
Share on other sites
Luke

Ok we're looking into it, thanks.

Share this post


Link to post
Share on other sites
kumaheiyama

Ditto. Also Emby 1.9.7, iPad gen 4 and iOS 10.3.3, and I have had this problem since I first installed the app (unknown which version I installed back then, about 4 months ago).

 

The problem got worse with 1.9.7 as now all videos freeze up at the start, before upgrading it would only freeze when I pressed rewind, pause or forward. The only way to unfreeze it in previous versions was to close the app and restart it. Position in video seems to be saved so it was easy to continue where I left off.

 

I have however noticed two workarounds that work even in 1.9.7. The pause/rewind/forward buttons makes the video freeze, but I can still use the slider to move back and forward.

Also, to get the video to play (this is every time when I start watching) I press play, the video starts for two seconds. I press play again and before it freezes I press rewind once. After that it actually starts playing the video.

 

I will try to post a video of this.

Share this post


Link to post
Share on other sites
kumaheiyama

I managed to film a short video of me trying to get Emby to start playing. Wasn't able to upload the mp4 directly so I had to zip it first.

 

As you can see it's difficult to get it to work, but eventually I managed. As soon as I press pause again the freezing symptoms reoccur.

VID-20200605-WA0000.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...