Jump to content


Photo

[Trakt] One episode won't sync playstate and keep being marked as unwatched


  • Please log in to reply
5 replies to this topic

#1 sephrat OFFLINE  

sephrat

    Advanced Member

  • Members
  • 77 posts
  • Local time: 06:10 PM

Posted 17 May 2020 - 04:49 AM

I've got one particular episode that keeps being marked as unwatched in Emby after "Import playstates from Trakt.tv" is executed.

When I set it to "watched" in Emby, it won't sync to Trakt, either after a direct play through scrobble or after setting it manually and running the dedicated task.

 

Episode is Rick and Morty 4x07. IDs in Emby metadata are:

https://www.imdb.com/title/tt10655690/

https://thetvdb.com/...sode&id=7229022

So good so far, except the synopsis retrieved in Emby metadata is just wrong. It's neither the one from IMDB or TVDB. It goes:

Morty meets a new kid called Jack who's in love with an alien called Tom. Rick tries to save him when it turns out the alien isn't who he thinks

Something looks strange in the log:

2020-05-17 10:39:17.697 Debug Trakt: Could not match S0E155 from {"title":"Rick and Morty","year":2013,"ids":{"imdb":"tt2861424","tmdb":60625,"tvdb":275274,"tvrage":33381,"trakt":69829,"slug":"rick-and-morty"}} to any Emby episode, marking for collection removal

In Trakt this episode is set as watched several times when I actually never watched it. I believe Trakt plugin sets this one as watched instead of 4X07.

 

I tried refreshing Emby metadata for that episode several times over the past few days but it doesn't help.

 

Any idea what's wrong? I've had 0 issues for months with other episodes/series/films.

Running Emby 4.5.0.10 with Trakt 3.4.4.0.


Edited by sephrat, 17 May 2020 - 04:51 AM.


#2 sephrat OFFLINE  

sephrat

    Advanced Member

  • Members
  • 77 posts
  • Local time: 06:10 PM

Posted 21 May 2020 - 04:40 AM

I'm still having the issue.

The only fix I found was to set it as watched in Trakt. Syncing Trakt playstates set the episode as watched correctly in Emby.

How come it syncs from one way but not the other?

 

Episode 4x08 worked fine... It's really only that 4x07 episode. 



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156672 posts
  • Local time: 12:10 PM

Posted 22 May 2020 - 10:25 PM

Hi, I would use the emby metadata editor to ensure the episode has the correct season number, episode number, and external IDs.

Please see if this helps. Thanks.

#4 sephrat OFFLINE  

sephrat

    Advanced Member

  • Members
  • 77 posts
  • Local time: 06:10 PM

Posted 23 May 2020 - 02:35 AM

It's all correct. The IDs in my original post came from there.

And then again, if it were not correct, it wouldn't sync correctly from Trakt to Emby, would it?



#5 sephrat OFFLINE  

sephrat

    Advanced Member

  • Members
  • 77 posts
  • Local time: 06:10 PM

Posted 23 May 2020 - 05:18 AM

Giving it a second look, I think the problem lies in Trakt. Both 4x07 and 0x155 have the same TVDB ID in Trakt:

https://trakt.tv/sho...ns/4/episodes/7

https://trakt.tv/sho.../0/episodes/155

Trakt API must pick up the first episode with a matching TVDB ID 7229022, and it so happens to pick the wrong one (0x155).

TVDB actually doesn't list 0x155 (https://www.thetvdb....sons/official/0). 

 

I guess syncing from Trakt to Emby is less random than the other way around and it manages to set 4x07 watched correctly.

 

I guess I'll have to live with it then, since refreshing Trakt metadata seems to be a VIP feature... *sigh*

Thanks for helping.


Edited by sephrat, 23 May 2020 - 05:23 AM.


#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156672 posts
  • Local time: 12:10 PM

Posted 23 May 2020 - 01:13 PM

Thanks for the feedback.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users