Jump to content

Worked for two nights, now doesn't work at all


iveson
 Share

Recommended Posts

iveson

I installed Emby last week as a replacement for Plex. Set up Emby server (MAC, accessing files on a WD My Cloud (not My Cloud Home or dl/pr series), to Roku. Worked like a charm for two nights.

 

This week, I got play back errors (Roku). Troubleshooting: All videos play just fine via Roku Media Player so it's not that. They also play fine on the MAC using QuickTime. But they don't play at all on Emby. I've been working through what I could find on the forums. Today I uninstalled and reinstalled Emby. Same problem. 

 

At a loss...please help.

 

Link to comment
Share on other sites

iveson

Here is zip file of all logs. And screen shot of error message though I'm guessing you're familiar with that.

Link to comment
Share on other sites

Here is zip file of all logs. And screen shot of error message though I'm guessing you're familiar with that.

 

The zip file and screen shot appear to be absent. Hopefully you solved the problem and this is just a stale thread. ;)

 

If you are still having issues are any ffmpeg logs created? Those would be helpful.

Edited by speechles
Link to comment
Share on other sites

2020-05-10 08:11:16.040 Info HttpServer: HTTP Response 200 to ::1. Time: 167ms. http://localhost:8096/emby/Items/1630/PlaybackInfo?UserId=04fc661bdfd64cefaf1a1eaf723689e2&StartTimeTicks=690000000&IsPlayback=true&AutoOpenLiveStream=true&MaxStreamingBitrate=140000000
2020-05-10 08:11:16.396 Info HttpServer: HTTP GET http://localhost:8096/emby/videos/1630/stream.mp4?DeviceId=e5934c1c-18dd-4db7-b57c-d8c48ce19ecd&MediaSourceId=7debcc9a6d4d00c23b33d345df1f5311&Static=true&PlaySessionId=e25004c57ed845f7b6973ebb271f2d1c. Host=localhost:8096, User-Agent=Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:76.0) Gecko/20100101 Firefox/76.0, Accept=video/webm,video/ogg,video/*;q=0.9,application/ogg;q=0.7,audio/*;q=0.6,*/*;q=0.5, Accept-Language=en-US,en;q=0.5, Range=bytes=0-, Connection=keep-alive, Referer=http://localhost:8096/web/index.html
2020-05-10 08:11:16.397 Info HttpServer: HTTP GET http://localhost:8096/emby/Videos/1630/7debcc9a6d4d00c23b33d345df1f5311/Subtitles/1/0/Stream.vtt. Host=localhost:8096, User-Agent=Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:76.0) Gecko/20100101 Firefox/76.0, Accept=*/*, Accept-Language=en-US,en;q=0.5, Accept-Encoding=gzip, deflate, Connection=keep-alive
2020-05-10 08:11:16.413 Error HttpServer: Error processing request
*** Error Report ***
Version: 4.4.2.0
Command line: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll
Operating system: Unix 19.4.0.0
64-Bit OS: True
64-Bit Process: True
User Interactive: True
Runtime: file:///Applications/EmbyServer.app/Contents/MacOS/System.Private.CoreLib.dll
System.Environment.Version: 3.1.2
Processor count: 4
Program data path: /Users/ivesonhome/emby-server
Application directory: /Applications/EmbyServer.app/Contents/MacOS
SharpCifs.Smb.SmbException: SharpCifs.Smb.SmbException: Failed to connect to server
   at SharpCifs.Smb.SmbFile.Connect0()
   at SharpCifs.Smb.SmbFile.QueryPath(String path, Int32 infoLevel)
   at SharpCifs.Smb.SmbFile.Exists()
   at Emby.Server.Implementations.IO.SharpCifsFileSystem.AssertFileExists(SmbFile file, String path)
   at Emby.Server.Implementations.IO.SharpCifsFileSystem.OpenRead(String path)
   at Emby.Server.Implementations.IO.SharpCifsFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share)
   at Emby.Server.Implementations.IO.IOManager.GetResponse(HttpRequestOptions options, MediaProtocol protocol)
   at Emby.Server.Implementations.IO.IOManager.GetResponse(HttpRequestOptions options)
   at Emby.Server.Implementations.HttpServer.HttpResultFactory.GetContent(StaticFileResultOptions options, Int64 offset, Int64 length, CancellationToken cancellationToken)
   at Emby.Server.Implementations.HttpServer.FileWriter.SetContentResponseHeaders(Nullable`1 reportedTotalContentLength, CancellationToken cancellationToken)
   at Emby.Server.Implementations.HttpServer.HttpResultFactory.GetStaticResult(IRequest requestContext, StaticResultOptions options)
   at Emby.Server.MediaEncoding.Api.Progressive.BaseProgressiveStreamingService.ProcessRequest(StreamRequest request, Boolean isHeadRequest)
   at Emby.Server.Implementations.Services.ServiceController.GetTaskResult(Task task)
   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, RestPath restPath, String responseContentType, CancellationToken cancellationToken)
   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, ReadOnlyMemory`1 urlString, ReadOnlyMemory`1 localPath, CancellationToken cancellationToken)
SharpCifs.Util.Sharpen.UnknownHostException: WDMYCLOUD<20>
   at SharpCifs.Netbios.NbtAddress.DoNameQuery(Name name, IPAddress svr)
   at SharpCifs.Netbios.NbtAddress.GetByName(String host, Int32 type, String scope, IPAddress svr)
   at SharpCifs.UniAddress.GetAllByName(String hostname, Boolean possibleNtDomainOrWorkgroup)
   at SharpCifs.Smb.SmbFile.GetFirstAddress()
   at SharpCifs.Smb.SmbFile.Connect()
   at SharpCifs.Smb.SmbFile.Connect0()
 
Source: Emby.Server.Implementations
TargetSite: Void Connect0()
 
2020-05-10 08:11:16.413 Info HttpServer: HTTP Response 500 to ::1. Time: 17ms. http://localhost:8096/emby/videos/1630/stream.mp4?DeviceId=e5934c1c-18dd-4db7-b57c-d8c48ce19ecd&MediaSourceId=7debcc9a6d4d00c23b33d345df1f5311&Static=true&PlaySessionId=e25004c57ed845f7b6973ebb271f2d1c

It seems to be an issue with SMB paths/permissions.

The exact error is: Failed to connect to server.

Edited by speechles
Link to comment
Share on other sites

  • 1 month later...
iveson

Yes. I gave up on it weeks ago as the only reply I got was the incomprehensible one on May 15. I know it is code but that is not helpful to me as I'm not a programmer. I went back to Plex. 

Link to comment
Share on other sites

  • 4 weeks later...

Have you reset your path & permissions correctly and retried Emby?

Link to comment
Share on other sites

  • 2 weeks later...

The issue looks like the Emby user doesn't have access to the share. It doesn't have permission to execute which is required to "play" them. You might have forgot to set +X on the directory?

SharpCifs.Util.Sharpen.UnknownHostException: WDMYCLOUD<20>
Edited by speechles
  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
On 8/4/2020 at 4:02 PM, iveson said:

No.

Your log suggests you're added an smb share. How many emby libraries have you created? What folders have you added to each one? 

You could also try the beta server if you're still having an issue. Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...