Jump to content


Photo

High CPU consumption

rpi

  • Please log in to reply
7 replies to this topic

#1 elitearmedforce OFFLINE  

elitearmedforce

    Newbie

  • Members
  • 5 posts
  • Local time: 09:42 PM

Posted 09 May 2020 - 03:55 PM

#####Specs of Hardware used######

RPi 3 B+

OS: DietPi v6.29.2

Server installed in RPi 3 b+

Client: Mobile browser, Mobile app & PC browser

Browser: Chrome latest version

Emby App latest.

Test done using "htop" command

###################################

Attached Documents(Below)

Using emby app (Mobile using emby app.jpg)

Chrome mobile browser (Mobile with browser_2.jpg ....)

Chrome PC (browser)

Video details

##################################

 

This rpi3 b+ is used for media server. I play various videos independent of the of its codec. Most of the time, i play H264 videos, as rpi3 b+ fails to play high bit videos of AVC/H 265 and often experience poor video playback. So, i planned to purchase new rpi 4 as it supports h265, but i stumbled upon something yesterday.

I noticed that I was able to play Naruto episodes in emby mobile app smoothly without laggy playback issues that i used to get in using chrome(for video specs detail, check below)(screenshot attached below)

 

Can anyone explain, how to fix this? and explain the problem?

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156672 posts
  • Local time: 01:42 PM

Posted 09 May 2020 - 04:41 PM

Hi, is it transcoding? You'll probably see high cpu usage during video transcoding, that would be normal.



#3 MicuNep OFFLINE  

MicuNep

    Newbie

  • Members
  • 1 posts
  • Local time: 12:12 AM
  • LocationBurma

Posted 09 May 2020 - 06:20 PM

emby.media cialis online con paypalcomprar cialis online sin receta cialis online london levitra cialis onlinebuy female cialis online cheap

#4 elitearmedforce OFFLINE  

elitearmedforce

    Newbie

  • Members
  • 5 posts
  • Local time: 09:42 PM

Posted 09 May 2020 - 09:31 PM

Hi, is it transcoding? You'll probably see high cpu usage during video transcoding, that would be normal.

Hello @Luke. Yes i believe it is transcoding, but this doesn't make sense that when using Emby mobile app it uses less cpu usage. Weird part is that, same video when streamed using same mobile through browser uses high cpu usage(all cores of rpi) and it goes the same for Tv and PC. This thing doesnt make sense and i dont even understand why. I hope u got my question now?


Edited by elitearmedforce, 09 May 2020 - 09:32 PM.


#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156672 posts
  • Local time: 01:42 PM

Posted 09 May 2020 - 10:52 PM

It's normal. Browsers have limited media format support, which means you will see more transcoding when playing from the browser than you will with our android app.



#6 elitearmedforce OFFLINE  

elitearmedforce

    Newbie

  • Members
  • 5 posts
  • Local time: 09:42 PM

Posted 10 May 2020 - 01:43 AM

Interesting, I didn't know that media support in browsers matter. Thank you for the information. In that case, i would really prefer to use app/executable for linux/windows(ubuntu/raspbain/windows10). More like extra work for devs.



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156672 posts
  • Local time: 01:42 PM

Posted 10 May 2020 - 01:53 AM

Then you might like this:

https://emby.media/c...ater-for-linux/



#8 elitearmedforce OFFLINE  

elitearmedforce

    Newbie

  • Members
  • 5 posts
  • Local time: 09:42 PM

Posted 10 May 2020 - 02:14 AM

Then you might like this:

https://emby.media/c...ater-for-linux/

Nice, didn't know this even exist. Thanks man, i will be trying it out.







Also tagged with one or more of these keywords: rpi

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users