Jump to content
DJIemby

Kodi - Subtitles not working on Nvidia Shield

Recommended Posts

DJIemby

I was wondering if anyone else who is using an Nvidia Shield is having problems with Subtitles showing on Movies when playing through Kodi app?

I have tried several other movies with subtitles and all are not working. It seems this is a recent thing as it used to work. The same movie/s work in Emby app and even on other media boxes in the home e.g Xiaomi Mi box.

 

I have tried installing the latest Emby Android TV Beta release (1.8.00) thinking it might update something to work but still the same.

 

Anything i can try as i have searched forums and doesn't seem to be a problem for anyone else with embedded subtitles in their .mkv files.

 

On initial tests, it seems PGS subtitles work but SRT subtitles dont. They are both set to be on upon playback but Kodi is not showing SRT subtitles. I have checked when in playback and it states that the subtitle is on but no visual subtitles show on screen. I am on version 4.1.19 Emby for Kodi version.

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites
Luke

Hi there, can we please look at an example? Please attach the information requested in how to report a media playback issue. thanks !

Share this post


Link to post
Share on other sites
DJIemby

Hi Luke, no problem. I will play same file in Kodi and within the Emby App on the Shield and supply the 'embyserver.txt' file. Do i need to enable debug logging before i do the tests from with the Emby web gui?

Share this post


Link to post
Share on other sites
Luke

You might as well. Just make sure to disable that when you're done. Thanks.

Share this post


Link to post
Share on other sites
DJIemby
Posted (edited)

Hi Luke, please find my Emby Server log. 

Here is what i tried on the Nvidia Shield:

 

(1) Played 'Ip Man 1' on Emby App. Result: Video & Audio Played as it should with English subtitles showing

 

(2) Played 'Ip Man 4' on Emby App. Result: Video & Audio Played as it should with English subtitles showing

 

(3) Played 'Ip Man 1' through Kodi. Result: Video & Audio Played as it should but English subtitles were not showing. I paused playback and switched subtitles on as it was off. Kodi recognised that file had English subtitles and upon playback, subtitles showed.

 

(4) Played 'Ip Man 4' through Kodi. Result: Video & Audio Played as it should but English subtitles were not showing. I paused playback and switched subtitles on as it was off. Kodi recognised that file had English subtitles but upon playback it still did not show.

 

Hope you can help and suggest a workaround.

embyserver.txt

Edited by DJIemby

Share this post


Link to post
Share on other sites
Luke

What format are the subtitles in Ip Man 4?

Share this post


Link to post
Share on other sites
DJIemby

Ip Man 4 subtitles are: SRT

Ip Man 1 subttiles are: PGS

Share this post


Link to post
Share on other sites
Luke

Can you attach the kodi log from that Ip man 4 test? thanks.

Share this post


Link to post
Share on other sites
DJIemby

Hi Luke, i have tried playing Ip Man 4 now with Kodi debugging enabled. Please find attached the Kodi log file.

kodi.log.txt

Share this post


Link to post
Share on other sites
ulrick65

I am having this same issue.  External subtitle in SRT format don't play in Kodi using the Add In.  I have an Nvidia Shield as well.  Embedded subtitles play fine and it seems that if both embedded and external exist, I can switch between them sometimes and the external wiil play.  However, when there is just external...they don't show.

 

They play fine on the Emby Web App.  Also, they do "show up" in Kodi as being there and selected when I go to the subtitles selections, they just do not play.

 

Any update on this issue?  Anything I can do to send logs to help or identify it?

 

Thanks.

Share this post


Link to post
Share on other sites
CHA0SENG7NE

Hi

Glad I found this thread.

Im struggling with the same issue,

I have SRT subtitles and 50% of the time they dont display when enabled.

The only workaround as mentioned is to download another subtitle within Kodi and then switch back???

Share this post


Link to post
Share on other sites
Luke

We'll take a look at this. Thanks for reporting.

Share this post


Link to post
Share on other sites
DJIemby

Hi Like, any updates on this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...