Jump to content

Playback Reporting


TeamB
 Share

Recommended Posts

TeamB

thanks for testing, if you see any inconsistencies or differences with the old version let me know.

Link to comment
Share on other sites

DarWun

After updating to 1.9.0.1 the pie charts on the Breakdown screen appear to be okay (i.e. the pie charts on the left show number of times played and the ones on the right show total time played). But the information listed below the ones on the right is number of times played instead of play time.

Edited by DarWun
  • Like 1
Link to comment
Share on other sites

TeamB
8 hours ago, DarWun said:

After updating to 1.9.0.1 the pie charts on the Breakdown screen appear to be okay (i.e. the pie charts on the left show number of times played and the ones on the right show total time played). But the information listed below the ones on the right is number of times played instead of play time.

Ok thanks, i will look into it.

  • Thanks 1
Link to comment
Share on other sites

TeamB
10 hours ago, DarWun said:

After updating to 1.9.0.1 the pie charts on the Breakdown screen appear to be okay (i.e. the pie charts on the left show number of times played and the ones on the right show total time played). But the information listed below the ones on the right is number of times played instead of play time.

fixed in version 1.9.0.2

  • Thanks 1
Link to comment
Share on other sites

seanbuff

Everything appears to be working fine in 1.9.0.2

The only noticeable UI difference I can see is the size of the pie charts, updated version are much larger than previously.

Previous version:
image.png.75ea2281d9e5a6afa58111d2c587506b.png

 

Updated version:
image.png.12a46311c5282baf475d8a52bf0cd1b5.png

Functionality wise, they all appear to be working correctly thanks.

  • Agree 1
Link to comment
Share on other sites

TeamB
9 minutes ago, seanbuff said:

Everything appears to be working fine in 1.9.0.2

The only noticeable UI difference I can see is the size of the pie charts, updated version are much larger than previously.

Previous version:
image.png.75ea2281d9e5a6afa58111d2c587506b.png

 

Updated version:
image.png.12a46311c5282baf475d8a52bf0cd1b5.png

Functionality wise, they all appear to be working correctly thanks.

Ok I will have a look at that.

Link to comment
Share on other sites

seanbuff
2 hours ago, TeamB said:

1.9.0.3 should fix the pie chart size issue

The size of the charts are good now, however at the risk of sounds really pedantic - the spacing between the 2 charts is still really tight

image.png.380fc45793ba9584e82bc7cbf888c5f7.png

 

Unlike the spacing that they used to have in previous 1.8.x.x versions

image.png.c66f3d7ff6d4ef57fc174b0cc431c8f0.png

Appreciate your work 👌🏽

  • Like 1
Link to comment
Share on other sites

DarWun

@TeamBFYI I just noticed that the "Other" setting on the Breakdown page no longer works after updating to 1.9.0.3.

Link to comment
Share on other sites

DarWun
1 hour ago, DarWun said:

@TeamBFYI I just noticed that the "Other" setting on the Breakdown page no longer works after updating to 1.9.0.3.

@TeamBPlease ignore this. I rebooted the server for non-emby reasons. When Emby restarted, the "Other" setting was working as expected. I'll post back if that changes. Sorry for the false alarm.

Edited by DarWun
Link to comment
Share on other sites

Dreakon13
On 6/15/2021 at 7:53 AM, TeamB said:

I have released a new version with the ability to save custom queries and also charting options to the custom query page.

Not to seem unappreciative, I just noticed this and that's awesome.  Such a quick turnaround, love it!  Thank you!

  • Like 1
Link to comment
Share on other sites

seanbuff
On 22/06/2021 at 14:21, TeamB said:

version 1.9.0.4

Small changes to the layout of the breakdown page.

Wow just noticed this now. Everything is perfect again 👌🏽

Appreciate your efforts @TeamB cheers!

  • Like 1
Link to comment
Share on other sites

rbjtech

This plugin is a must have for the serious emby user.  I use in conjunction with the email plugin & Notifications to send reports generated by the plugin - fantastic.

So a big thumbs up from me 👍  

Link to comment
Share on other sites

  • 3 weeks later...
hugo.lapointe

Sorry if this isn't the right place to ask for help.

Since the last update of the plugin (1.9.0.0), the plugin doesn't to be supported anymore. It's like if a uninstalled the plugin and when I try to reinstalled, nothing work. What can I do? Which logs would you want?

Link to comment
Share on other sites

Happy2Play
20 minutes ago, hugo.lapointe said:

Sorry if this isn't the right place to ask for help.

Since the last update of the plugin (1.9.0.0), the plugin doesn't to be supported anymore. It's like if a uninstalled the plugin and when I try to reinstalled, nothing work. What can I do? Which logs would you want?

Would need to see a server log but the current plugin is version 1.9.0.4.  I can't even get version 1.9.0.0 anymore.

pr.jpg.5b5492286eaf32c913e11c4e9f885270.jpg

Edited by Happy2Play
Link to comment
Share on other sites

hugo.lapointe

Yes, several tries and you're right, I did try to install the version (1.9.0.4)... but nothing happen.

 

Here's the latest server logs.

embyserver.txt

Link to comment
Share on other sites

Happy2Play
3 minutes ago, hugo.lapointe said:

Yes, several tries and you're right, I did try to install the version (1.9.0.4)... but nothing happen.

 

Here's the latest server logs.

embyserver.txt 76.1 kB · 0 downloads

Sorry is there a reason you are on server 4.5.4.0 and not the current 4.6.4.0?

This current plugin version will not run and previous server version so you would have to potentially find a previous plugin version as it looks like it was superseded via versioning.

Hard to tell what plugin but as you can see it can no load as it is not compatible.

2021-07-16 22:42:18.959 Error App: LoaderException: Could not load file or assembly 'MediaBrowser.Controller, Version=4.6.0.50, Culture=neutral, PublicKeyToken=null'. The system cannot find the file specified.

 

Link to comment
Share on other sites

  • 1 month later...
InaudibleDirge

is it possible for the playlists generated by the plugin to be created with artwork? manually adding the artwork doesn't stick since they are deleted and re-generated every day

Link to comment
Share on other sites

InaudibleDirge
On 8/28/2021 at 2:27 PM, TeamB said:

The plugin just calls the create playlist server function and passes in a list if ids

https://github.com/faush01/playback_reporting/blob/e0d169459a5c3177355e5aa924eeda67cb0ce3c3/playback_reporting/Tasks/TaskCreatePlaylists.cs#L153

It does not need to set any artwork, the server does that.

interesting. every time i manually set the artwork from the server, it's deleted the next time the playlist task is run

Link to comment
Share on other sites

Happy2Play
Just now, InaudibleDirge said:

interesting. every time i manually set the artwork from the server, it's deleted the next time the playlist task is run

Yes I tested this and it would appear the current playlist is deleted and a new playlist is created, so custom image is lost.

I can have the playlist folder open and see the playlist get deleted and recreated when the task runs.

Link to comment
Share on other sites

TeamB

it looks like the .CreatePlaylist() call actually deletes the old playlist and creates a new one. This is probably why you see your custom art disappear.

Sorry but I dont think I can do anything about this.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...