Jump to content
JZStudios

ANSWERED How to get Emby to display embedded album artwork?

Recommended Posts

JZStudios

Seems like this gets brought up a lot and there doesn't seem to be a step by step guide, so I'm asking again.

I just set up Emby to handle music files only (any other setup tips would be welcome) and had it sort through the library, it's been a few days since then and it's still not displaying embedded artwork, so I don't know if I missed a setting somewhere or not.

 

So to go through the motions, here's my step by step.

  1. I've manually combed through all of my music with MusicBrainz Picard and mp3tag. I have correct tags for everything, and most importantly, correct album cover art. On a different thread I read that there might be some confusion between id3v1 and id3v2.3, but looking in the extended tags in mp3tag, there's nothing with duplicates that should cause any confusion. I'm pretty sure I have Picard set to erase all the metadata and only rewrite it with new values, so v1 and v2.3 should be identical for everything, and was for the few albums I checked.
  2. Installed Emby, a crucial step.
  3. When setting up the music library, I turned off all metadata providers. The library settings, with the advanced options, only has real time monitoring enabled. Everything else is unticked, with "Automatically refresh metadata from the internet" set to Never.
  4. Library scan.
  5. No or incorrect artwork shown. For having the metadata and all providers disabled, it's still finding a few album covers, which are noticeably different from the embedded files, and mp3tag only shows the single image I've put in.

Did I miss something? There's no obvious tick box in the library setup saying "Read embedded metadata"

Share this post


Link to post
Share on other sites
PenkethBoy

1. what file type(s)

2. Any images in the album folder along with the songs?

3. emby does read the embeded images for me from mp3 files even with metadata downloaders enabled

 

Do you have image extractor enabled for Audio Images - if not that will be why you are not getting images pulled from the songs

  • Like 1

Share this post


Link to post
Share on other sites
JZStudios

1. what file type(s)

2. Any images in the album folder along with the songs?

3. emby does read the embeded images for me from mp3 files even with metadata downloaders enabled

 

Do you have image extractor enabled for Audio Images - if not that will be why you are not getting images pulled from the songs

  1. Multiples, but primarily .mp3
  2. No, it's all embedded. I deleted any images that were in the folders.
  3. ..is not a question.

Negative, the only option I have checked is real time monitoring. I can try checking that box and doing a rescan.

Share this post


Link to post
Share on other sites
PenkethBoy

Thats your problem then - you told emby not to extract images

Share this post


Link to post
Share on other sites
JZStudios

Thats your problem then - you told emby not to extract images

After doing a very clunky deletion of the library and a rescan... it's kind of mostly working? Anything that didn't manage to pull low res album art out of thin air has "proper" (Emby downsizes to a very compressed 600x600) but anything that had low res ~200px album art is still present for some reason and doing a "Refresh Metadata" doesn't pull in the proper album art, I had to manually delete the image and then rescan, which is going to be annoying to do for any volume of covers.

Still, I guess the majority are probably fine.

Share this post


Link to post
Share on other sites
Luke

Glad you figured it out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...