Jump to content
Asaki

WAN inaccessible

Recommended Posts

Asaki

Bonjour, je rencontre un problème suite à l'installation de emby server sur mon Raspberry Pi 4 (4GB).

Emby est inaccessible en dehors du réseau local (inaccessible en WAN, je ne peu donc pas y accéder depuis un appareil non connecter sur le réseaux local).

 

 
J'ai installé cette version de emby server :
 
Ubuntu Armv7 (armhf) - BETA
  1. Download emby-server-deb_4.5.0.6_armhf.deb
  2. dpkg -i emby-server-deb_4.5.0.6_armhf.deb
  3. Open a web browser to http://localhost:8096

 

Puis cette version pensant que c'était surement dû à la beta :

 

Ubuntu Armv7 (armhf)
  1. Download emby-server-deb_4.4.2.0_armhf.deb
  2. dpkg -i emby-server-deb_4.4.2.0_armhf.deb
  3. Open a web browser to http://localhost:8096

Ça n'a rien changé, j'ai donc pensé que c'était un problème de port.

J'ai ouvert les ports en allant sur le site http://livebox/. J'ai mit :

- Web Server (HTTP) dans la colonne application/service.

- 80 dans les colonnes port interne et externe (j'ai aussi essayé 8096).

- TCP/UDP dans la colonne protocole.

- L'ip de mon raspberry dans la colonne appareil.

A noter aussi que j'ai mit une ip statique (dans la partie DHCP) pour le raspberry.

Je vois vraiment pas quoi faire d'autre, si il y en a qui ont des solutions je suis preneur.

Cordialement.

Share this post


Link to post
Share on other sites
chacawaca

si le serveur roule sur le port 8096, dans ton routeur du doit configurer le même port. Le port 80 ne fonctionnera pas.

  • Like 1

Share this post


Link to post
Share on other sites
Asaki
Posted (edited)

J'ai déjà essayé, ça n'a rien changé et je trouve bizarre de devoir le configurer car sur mon pc Windows 10 je n'ai jamais eu à configurer les ports et pourtant ça à toujours fonctionné. J'utilise le même réseau.

Je pense pas que ça change grand chose mais le disque dur qui me sert de stockage pour les films/séries qui sont sur Emby, est branché sur le Raspberry mais il est aussi partagé par le raspberry aux pc du réseau local (avec Samba).

Edited by Asaki

Share this post


Link to post
Share on other sites
Luke

Did you configure port forwarding in your router?

  • Like 1

Share this post


Link to post
Share on other sites
chacawaca
Posted (edited)

ton windows 10 est sur ton réseau local il passe par les ports lan de ton routeur donc aucun firewall, quand tu veux y accéder de l'extérieur tu n'a pas le choix de faire un foward de port sur ton routeur vers ton raspberry pi sinon jamais ca ne va marcher.

 

https://support.emby.media/support/solutions/articles/44001159601-hosting-settings

https://support.emby.media/support/solutions/articles/44001159258-advanced-menu

Edited by chacawaca
  • Like 1

Share this post


Link to post
Share on other sites
Asaki

Nickel ça à marché, c'était bien un problème de port. Il suffisait d'ouvrir les ports avec cette configuration :

- Web Server (HTTP) dans la colonne application/service.

- 8096 dans les colonnes port interne et externe.

- TCP/UDP dans la colonne protocole.

- L'ip de mon raspberry dans la colonne appareil.

Je mettais trompé au niveau de la colonne application/service.
Merci beaucoup pour votre aide et votre réactivité ^^.

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...