Jump to content
JulesC

Double Router Port Forwarding Not Working

Recommended Posts

JulesC

Port Forwarding is new to me, so I would greatly appreciate any assistance. I've read many posts and viewed videos on this topic, but still not able to get it to work.

 

Here is my 2-Router setup:

 

ISP Router/Modem [Zyxel VMG 4381-b10a]

LAN IP: 192.168.200.1

WAN IP: 50.5.xxx.xxx

 

Linksys Router/Wifi [EA8300]

LAN IP: 192.168.1.1

WAN IP: 192.168.200.216

 

Emby Server

LAN IP: 192.168.x.x

 

I'm trying to forward 8096 on ISP Router (LAN IP)  -- to Linksys Router (WAN IP) -- Emby Server (LAN IP) and it "appears" to work. However, when I test the port (8096) on CanYouSeeMe.org, it displays the WAN IP Address from my ISP Router/Modem and I get an Error: "I could not see you service on 50.5.xxx.xxx".

 

I'm sure as a newbie to this that I'm doing something wrong, but I haven't been able to figure it out.  Any suggestions on how I can get this working would be greatly appreciated. Let me know if you need any additional information. Thank you.

Share this post


Link to post
Share on other sites
denz
Posted (edited)

This is double NAT situation there was a thread about this subject few months ago. I am just trying to find it. 

 

You have checked that you have port forward 8096 on your isp router to 192.168.200.216 and then to your emby server. 

 

https://emby.media/community/index.php?/topic/82785-connectivity-port-forwarding/?hl=%2Bport+%2Bforwarding

 

Have a look through this thread it should help. If not there are many very smart users that will help with this. 

Edited by denz

Share this post


Link to post
Share on other sites
Luke

@@Happy2Play may know of other topics as well. Thanks.

Share this post


Link to post
Share on other sites
maegibbons
Posted (edited)

The first question that has to be asked is why have you set your network up like this rather than keeping it as one layer 2 network?

 

Is this deliberate and if so why?

 

Lets sort the basics out first.

 

Krs

 

Mark

 

A 'like' is always appreciated!

Edited by maegibbons
  • Like 1

Share this post


Link to post
Share on other sites
JulesC

This is double NAT situation there was a thread about this subject few months ago. I am just trying to find it. 

 

You have checked that you have port forward 8096 on your isp router to 192.168.200.216 and then to your emby server. 

 

https://emby.media/community/index.php?/topic/82785-connectivity-port-forwarding/?hl=%2Bport+%2Bforwarding

 

Have a look through this thread it should help. If not there are many very smart users that will help with this. 

 

Yes, I have port forward 8096 on my ISP Router to 192.168.200.216 and to my Emby Server. Thanks for the link, I've based everything that I've done so far on this link.

 

However, I have no idea why when I test the port (8096) on CanYouSeeMe.org, it displays the WAN IP Address from my ISP Router/Modem and I get an Error: "I could not see you service on 50.5.xxx.xxx". Any help from the experts, would be appreciated. Thank you.

Share this post


Link to post
Share on other sites
JulesC

The first question that has to be asked is why have you set your network up like this rather than keeping it as one layer 2 network?

 

Is this deliberate and if so why?

 

Lets sort the basics out first.

 

Krs

 

Mark

 

A 'like' is always appreciated!

 

The ISP Router brings in the Internet into my home and I have the second Router (Linksys Router/Wifi [EA8300]) for my Wifi. The WiFi from the ISP Router is very poor quality.  

Share this post


Link to post
Share on other sites
JulesC

@@Happy2Play may know of other topics as well. Thanks.

 

@@Happy2Play, I would appreciate any assistance that you can provide.

Share this post


Link to post
Share on other sites
Happy2Play

Have you tried connecting directly to the "ISP Router/Modem" and port forward to the system and get it to work?  If that does not work you would need to took at all firewalls and security software or possibly your ISP itself.  It it works off router 1 then stepping to router to should be pretty straight forward.

Share this post


Link to post
Share on other sites
JulesC

Have you tried connecting directly to the "ISP Router/Modem" and port forward to the system and get it to work?  If that does not work you would need to took at all firewalls and security software or possibly your ISP itself.  It it works off router 1 then stepping to router to should be pretty straight forward.

 

Thanks @@Happy2Play. I will try to directly connect to the "ISP Router/Modem" and port forward to Router 2 (Linksys Router/Wifi [EA8300]) and then onto my Emby Server. What should I look at on the Firewalls (Router 1, Router 2, Windows Firewall) to possibly change? I'm just so perplexed when I test the port (8096) on CanYouSeeMe.org, it displays the WAN IP Address from my ISP Router/Modem and I get an Error: "I could not see you service on 50.5.xxx.xxx". Why is it looking at this IP? Greatly appreciate your help.

Share this post


Link to post
Share on other sites
maegibbons

The ISP Router brings in the Internet into my home and I have the second Router (Linksys Router/Wifi [EA8300]) for my Wifi. The WiFi from the ISP Router is very poor quality.

Thats not a reason.

 

On the linksys just disable dhcp and plug a cable from one of the LAN ports to the Zyzel. Ignore WAN port on linksys

 

Optionally change the LAN ip of linksys to 192.168.200.2 if you still want to manage it.

 

The zyzel will issue dhcp to wired and wireless clients on the layer 2 LAN

 

You have just changed operation of linksys from Router to.Access point.

 

Most important point is to disable dhcp on linksys.

 

All devices will then be on the 192.168.200.x subnet.

 

Krs

 

Mark

 

A 'like' is always appreciated!

Share this post


Link to post
Share on other sites
JulesC
Posted (edited)

Thats not a reason.

 

On the linksys just disable dhcp and plug a cable from one of the LAN ports to the Zyzel. Ignore WAN port on linksys

 

Optionally change the LAN ip of linksys to 192.168.200.2 if you still want to manage it.

 

The zyzel will issue dhcp to wired and wireless clients on the layer 2 LAN

 

You have just changed operation of linksys from Router to.Access point.

 

Most important point is to disable dhcp on linksys.

 

All devices will then be on the 192.168.200.x subnet.

 

Krs

 

Mark

 

A 'like' is always appreciated!

 

@@maegibbons Thank you for these suggestions. I will definitely try this out and report back my learnings. 

 

FYI - I forgot to mention that our home has a hard-wired network and my Router 2 is plugged into my Network Switch. Does this change your suggestions?

 

 Will this fix CanYouSeeMe.org, displaying the WAN IP Address from my ISP Router/Modem where I get an Error: "I could not see you service on 50.5.xxx.xxx". Just not sure why it's looking at this IP. Thanks again.

Edited by JulesC

Share this post


Link to post
Share on other sites
Q-Droid
Posted (edited)

Thanks @@Happy2Play. I will try to directly connect to the "ISP Router/Modem" and port forward to Router 2 (Linksys Router/Wifi [EA8300]) and then onto my Emby Server. What should I look at on the Firewalls (Router 1, Router 2, Windows Firewall) to possibly change? I'm just so perplexed when I test the port (8096) on CanYouSeeMe.org, it displays the WAN IP Address from my ISP Router/Modem and I get an Error: "I could not see you service on 50.5.xxx.xxx". Why is it looking at this IP? Greatly appreciate your help.

 

Your WAN IP address as assigned to the Zyxel is the only address visible to the internet and the only one CanYouSeeMe or anyone can reach.

 

What else is connected to the Zyxel router in addition to the Linksys?

 

You have some options:

1. If allowed you might be able to put the Zyxel modem/router in bridged mode. It bypasses the internal router and your Linksys becomes the primary router obtraining the public WAN IP. The Zyxel operating as a modem only. You have xDSL service so I don't know if there are restrictions or problems in doing this as opposed to, for example, Cable or Fiber based service. It also means going forward the one and only thing connected to the Zyxel should be the Linksys.

 

2. Create a DMZ in the Zyxel going to the Linksys router. Then all unsolicited traffic and connections to the WAN IP on the Zyxel get forwarded to the Linksys. Effectively a wide open port forwarding rule from one router to the other. The Linksys WAN port IP should be static for this.

 

3. Keep things as they are now but make sure you understand that the public IP is the Zyxel, not the Linksys, and any changes related to port forwarding in one have to be done on the other. And the Linksys should have a static WAN port IP.

Edited by Q-Droid

Share this post


Link to post
Share on other sites
Q-Droid

The AP option from @@maegibbons is another good one that resolves the double-NAT and subnets issue.

Share this post


Link to post
Share on other sites
JulesC
Posted (edited)

@@maegibbons I’ve disabled DHCP on Router 2 (LINKSYS Router WiFi). I plugged a cable from my ISP Router to an Ethernet Port (vs WAN) port on Router 2. I have a cable from Router 2 to my Network Switch. Now, I have no Internet on my home network jacks.

Am I doing something wrong? Thank you for your help

Edited by JulesC

Share this post


Link to post
Share on other sites
pwhodges

I would cable ISP router to switch first and get the Internet going; then cable the Linksys to the switch and go through the settings to get it working as a wifi access port.  I'm not familiar with Linksys routers, so I can't guide you further with that; but as a guess I'd use an internal network port, not the WAN port.

 

Paul

Share this post


Link to post
Share on other sites
maegibbons

As Paul says.

 

Zyzel goes to switch. You should have internet.

 

Linksys plugs in to switch from LAN port as wireless extension.

 

Krs

 

Mark

 

A 'like' is always appreciated!

Share this post


Link to post
Share on other sites
rbjtech

..or plug Linksys into 2nd ethernet port on the Zyzel.  Then if you lose the switch for whatever reason, then you'll still have wireless.

Share this post


Link to post
Share on other sites
maegibbons

..or plug Linksys into 2nd ethernet port on the Zyzel. Then if you lose the switch for whatever reason, then you'll still have wireless.

That was the original suggestion and he lost wired access. So NEW suggestion is to connect switch to zyzel as 1st step and PROVE internet to wired drops.

 

Krs

 

Mark

 

A 'like' is always appreciated!

  • Like 1

Share this post


Link to post
Share on other sites
rbjtech
Posted (edited)

That was the original suggestion and he lost wired access. So NEW suggestion is to connect switch to zyzel as 1st step and PROVE internet to wired drops.

 

Krs

 

Mark

 

A 'like' is always appreciated!

 

Right, with you.  So if he loses 'wired' when he plugs the Linksys in (via the switch OR direct to the Zyxel) then I'd imagine conflicting DHCP would be the primary reason.

Edited by rbjtech

Share this post


Link to post
Share on other sites
JulesC

To ALL who have contributed to my "Double Router" network challenge, thank you so much for your input.

 

I have Internet to all my connected devices - Yeah!

 

I was able to Port Forward from the Zyxel ISP Router directly to my Emby Server - Yeah!

 

I still have the issue where when I check my Port against CanYouSeeMe.org, it's still displaying the WAN IP Address from my ISP Router/Modem where I get an Error: "I could not see your service on 50.5.xxx.xxx"

 

As for my Linksys WiFi Access Point (DHCP disabled on this device), I have WiFi connections working, but I'm unable to access the Console if I wanted to change any configurations.

 

Sorry for all the issues I'm encountering, but I greatly appreciate your help. THANK YOU

Share this post


Link to post
Share on other sites
pwhodges

I still have the issue where when I check my Port against CanYouSeeMe.org, it's still displaying the WAN IP Address from my ISP Router/Modem where I get an Error: "I could not see your service on 50.5.xxx.xxx"

 

I wonder if your ISP is using NAT  internally ("Carrier-grade NAT") and this is confounding things somehow.

 

Paul

Share this post


Link to post
Share on other sites
maegibbons
Posted (edited)

Hi. Sounds good. Ref getting in to the linksys router, did you do this bit:

 

"Optionally change the LAN ip of linksys to 192.168.200.2 if you still want to manage it."

 

From the instructions above?

 

Krs

 

Mark

 

A 'like' is always appreciated!

Edited by maegibbons

Share this post


Link to post
Share on other sites
JulesC

Hi. Sounds good. Ref getting in to the linksys router, did you do this bit:

 

"Optionally change the LAN ip of linksys to 192.168.200.2 if you still want to manage it."

 

From the instructions above?

 

Krs

 

Mark

 

A 'like' is always appreciated!

 

@@maegibbons Yes, I changed the LAN IP for the Linksys (192.168.200.43) to be inline with the Zyxel Router, and I'm able to access the Linksys Control Screen so I can make configuration changes if needed. The Linksys is setup as an Access Point (No DHCP) - thanks to your guidance. 

 

Now, my last problem to address (YEAH!!!) - I still have the issue where when I check the Port I forwarded against CanYouSeeMe.org, it's still displaying the WAN IP Address where I get an Error: "I could not see your service on 50.5.xxx.xxx"

Any ideas?

Share this post


Link to post
Share on other sites
Q-Droid

CanYouSeeMe is supposed to show the WAN IP. Are you putting in the correct port (8096) at the site?

Share this post


Link to post
Share on other sites
JulesC

CanYouSeeMe is supposed to show the WAN IP. Are you putting in the correct port (8096) at the site?

@@Q-Droid Yes I entered 8096.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...