Jump to content
Sign in to follow this  
sliderbot

Emby Guide Data Won't Map for Ceton Tuners

Recommended Posts

sliderbot

I can use the tuners under Live TV, but in the guide data setup, the mapping utility brings up no information--even if left for some time.

Share this post


Link to post
Share on other sites
Luke

Hi, how did you import the tuners?

Share this post


Link to post
Share on other sites
sliderbot
Posted (edited)

WMC->ServerWMC->Emby. The M3U references the streaming IP address giving in ServerWMC.

Edited by sliderbot

Share this post


Link to post
Share on other sites
Luke

So are you using the ServerWMC plugin for Emby, or did you import the tuners as an m3u?

Share this post


Link to post
Share on other sites
Luke

Ok, try pulling up the mapping tool, then please attach the emby server log. thanks.

Share this post


Link to post
Share on other sites
Luke

If you put this url in a browser, what does it return?

http://localhost:9180/serverwmc.stream/ 

Share this post


Link to post
Share on other sites
sliderbot

This is a Windows© Communication Foundation service.

Metadata publishing for this service is currently disabled.

If you have access to the service, you can enable metadata publishing by completing the following steps to modify your web or application configuration file:

1. Create the following service behavior configuration, or add the <serviceMetadata> element to an existing service behavior configuration:

<behaviors>
<serviceBehaviors>
<behavior name="MyServiceTypeBehaviors" >
<serviceMetadata httpGetEnabled="true" />
</behavior>
</serviceBehaviors>
</behaviors>

2. Add the behavior configuration to the service:

<service name="MyNamespace.MyServiceType" behaviorConfiguration="MyServiceTypeBehaviors" >

Note: the service name must match the configuration name for the service implementation.

3. Add the following endpoint to your service configuration:

<endpoint contract="IMetadataExchange" binding="mexHttpBinding" address="mex" />

Note: your service must have an http base address to add this endpoint.

The following is an example service configuration file with metadata publishing enabled:

<configuration>
<system.serviceModel>

<services>
<!-- Note: the service name must match the configuration name for the service implementation. -->
<service name="MyNamespace.MyServiceType" behaviorConfiguration="MyServiceTypeBehaviors" >
<!-- Add the following endpoint. -->
<!-- Note: your service must have an http base address to add this endpoint. -->
<endpoint contract="IMetadataExchange" binding="mexHttpBinding" address="mex" />
</service>
</services>

<behaviors>
<serviceBehaviors>
<behavior name="MyServiceTypeBehaviors" >
<!-- Add the following element to your service behavior configuration. -->
<serviceMetadata httpGetEnabled="true" />
</behavior>
</serviceBehaviors>
</behaviors>

</system.serviceModel>
</configuration>

Share this post


Link to post
Share on other sites
Luke

Really? Well then that's your problem. That's not the expected response for an m3u channel list. This is an example of the expected response:

 

http://xmtvplayer.com/build-m3u-file

 

So you'll need to figure that out with ServerWMC. Are you sure it even supports m3u output? I wasn't aware of that.

Share this post


Link to post
Share on other sites
sliderbot

Apparently not. I have the Emby API for ServerWMC dishing them up. Since the format for programming has changed, where the tuners aren’t listed, it created a bit of confusion.

 

However, with the M3U removed and the tuners coming in through the Emby ServerWMC API, the EPG still isn’t mapping.

Share this post


Link to post
Share on other sites
Luke

 

 

However, with the M3U removed and the tuners coming in through the Emby ServerWMC API, the EPG still isn’t mapping.

You mean with the ServerWMC plugin? Mixing and matching is not supported, at least not right now, so you'll need to ensure ServerWMC has guide data and then the ServerWMC plugin will import it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...