Jump to content


Photo

Email notifications


  • Please log in to reply
24 replies to this topic

#1 Ninko OFFLINE  

Ninko

    Advanced Member

  • Members
  • 177 posts
  • Local time: 02:08 PM
  • LocationGloucestershire, England

Posted 07 April 2020 - 06:19 AM

Hi,
I've recently changed my email provider and update the plug-in settings with the correct details but every time I try to send a test email it says there was an error straight away, it's almost as though it's not even attempting to send.

Any help please

Thanks

#2 rbjtech OFFLINE  

rbjtech

    Advanced Member

  • Members
  • 762 posts
  • Local time: 02:08 PM
  • LocationLondon, UK

Posted 07 April 2020 - 09:16 AM

what settings have you used ? (don't specify your email address here, just the settings.. )  ;)

 

Does your new provider use the same SSL/TLS ports ? - try with 25 for basic SMTP to ensure that works to start with.



#3 Ninko OFFLINE  

Ninko

    Advanced Member

  • Members
  • 177 posts
  • Local time: 02:08 PM
  • LocationGloucestershire, England

Posted 07 April 2020 - 07:09 PM

I'm using smtp.virginmedia.com port 465 with both SSL and authentication options selected. I've also tried port 587 and 25 as you adviced, still gives me an error.

#4 Ninko OFFLINE  

Ninko

    Advanced Member

  • Members
  • 177 posts
  • Local time: 02:08 PM
  • LocationGloucestershire, England

Posted 10 April 2020 - 02:57 PM

Any help please?

#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:08 AM

Posted 10 April 2020 - 03:04 PM

Hi there, please see how to report a problem. Thanks.



#6 Ninko OFFLINE  

Ninko

    Advanced Member

  • Members
  • 177 posts
  • Local time: 02:08 PM
  • LocationGloucestershire, England

Posted 10 April 2020 - 03:20 PM

That doesn't tell you what you want to know for a plugin problem?

#7 rbjtech OFFLINE  

rbjtech

    Advanced Member

  • Members
  • 762 posts
  • Local time: 02:08 PM
  • LocationLondon, UK

Posted 11 April 2020 - 01:48 PM

I'm using smtp.virginmedia.com port 465 with both SSL and authentication options selected. I've also tried port 587 and 25 as you adviced, still gives me an error.

 

If you use the same credentials in an email client (outlook etc) does this work ?

 

Are there any firewalls preventing OUTGOING requests on Ports TCP 25, 465 and 587 ?  If using Windows, default is to not block outgoing connections anyway.

 

Remember you do the setup per Emby USER - so make sure it is setup for the correct user and notifications are enabled for that user   ;)

 

My setup is as follows -

 

Configure email notifications for - 'Admin'

Enable Notifications - Ticked

Email from - My Primary email address

Email to - emby@mydomain.com (can be the same as your primary email)

smtp hostname - smtp.mydomain.com

smtp port - 587

Enable SSL - ticked

Enable SMTP Auth - ticked

smtp username - My Primary email address

smtp password - same as my main email password

 

ps - if using Port 25 (as a test), do not tick SSL  ;)

 

Click SAVE, then a Test Notification will send you an email with the contents below :-

 

Emby: Test Notification

 

This is a test notification from Emby Server

 

A notification set to send an email when a particular user plays a video results in the following in the logs :-

 

2020-04-11 18:54:24.922 Info App: Sending email emby@mydomain.com with subject Emby: MyUser is playing SomeThing on Chrome

2020-04-11 18:54:25.382 Info App: Completed sending email emby@mydomain.com with subject Emby: MyUser is playing SomeThing on Chrome

 

@Luke - to note, looking at the logs, the 'Test' is also generating an error, but the email is being sent (and received) regardless.

 

2020-04-11 18:45:05.042 Error App: Error sending email: System.Net.Mail.SmtpException: Service not available, closing transmission channel. The server response was: 4.7.0 smtp.<smtpprovider> Error: too many errors
at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
at System.Net.Mail.MailCommand.EndSend(IAsyncResult result)
at System.Net.Mail.SendMailAsyncResult.SendMailFrom()
at System.Net.Mail.SmtpTransport.BeginSendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, Boolean allowUnicode, AsyncCallback callback, Object state)
at System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)
--- End of stack trace from previous location where exception was thrown ---
at MediaBrowser.Plugins.SmtpNotifications.Notifier.SendNotification(UserNotification request, CancellationToken cancellationToken)

 

I hope this helps. 


Edited by rbjtech, 11 April 2020 - 02:04 PM.


#8 Dibbes OFFLINE  

Dibbes

    Advanced Member

  • Members
  • 1233 posts
  • Local time: 03:08 PM
  • LocationMadrid, Spain

Posted 11 April 2020 - 01:55 PM

I'm using smtp.virginmedia.com port 465 with both SSL and authentication options selected. I've also tried port 587 and 25 as you adviced, still gives me an error.

 

https://getmailsprin...m-via-imap-smtp

 

Make sure you use the settings as they give



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156872 posts
  • Local time: 09:08 AM

Posted 12 April 2020 - 12:26 AM

Right now I honestly don't know. I wish I had a better answer but these kinds of things always seem to end up being domain or configuration specific.

#10 Ninko OFFLINE  

Ninko

    Advanced Member

  • Members
  • 177 posts
  • Local time: 02:08 PM
  • LocationGloucestershire, England

Posted 12 April 2020 - 01:46 AM

Is there anyway to clear all settings from the plugin to start from scratch as I'm wondering if that might be part of the problem?

Thanks

#11 Dibbes OFFLINE  

Dibbes

    Advanced Member

  • Members
  • 1233 posts
  • Local time: 03:08 PM
  • LocationMadrid, Spain

Posted 12 April 2020 - 05:58 AM

Is there anyway to clear all settings from the plugin to start from scratch as I'm wondering if that might be part of the problem?

Thanks

 

Manually remove the .dll and the config file from the plugin folder. Unless you've changed these paths, you find these folders at \\%appdata%\Roaming\Emby-Server\programdata\plugins\

 

I don't which file in the configurations folder is the one for email notifications, as this seems encrypted...


  • FrostByte likes this

#12 Ninko OFFLINE  

Ninko

    Advanced Member

  • Members
  • 177 posts
  • Local time: 02:08 PM
  • LocationGloucestershire, England

Posted 12 April 2020 - 06:29 AM

I'm running emby on Synology, so I'm not sure it's as easy as that?
Thanks

#13 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15920 posts
  • Local time: 02:08 PM
  • LocationEngland

Posted 12 April 2020 - 06:57 AM

I'm running emby on Synology, so I'm not sure it's as easy as that?
Thanks


@FrostByte, @Spaceboy or @PenkethBoy might know.
  • FrostByte likes this

#14 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 4297 posts
  • Local time: 02:08 PM
  • LocationWarrington,UK

Posted 12 April 2020 - 07:04 AM

use putty and/or WinScp to login to your nas and do as dibbes suggested

 

reboot the emby server after


  • CBers and FrostByte like this

#15 FrostByte OFFLINE  

FrostByte

    Advanced Member

  • ForumMod
  • 5057 posts
  • Local time: 09:08 AM
  • LocationThe UP

Posted 12 April 2020 - 07:29 AM

the paths you're looking for on Synology are

 

/var/packages/EmbyServer/target/var/plugins

/var/packages/EmbyServer/target/var/plugins/configurations

 

If the config file is encrypted though, not sure how you figure which is which


Edited by FrostByte, 12 April 2020 - 07:31 AM.

  • PenkethBoy likes this

#16 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15920 posts
  • Local time: 02:08 PM
  • LocationEngland

Posted 12 April 2020 - 08:41 AM

I'm using smtp.virginmedia.com port 465 with both SSL and authentication options selected. I've also tried port 587 and 25 as you adviced, still gives me an error.


465 is the correct port for smtp.virginmedia.com, but it just does not like sending an email initiated by Emby.

Using a Gmail account works fine, but you need to enable "Less secure apps access".

#17 Ninko OFFLINE  

Ninko

    Advanced Member

  • Members
  • 177 posts
  • Local time: 02:08 PM
  • LocationGloucestershire, England

Posted 12 April 2020 - 01:40 PM

465 is the correct port for smtp.virginmedia.com, but it just does not like sending an email initiated by Emby.
Using a Gmail account works fine, but you need to enable "Less secure apps access".

Did you find smtp.virginmedia.com wouldn't work either then?

Thanks

Edited by Ninko, 12 April 2020 - 01:41 PM.


#18 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15920 posts
  • Local time: 02:08 PM
  • LocationEngland

Posted 12 April 2020 - 03:12 PM

Did you find smtp.virginmedia.com wouldn't work either then?

Thanks


Yes.

The Test Email also fails in Emby with my Gmail account, but I still receive the email.

#19 Ninko OFFLINE  

Ninko

    Advanced Member

  • Members
  • 177 posts
  • Local time: 02:08 PM
  • LocationGloucestershire, England

Posted 12 April 2020 - 03:20 PM

Right... I have no idea what's wrong here then, shame as I found it a useful plugin.

#20 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15920 posts
  • Local time: 02:08 PM
  • LocationEngland

Posted 12 April 2020 - 03:23 PM

Right... I have no idea what's wrong here then, shame as I found it a useful plugin.


Just create yourself a Gmail account and use that.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users