Jump to content

Emby for Kodi - Only first season of a TV show syncs to Kodi


Pulseeey
 Share

Recommended Posts

cybergrimes

Is anyone able to do a test and isolate it to a specific Emby Server version? This is easy on windows with portable installations. I can help with that.

 

For example, does it happen with 4.2.1? 4.3.1? Thanks.

I think it's somewhere in the current beta server.

I went through portable 4.2.1, 4.3.1 and 4.4.2 without seeing the issue. I just fired up Kodi today for the first time in awhile, using server 4.5.0.8, and seeing this issue.

 

edit1: posts on first page of thread seem to confirm, users went back to stable and no longer saw the issue.

edit2: tried rolling back to add-on version 4.1.18 but no change and also a 4.1.19a that I saw in the public testing folder but no difference with beta server.

Edited by cybergrimes
  • Like 1
Link to comment
Share on other sites

Is anyone able to do a test and isolate it to a specific Emby Server version? This is easy on windows with portable installations. I can help with that.

 

For example, does it happen with 4.2.1? 4.3.1? Thanks.

@@Luke I'll help test if it will help. But @@cybergrimes post https://emby.media/community/index.php?/topic/84727-emby-for-kodi-only-first-season-of-a-tv-show-syncs-to-kodi/page-2&do=findComment&comment=879443 pretty much captures when the issue first presented already. Stable 4.4.2 good...beta 4.5.0.4 onward bad.

Edited by DarWun
Link to comment
Share on other sites

Hi all,

 

any news on this? facing the same problem with Emby Server 4.5.0.10 Beta and Kodi 18.6 using Emby Plugin 4.1.19.

Started some releases ago and took some time till i recognized it. 

Tried a local reset of kodi database, uninstall/reinstall emby in kodi and so on... without success... 

About 20% of my Media is synced the rest is ignored.

 

Thanks!

 

Best Regards,

Hans

Edited by DaAigolf
Link to comment
Share on other sites

i also tested this behaviour, 2 new clients setup, kodi 18 on linux and windows, emby kodi addon stable and beta, ...

 

in the end, 15 episodes per show, doesnt matter if all in 1 season or 15 + 5 ...

Link to comment
Share on other sites

i also tested this behaviour, 2 new clients setup, kodi 18 on linux and windows, emby kodi addon stable and beta, ...

 

in the end, 15 episodes per show, doesnt matter if all in 1 season or 15 + 5 ...

So you did get multiple seasons?

Link to comment
Share on other sites

So you did get multiple seasons?

@@Luke Only the first fifteen episodes actually present in the library per show are shown. If there are more than fifteen episodes present in the library for the first season, then none of the other seasons show up in Emby for Kodi. If there are less than fifteen episodes in the first season, then episodes from the second season will be shown. If you have a show with more than fifteen specials in the Season 0 folder, then you don't even see episodes from the first season.

 

If the episodes aren't deleted once they have been watched, the number of episodes available for the show will decrease by one every time an episode is watched. If all fifteen episodes are watched in the first season, the show no longer appears in Emby for Kodi. If episodes are deleted as they are watched, then Emby for Kodi will eventually start listing episodes in other seasons.

  • Like 1
Link to comment
Share on other sites

So you did get multiple seasons?

 

exactly, 15 episodes / show here

 

sample

 

show has 3 seasons, 10 episodes each

 

sync is

 

season 1, shows 10

season 2, shows 5

season 3, not existent ... (i actually never tick show empty series folders)

 

i ll now test with "show empty series" if they show empty season folders  ..

 

report back

Link to comment
Share on other sites

So you did get multiple seasons?

 

ok, dirty quick test, raised the value in emby settings to 9999, but looks like 50 is the limit.

 

sample in attachements, x-Files, i have all seasons with all episode, kodi addon syncs up to season 3, episode 1 (50 shows, season 1 24, season 2 25, ...)

 

then the print  from emby page where u see all seasons are active

 

in kodi it doesnt show empty folders for seasons even with the feature (show empty seasons) which is as expected ...

 

so overall, for a show, it stops after the setted value (max 50, nvm what u put there as greater value, see attachement) and moves forward to next show instead stay in show ...

setting "max simultan server queries"

 

may the server log could also give a hint, i couldnt see anything helpful now ... also attached.

post-112497-0-94638000-1589284093_thumb.png

post-112497-0-24608800-1589284101_thumb.png

post-112497-0-46207700-1589284108_thumb.png

embyserver.txt

Edited by alturismo
  • Like 1
Link to comment
Share on other sites

Hi all,

 

just updated to Emby Beta 4.5.0.11 and it seems like that the sync is working again.

Looks like that all my shows are again visible in Kodi.

Had to reset the local Kodi DB and the Emby Plugin Settings.

But i just did a spot check. Anyone else can confirm? 

  • Like 1
Link to comment
Share on other sites

not here, just made a clean install.

 

still the same limit as described above, and im sure its the setting "max simultan server queries"

 

default 15, -> first 15 shows synced

set to 25 -> first 25 shows synced

...

this goes up to 50 (seems internal limit), anything higher makes no difference,

always tested by reset database etc.

 

so this setting seems responsible for this "really bad" sync issue, after this value the scraper jumps to the next show instead finishing the same show ...

Link to comment
Share on other sites

and after some more debugging, im pretty sure

 

workaround for now (own risk) ;)

 

1st

 

set limit in kodi settings to 999 (or your personal max show limit you want to fetch)

 

2nd

 

in your addons folder

/addons/plugin.video.emby/resources/lib/downloader.py

Line 25

 

LIMIT = min(int(settings('limitIndex') or 50), 50)

 

i changed to

 

LIMIT = min(int(settings('limitIndex') or 999), 999)

 

or your limit you setted in GUI

 

now all episodes from all shows are syncing ...

 

again, at your own risk ... i just raise the internal limit now, but thats a "workaround", rest is on emby team ;)

post-112497-0-37177000-1589708520_thumb.png

post-112497-0-73830500-1589708526_thumb.png

Edited by alturismo
  • Like 1
Link to comment
Share on other sites

Dont ask me why, but it currently works for me with Emby Beta Server 4.5.11 ...

For (re)testing purposes i just did a completly new Kodi setup (Libreelec VM) which never got in touch with Emby Server/Library before.

Installed Emby Beta Addon 4.1.19. Configured Emby Addon, did a library scan and it again shows all episodes to me... 

Hopefully it keeps working this way...

Link to comment
Share on other sites

@@Luke After updating to Beta 4.5.11, the issue also seems to be fixed for me. I just did a full database reset in Emby for Kodi, and the episode counts for all my series reported by Kodi matches the number actually on the Emby server. So for now, good news!!!

Link to comment
Share on other sites

I will going to try Emby for Kodi today.

 

I will do a feedback later

 

Feedback.

 

Working fine for me.

 

Server:

Emby Server on Docker Portanier 4.5.0.11 beta

All libraries with the path of the shared network

 

Client on Shield:

Kodi latest version on Nvidia Shield 2017 Pro

Kodi setup with the local server and emby repo

Emby for Kodi latest-> kodi.emby.tv

 

 

 

Sync was faster and accurate.

 

Side note:

 

Curl.Lyrics doesn't work (anyone experience this?) <------- Question

 

Comment: Emby for kodi works well with any skin that is supported or use "Add-on: Skin Shortcuts - Add To Menu"

 

My choice was AeonNox Silvo.

 

Thanks

Edited by Riggs
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...