Jump to content


Photo

Chromecast issue from Android App


  • Please log in to reply
6 replies to this topic

#1 gregcab81 OFFLINE  

gregcab81

    Newbie

  • Members
  • 9 posts
  • Local time: 10:11 PM

Posted 28 March 2020 - 10:19 AM

Hi,

 

I'm currently having a big issue with playing movies from Android App to Chromecast.

Here's my environment:

1. emby server on raspberry pi 4, version 4.4.0.40: movies are on a usb HDD attached to the raspberry

2. Emby mobile app version 3.1.12

3. Google Chromecast

 

If I try to play a movie from Android App to Chromecast:

1. Android app can find the Chromecast.

2. When I press play on a movie, the TV screen came black and nothing happens.

 

I attached the embyserver log and the ffmpeg transcode. 

Could you please help me?

 

On a browser and directly on the app, the movie is playing without problem: the issue occurred when I try to cast on Chromecast.

 

Thanks

 

 

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156851 posts
  • Local time: 04:11 PM

Posted 28 March 2020 - 08:35 PM

Hi, as a test, if you turn off subtitles prior to playback, does that help?



#3 gregcab81 OFFLINE  

gregcab81

    Newbie

  • Members
  • 9 posts
  • Local time: 10:11 PM

Posted 29 March 2020 - 05:15 AM

Hi Luke,

 

without sub the video is playing (Direct stream as I can see from the emby server dashboard), with a lot of freezing and buffering (why?)

I attached the logs.

 

Thanks for the quick response

 

 

Attached Files



#4 thegrunge OFFLINE  

thegrunge

    Advanced Member

  • Members
  • 105 posts
  • Local time: 04:11 PM

Posted 29 March 2020 - 04:04 PM

@gregcab81 The PGS subtitle has always been problematic for me and forces transcoding and causes buffering. Disable the subtitles I already made a post above and for now only the other type of subtitles are ok to avoid unnecessary transcoding.

 

 

Attached Files



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156851 posts
  • Local time: 04:11 PM

Posted 06 April 2020 - 11:10 PM

@gregcab81 The PGS subtitle has always been problematic for me and forces transcoding and causes buffering. Disable the subtitles I already made a post above and for now only the other type of subtitles are ok to avoid unnecessary transcoding.

 

Chromecast does not support PGS, so yes it will cause transcoding, and your server machine will need to be able to handle that.



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156851 posts
  • Local time: 04:11 PM

Posted 06 April 2020 - 11:12 PM

@gregcab81, burning in subtitles is a very costly process even for powerful servers, and you're running on a Raspberry Pi.

 

I would suggest using our subtitle download features to obtain external text subtitles as these will be much more efficient. Please let us know if this helps. Thanks.



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156851 posts
  • Local time: 04:11 PM

Posted 10 April 2020 - 10:06 PM

@gregcab81 has this helped?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users