Jump to content

Rating imported from .NFO with a rating of 6.1 have 8 decimal places


Recommended Posts

invader

This is an odd one. I'm running Windows server 4.4.0.40 and Synology Emby Server 4.3.1.0. Both have the same issue. 
 
The .nfo file was generated using Tiny Media Manager. I have deleted it and regenerated and it doesn't help.
 
If I manually edit the rating to 6.2, then refresh metadata, it displays fine; only 1 decimal place. Then I change it back to 6.1 and it goes to the 8 decimal places again. Looks to be specific to a rating of 6.1!
 
https://imgur.com/a/V4HriS4

post-502966-0-45773500-1585351243_thumb.png

post-502966-0-66953600-1585351250_thumb.png

Edited by invader
Link to post
Share on other sites
Happy2Play

What browser?

 

I don't see that rating format but believe it was added.  Can you post the nfo file?

Link to post
Share on other sites
invader
Posted (edited)

I'm using Chrome. I just tried Firefox too, same issue. I've just attached the nfo. Thanks.

 

 

movie.zip

Edited by invader
Link to post
Share on other sites
Happy2Play

I'm using Chrome. I just tried Firefox too, same issue. I've just attached the nfo. Thanks.

 

Sorry no nfo attached.

Link to post
Share on other sites
invader

Sorry no nfo attached.

Woops sorry. I didn't realise it said "error" when I tried to attache the .nfo. I've zipped it and now it worked and is attached to that post.

 

Can you compare using a different browser? 

Hi Luke. I tried Chrome and Firefox. Did you want me to try another?

Link to post
Share on other sites
Luke

No I was just curious. We're using a browser function to format the numeric value appropriately for your locale.

Link to post
Share on other sites
invader

I see. Well I just tried the iOS Emby app and it shows the same number of decimal places too. So seems platform independent.

Link to post
Share on other sites
Happy2Play

No I was just curious. We're using a browser function to format the numeric value appropriately for your locale.

It appears to this format as i can reproduce.

 

changed

<rating>6.1</rating>

to

<ratings>
	<rating default="true" max="10" name="imdb">
		<value>6.1</value>
		<votes>40796</votes>
	</rating>
</ratings>
Edited by Happy2Play
Link to post
Share on other sites
Luke

Yea actually i was wrong, we're not using the platform function to format it, but maybe now we should.

Link to post
Share on other sites
Happy2Play

Is it just the way Emby is reading these 3rd party ratings, since Emby doesn't write this newer format?

Edited by Happy2Play
Link to post
Share on other sites
Happy2Play

If you use the metadata editor, what does it show?

 

You mean this.  Easy to reproduce using new format.

5e7ea1633e951_test.jpg

Edited by Happy2Play
Link to post
Share on other sites
invader

This issue has been resolved in NFO Metadata plugin 1.0.28. Thank you.

Woops. I got too excited. It isn't fixed, I refreshed metadata and it's got the 8 decimal places again. Still an issue. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...