Jump to content


Photo

Frustrating issue with Metadata

metadata

  • Please log in to reply
40 replies to this topic

#1 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 11:42 AM

I've probably missed a setting here somewhere so I hope it's a simple fix.

I spent a few hours last week refreshing metadata and updating images for the many titles i had that hadn't auto scraped....there were a lot. Only to come back on today to find they have all reverted back to thumbnails of the movie..... What have I done wrong please. Most movies scrape properly and stay correct and all will scrape the correct info if go through and manually re-scan them.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 02:46 AM

Posted 27 March 2020 - 11:45 AM

Hi there, are these thumbnail images located in your media folder next to the movie?



#3 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 11:51 AM

I have thumbnail images turned off so i'm not sure where its pulling them from. I have just manually re-scanned a number of the movies that are affected and they show proper artwork now but they will change again sometime. It's weird because not all movies do the same.



#4 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 11:55 AM

this is my file structure. I use same files for Plex, although I'm trying to move away from Plex which why I'm so frustrated with this small issue which is all that's holding me back.5e7e220359261_files.jpg



#5 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 11:56 AM

oops sorry..forgot to resize image!



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 02:46 AM

Posted 27 March 2020 - 12:01 PM

Did you check the contents of those poster jpg files?



#7 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 12:09 PM

Right what I have found from your question is that the Titles with missing artwork have no Poster image saved, what I cant understand is that they all had images when I finished re-scanning them manually last week. I have found that when I do a manual scan I can select "Search for missing Metadata" and select "replace all images", which is how i re-scan the missing metadata and it works. Is there a setting that does an Auto scan at specified times which I can select "missing data only" or leave current images. It seems as though the images I download manually are being deleted automatically somehow?



#8 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 12:16 PM

I've searched through a few more of the missing titles and some do have Poster image files but they are screenshots or thumbnails....



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 02:46 AM

Posted 27 March 2020 - 12:19 PM

in your emby library settings did you enable saving images to media folders?



#10 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 12:26 PM

Save Artwork into media folders = Yes. Although there are no media folders on the same drive as the media....


Edited by justermin, 27 March 2020 - 12:29 PM.


#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 02:46 AM

Posted 27 March 2020 - 12:29 PM

Save Artwork into media folders = Yes. Although there are no media folders on the same drive as the media....

 

The media folder is the folder you showed a screenshot of.



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 02:46 AM

Posted 27 March 2020 - 12:30 PM

What version of Emby Server are you running?



#13 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 12:31 PM

version 4.4.0.40 I have Emby Premiere too.


Edited by justermin, 27 March 2020 - 12:32 PM.


#14 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 12:50 PM

This is a screenshot of the pictures saved in the metadata for one of the movies that is not showing correct images. It has no Primary image (poster) so it's using the Backdrop image. It will be there if I manually scan it as it was there last week but next time i look in a few days it will be missing again.

5e7e2e4bd208f_small.jpg



#15 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 01:11 PM

I've gone through whole library again now and re-scanned all titles so that they now show the correct title image. I'll check again in a few days to see if anything changes.



#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 02:46 AM

Posted 27 March 2020 - 01:14 PM

Are all the poster files saved in the folder now next to your videos?

#17 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 27 March 2020 - 06:20 PM

Yes they are all there currently.... fingers crossed.



#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 02:46 AM

Posted 28 March 2020 - 12:07 PM

Ok if it happens again please capture the emby server log. thanks.



#19 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 28 March 2020 - 12:44 PM

Just checked.....All gone again.. and the -poster.jpg files gone for each movie. I'll download the log and post.



#20 justermin OFFLINE  

justermin

    Member

  • Members
  • 24 posts
  • Local time: 07:46 AM

Posted 28 March 2020 - 12:49 PM

I have the log..its very big and contains personal data(i.p addresses etc)... should i be looking at anything specific?







Also tagged with one or more of these keywords: metadata

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users