Jump to content

No compatible streams available, but plays on Samsung phone


gillmacca01
 Share

Go to solution Solved by gillmacca01,

Recommended Posts

gillmacca01

I am attempting to play a movie on my Samsung TV (Tizen), but keep getting 'No Compatible stream available', but when attempting to play the same file through Emby on a Samsung s10+, the file plays fine.

Here is the media info for the file. Should this play fine on the TV, or is there something I need to adjust to get it working

 

5e7d0a2f2755c_1.png

Link to comment
Share on other sites

gillmacca01

Sorry for this. I have solved this, but would like to know for future reference, why this caused playback to fail.

I noticed for some reason, even though I have subtitles set to off, Engish (PGSSUB) was selected. As soon as I selected off, the movie started playing.

Link to comment
Share on other sites

But you still should be able to play them. The server will burn in the pgs with transcoding.

Link to comment
Share on other sites

gillmacca01

Well obviously not working correctly, unless I need to change a setting in transcoding - currently set default

Sent from my SM-G975F using Tapatalk

 

 

Did you want me to re-enable the subs and send you and logs? If so, what logs would you like?

Edited by gillmacca01
Link to comment
Share on other sites

gillmacca01

Just to let you know that 3 trailers are playing before the movie that I have skipped. I know that you know what you are looking at, but just in case.

Also I seem to have multiple ffmpeg around that time, so have attached the latest

embyserver.txt

ffmpeg-transcode-1d689a45-701e-46ac-b107-a7a47ce867a3_1.txt

Edited by gillmacca01
Link to comment
Share on other sites

Hmm, there's something about the file that ffmpeg doesn't like:

21:11:12.815 /share/CACHEDEV2_DATA/Movies/Movies/Joker (2019)/Joker (2019).mp4: Invalid data found when processing input

That's why the server can't transcode it, but oddly, some devices can still direct play it. Any ideas @@softworkz ?

 

Is this an mkv file that somehow got renamed to mp4?

Link to comment
Share on other sites

gillmacca01

I know why other devices are playing the file fine. My phone I have subtitles turned off.

A few days ago, I updated the Emby app for Samsung TV - my tv will not allow me to install over the top of a pre-existing app, so I have to uninstall the app, which means settings are returned to default. Subtitles must be defaulted to default on install.

Would not have come across this issue, if I hadn't updated tv app

 

Sent from my SM-G975F using Tapatalk

Link to comment
Share on other sites

SamES

I am attempting to play a movie on my Samsung TV (Tizen), but keep getting 'No Compatible stream available', but when attempting to play the same file through Emby on a Samsung s10+, the file plays fine.

Here is the media info for the file. Should this play fine on the TV, or is there something I need to adjust to get it working

 

5e7d0a2f2755c_1.png

 

Container says mkv, but the path is mp4.  Why?

Link to comment
Share on other sites

gillmacca01

No idea. This is how I received the file. I have not changed anything

 

Sent from my SM-G975F using Tapatalk

Link to comment
Share on other sites

SamES

Try renaming the file to mkv, then refresh the metadata and see if that changes the problem.

Link to comment
Share on other sites

  • Solution
gillmacca01

Changing to MKV solved it. Something for me to keep on eye on if it happens again.

Thanks for your help

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...