Jump to content


Photo

No compatible streams available, but plays on Samsung phone

Samsung TV Samsung phone

Best Answer gillmacca01 , 27 March 2020 - 12:52 PM

Changing to MKV solved it. Something for me to keep on eye on if it happens again.

Thanks for your help

Go to the full post


  • Please log in to reply
14 replies to this topic

#1 gillmacca01 OFFLINE  

gillmacca01

    Advanced Member

  • Members
  • 67 posts
  • Local time: 07:09 AM

Posted 26 March 2020 - 04:02 PM

I am attempting to play a movie on my Samsung TV (Tizen), but keep getting 'No Compatible stream available', but when attempting to play the same file through Emby on a Samsung s10+, the file plays fine.

Here is the media info for the file. Should this play fine on the TV, or is there something I need to adjust to get it working

 

5e7d0a2f2755c_1.png



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157111 posts
  • Local time: 02:09 AM

Posted 26 March 2020 - 04:03 PM

Hi there, let's look at an example. Please attach the information requested in how to report a media playback issue. thanks !



#3 gillmacca01 OFFLINE  

gillmacca01

    Advanced Member

  • Members
  • 67 posts
  • Local time: 07:09 AM

Posted 26 March 2020 - 04:10 PM

Sorry for this. I have solved this, but would like to know for future reference, why this caused playback to fail.

I noticed for some reason, even though I have subtitles set to off, Engish (PGSSUB) was selected. As soon as I selected off, the movie started playing.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157111 posts
  • Local time: 02:09 AM

Posted 26 March 2020 - 04:23 PM

But you still should be able to play them. The server will burn in the pgs with transcoding.



#5 gillmacca01 OFFLINE  

gillmacca01

    Advanced Member

  • Members
  • 67 posts
  • Local time: 07:09 AM

Posted 26 March 2020 - 04:33 PM

Well obviously not working correctly, unless I need to change a setting in transcoding - currently set default

Sent from my SM-G975F using Tapatalk

 

 

Did you want me to re-enable the subs and send you and logs? If so, what logs would you like?


Edited by gillmacca01, 26 March 2020 - 04:37 PM.


#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157111 posts
  • Local time: 02:09 AM

Posted 26 March 2020 - 04:50 PM

Yes please that would be great, thanks.



#7 gillmacca01 OFFLINE  

gillmacca01

    Advanced Member

  • Members
  • 67 posts
  • Local time: 07:09 AM

Posted 26 March 2020 - 04:59 PM

Did you just want server log, or something else as well?



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157111 posts
  • Local time: 02:09 AM

Posted 26 March 2020 - 05:04 PM

server + ffmpeg log. thanks.



#9 gillmacca01 OFFLINE  

gillmacca01

    Advanced Member

  • Members
  • 67 posts
  • Local time: 07:09 AM

Posted 26 March 2020 - 05:17 PM

Just to let you know that 3 trailers are playing before the movie that I have skipped. I know that you know what you are looking at, but just in case.

Also I seem to have multiple ffmpeg around that time, so have attached the latest

Attached Files


Edited by gillmacca01, 26 March 2020 - 05:19 PM.


#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157111 posts
  • Local time: 02:09 AM

Posted 26 March 2020 - 10:22 PM

Hmm, there's something about the file that ffmpeg doesn't like:

21:11:12.815 /share/CACHEDEV2_DATA/Movies/Movies/Joker (2019)/Joker (2019).mp4: Invalid data found when processing input

That's why the server can't transcode it, but oddly, some devices can still direct play it. Any ideas @softworkz ?

 

Is this an mkv file that somehow got renamed to mp4?



#11 gillmacca01 OFFLINE  

gillmacca01

    Advanced Member

  • Members
  • 67 posts
  • Local time: 07:09 AM

Posted 27 March 2020 - 06:31 AM

I know why other devices are playing the file fine. My phone I have subtitles turned off.
A few days ago, I updated the Emby app for Samsung TV - my tv will not allow me to install over the top of a pre-existing app, so I have to uninstall the app, which means settings are returned to default. Subtitles must be defaulted to default on install.
Would not have come across this issue, if I hadn't updated tv app

Sent from my SM-G975F using Tapatalk

#12 SamES OFFLINE  

SamES

    Advanced Member

  • Members
  • 1275 posts
  • Local time: 04:09 PM

Posted 27 March 2020 - 07:05 AM

I am attempting to play a movie on my Samsung TV (Tizen), but keep getting 'No Compatible stream available', but when attempting to play the same file through Emby on a Samsung s10+, the file plays fine.

Here is the media info for the file. Should this play fine on the TV, or is there something I need to adjust to get it working

 

5e7d0a2f2755c_1.png

 

Container says mkv, but the path is mp4.  Why?



#13 gillmacca01 OFFLINE  

gillmacca01

    Advanced Member

  • Members
  • 67 posts
  • Local time: 07:09 AM

Posted 27 March 2020 - 07:15 AM

No idea. This is how I received the file. I have not changed anything

Sent from my SM-G975F using Tapatalk

#14 SamES OFFLINE  

SamES

    Advanced Member

  • Members
  • 1275 posts
  • Local time: 04:09 PM

Posted 27 March 2020 - 07:56 AM

Try renaming the file to mkv, then refresh the metadata and see if that changes the problem.



#15 gillmacca01 OFFLINE  

gillmacca01

    Advanced Member

  • Members
  • 67 posts
  • Local time: 07:09 AM

Posted 27 March 2020 - 12:52 PM   Best Answer

Changing to MKV solved it. Something for me to keep on eye on if it happens again.

Thanks for your help


  • Luke and FrostByte like this





Also tagged with one or more of these keywords: Samsung TV, Samsung phone

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users