Jump to content
aziz

GameBrowser 3.2.5 and Latest server with Emby Classic server4 version.

Recommended Posts

aziz

Hello Folks,

 

First, I hope everyone is well and being very safe under the current scary circumstances.

 

I know I am a dying bread, and I have to move into Emby Theater or alternatives eventually, but I think this upgrade will be the last before that happens.  I need to work with whoever is responsible for Emby Theater to make integration work.

 

That said,

 

Currently, I have tested everything i need on the latest server and Emby classic for server 4 "beta".  Everything seems to be working as good as it will get, apart from GameBrowser, which is very important part of the integration even though it is written by volunteers.

 

here is the problem:

 

when I go to the games library, then select game system (windows), then  i can see a list of all games, and once i select a game, it drills in and shows me the word "No Items"..  So, the GameBrowswer integration is broken.

 

Same thing happens if i look at the server using the Web App.  when i click on games, it shows me no items, however, when i change the view to Folder, then I can see all the games and drill down on them using the Web App.

 

I am not sure if it is a problem with my setup, or a problem others are having. I know someone has this working on Emby Theater.

 

Interestingly, when I had the Emby Classic release code, I copied the old GameBrowswer pluggin and the configuration xml (ver 3.1.3) into the new server, and it worked for a while until the server automatically upgraded to GameBrowswer 3.2.5 and then it gave me this issue...  I tried the same trick with Emby Classic "beta", and I am unable to get the same results.

 

Currently, this is the only thing stopping me from being on server 4.. Can you please help.

 

Thanks.

Share this post


Link to post
Share on other sites
aziz

Hello everyone and hello Luke,

 

So, I have reported this issue on the plugin section back in March, but I got no response, So I am trying this here..

 

Server 4.4.2.0 upgrades the GameBrowser Plug-in to 3.2.5, which is not working with Emby Classic.  So, the ideal way is try to fix the new plugin so it works with Emby Classic, but I am sure everyone will remind me that Emby classic is dead, and I am very lucky to have it even running.

 

So, the alternative is to enable Server 4.4.2.0 to be able to run the GameBrowswer 3.1.3.  The reason I say this is, Game Browser plugin ver 3.1.3 was working fine with Emby Classic.   

 

Luke, Can you please help.  Maybe i can do something on my side to stop it upgrading the GameBrowser automatically..

 

 

Many thanks.

Share this post


Link to post
Share on other sites
d00zah
Posted (edited)

If you wish to prevent a specific plugin from updating, set the .dll in the /plugins directory to 'read only'.

 

Pros

 

- You preserve a "working" version.

 

Cons

 

- Daily msgs on your dashboard that an update failed,

- Backup plugin will archive that .dll with the 'read only' flag set, which causes FAIL msgs in log upon attempted deletion (keep x backups).

- It's on you if things start behaving badly.

 

YMMV

Edited by d00zah

Share this post


Link to post
Share on other sites
Luke

I've merged the topics so that we can keep relevant discussion together. Thanks guys.

Share this post


Link to post
Share on other sites
aziz

 

If you wish to prevent a specific plugin from updating, set the .dll in the /plugins directory to 'read only'.

 

Pros

 

- You preserve a "working" version.

 

Cons

 

- Daily msgs on your dashboard that an update failed,

- Backup plugin will archive that .dll with the 'read only' flag set, which causes FAIL msgs in log upon attempted deletion (keep x backups).

- It's on you if things start behaving badly.

 

YMMV

 

 

Thanks for that tip DOOzah,

 

It sounds a little bit touch and go, and not ideal for a live system.  as if it breaks, you disappoint many people.  (and it sounds like it will break as it will constantly be trying to upgrade...

 

I was hoping for an alternative.  I have noticed when you come to install the plug-in, it gives you a choice of versions.  How about if we make that stick in the next version of the server release.  That's what I am hoping for...

 

Thanks for the help Guys..... stay safe.

 

p.s.  A better alternative is to make the new plug-in (3.2.5) incorporate the items that made it work in (3.1.3), and then everyone would be happy.  Is that at all possible?  who is working on the Gamebrowser Plug-in.. I know it is a community effort, but who should i approach in the community.   GameBrowser is an integral part of Emby, and for me at least, it is more important than the Music player, as there are many alternative music players, that people already use, but Gamebrowser, now that's a killer app.  (brilliant piece to show to your friends :-) )

Share this post


Link to post
Share on other sites
d00zah

FWIW I've been using this approach for one of my plugins for > 1 yr. without any issues other than the reporting 'noise'.  The point is, you can have what you need NOW, vs waiting for a proper change (only you think is is important) which may never come. This type of request is neither new, nor novel & IMO just requires a little self-help.. I'd mentioned what I'd observed so you didn't waste dev time chasing a self-inflicted problem. Good luck.

Share this post


Link to post
Share on other sites
aziz

FWIW I've been using this approach for one of my plugins for > 1 yr. without any issues other than the reporting 'noise'.  The point is, you can have what you need NOW, vs waiting for a proper change (only you think is is important) which may never come. This type of request is neither new, nor novel & IMO just requires a little self-help.. I'd mentioned what I'd observed so you didn't waste dev time chasing a self-inflicted problem. Good luck.

Hello d00zah,

 

I will give it a try and report back... thanks for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...