Jump to content

Getting a "processing updates" after watching a video


Nazgulled
 Share

Recommended Posts

Hi,

 

After watching a Movie or a TV Show episode I always get the "processing updates" message and this always takes a while before the video is marked as "watched".

 

Is this expected? Because this didn't use to happen before. I'm not sure when it started to happen I just decided to post this here today.

 

I've noticed in kodi.log file that after watching a movie I get a bunch of lines like these:

2020-03-15 19:21:28.061 T:28934  NOTICE: EMBY.objects.movies -> USERDATA movie [2224/1] 28522: 6 Underground
2020-03-15 19:21:28.127 T:28934  NOTICE: EMBY.objects.movies -> USERDATA movie [2225/2] 28507: 12 Angry Men
2020-03-15 19:21:28.184 T:28934  NOTICE: EMBY.objects.movies -> USERDATA movie [2226/3] 28505: 2001: A Space Odyssey
2020-03-15 19:21:28.223 T:28934  NOTICE: EMBY.objects.movies -> USERDATA movie [2240/17] 28487: A Clockwork Orange
2020-03-15 19:21:28.257 T:28934  NOTICE: EMBY.objects.movies -> USERDATA movie [2293/70] 28446: A Single Man
2020-03-15 19:21:28.372 T:28934  NOTICE: EMBY.objects.movies -> USERDATA movie [2227/4] 28461: Alice Through the Looking Glass
2020-03-15 19:21:28.493 T:28934  NOTICE: EMBY.objects.movies -> USERDATA movie [2228/5] 28462: Allegiant
2020-03-15 19:21:28.728 T:28934  NOTICE: EMBY.objects.movies -> USERDATA movie [2229/6] 28493: Arctic
(...)
2020-03-15 19:22:08.549 T:28934  NOTICE: EMBY.database -> [emby] 752 rows updated.
2020-03-15 19:22:08.561 T:28934  NOTICE: EMBY.database -> [video] 752 rows updated.
2020-03-15 19:22:08.566 T:28934  NOTICE: EMBY.library -> --<[ q:userdata/151127287200 ]
2020-03-15 19:22:10.467 T:26012  NOTICE: EMBY.library -> -->[ q:userdata/Episode/151150109472 ]
2020-03-15 19:22:10.513 T:28948  NOTICE: EMBY.objects.tvshows -> USERDATA episode [2694/110] 24888: I Want to Be Free
2020-03-15 19:22:10.545 T:28948  NOTICE: EMBY.objects.tvshows -> USERDATA episode [2695/111] 24993: Are You the Mole?
2020-03-15 19:22:10.580 T:28948  NOTICE: EMBY.objects.tvshows -> USERDATA episode [3167/481] 34745: Love Is a Battlefield
2020-03-15 19:22:10.615 T:28948  NOTICE: EMBY.objects.tvshows -> USERDATA episode [3186/486] 34793: A Girl Named Sue
2020-03-15 19:22:10.649 T:28948  NOTICE: EMBY.objects.tvshows -> USERDATA episode [3211/499] 34849: Grodd Friended Me
(...)
2020-03-15 19:22:13.352 T:28948  NOTICE: EMBY.database -> [emby] 56 rows updated.
2020-03-15 19:22:13.354 T:28948  NOTICE: EMBY.database -> [video] 56 rows updated.
2020-03-15 19:22:13.355 T:28948  NOTICE: EMBY.library -> --<[ q:userdata/151150109472 ]
2020-03-15 19:22:14.487 T:26012  NOTICE: EMBY.library -> -->[ q:userdata/Season/151127287200 ]
2020-03-15 19:22:14.530 T:28949  NOTICE: EMBY.objects.tvshows -> USERDATA season [None/19] 19920: Season 6
2020-03-15 19:22:14.563 T:28949  NOTICE: EMBY.objects.tvshows -> USERDATA season [None/40] 20231: Season 6
2020-03-15 19:22:14.597 T:28949  NOTICE: EMBY.objects.tvshows -> USERDATA season [None/19] 19920: Season 6
2020-03-15 19:22:14.630 T:28949  NOTICE: EMBY.objects.tvshows -> USERDATA season [None/40] 20231: Season 6
2020-03-15 19:22:14.659 T:28949  NOTICE: EMBY.objects.tvshows -> USERDATA season [None/19] 19920: Season 6

Based on the log, a lot of movies/episodes/seasons seem to be repeated multiple times because based on the information above it may look like I have 752 movies which is not true, I have barely over 100.

 

Any idea what's going on with my library?

Link to comment
Share on other sites

Hi, what version of Emby Server , Kodi, and the addon?

Hello, I'm using:

  • Kodi v18.6 (Android)
  • Emby Server v4.4.0.18 beta
  • plugin.video.emby v4.0.14a

    plugin.video.emby.movies v0.14

    plugin.video.emby.musicvideos v0.14

    plugin.video.emby.tvshows v0.14

Link to comment
Share on other sites

Ok well for starters i would update your emby server.

I usually have it updated all the time, it's just that it wasn't updated when you asked me :D

 

But like I said, this issue has been going for a few months now, it's not recent.

 

Anyway, I have updated it now and the issue persists.

Link to comment
Share on other sites

I usually get this message but I don't have any noticeable issues with emby & kodi staying in sync.  I wonder if it is iterating through the entire database, and checking the status of and updating rows for things like fanart, coverart, etc.  Also, I'm on the stable release currently. 

Edited by jachin99
Link to comment
Share on other sites

I usually get this message but I don't have any noticeable issues with emby & kodi staying in sync.  I wonder if it is iterating through the entire database, and checking the status of and updating rows for things like fanart, coverart, etc.  Also, I'm on the stable release currently. 

I could try reverting both Emby and the add-ons to the stable releases and see if that makes a difference. What would be the best approach/order to downgrade things?

Link to comment
Share on other sites

You can also try vacuuming your emby db, and then resetting your local Kodi database to see if that speeds things up. I would backup emby and probably the PC itself before I did that though

Link to comment
Share on other sites

You can also try vacuuming your emby db

How do I do that?

 

 

I would backup emby and probably the PC itself before I did that though

No need for such extreme measures, I have Emby running in a Docker container.

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...