Jump to content

AppleTV 4 - Trailers - Unable to Fetch Data


plaidstallion
 Share

Recommended Posts

plaidstallion

Hello, I recently installed the trailers plugin and set it to play 2 movies before every movie. That behavior happens sometimes and sometimes not. I am not quite sure why. A bigger issue is that when I go to the "latest trailers" menu and try to play any trailer I get the error "Unable to Fetch Data Line: 37 Message: undefined is not an object (evaluating 'this.boxSet.backgroundImgUrl=o.default.defaultBackgroundImage()')"

 

Trailers work from this menu when I open Emby in a browser on my Windows laptop.

 

I have AppleTV client version 1.4.4 -- Released 29 Jan 2020.

 

If it matters, the server is 4.3.1.0 running from a Podman container on Fedora 31 (emby/embyserver:latest)

Edited by plaidstallion
Link to comment
Share on other sites

plaidstallion

@@plaidstallion -- this should be fixed in our next beta release.

Of the AppleTV client I am assuming? Just for fun I tried the beta server 4.4.0.22 but it was the same issue.

Link to comment
Share on other sites

Of the AppleTV client I am assuming? Just for fun I tried the beta server 4.4.0.22 but it was the same issue.

 

Yes, @@corey is the developer of the application for Apple TV. Thanks @@corey!

Link to comment
Share on other sites

plaidstallion

@@corey How do I force update past 1.4.4? I see there is a 1.5.3 for IOS but have no idea how to force the AppleTV to grab that.

Link to comment
Share on other sites

@@corey How do I force update past 1.4.4? I see there is a 1.5.3 for IOS but have no idea how to force the AppleTV to grab that.

 

Hi.  iOS and Apple TV (tvOS) are two different apps.

Link to comment
Share on other sites

plaidstallion

Hi. iOS and Apple TV (tvOS) are two different apps.

Yep. Sorry. Not sure why I thought they were the same. I'll keep waiting then :)

Link to comment
Share on other sites

Hi Guys,

 

I´m really new in the EMBY usage, but I got a big problem while using the app on Apple TV.

No Trailers are shown and the badest thing, when I use 4K content I got a "rainbow effect"....a horrible picture!

 

While using the iOS App, alle fine, got theme music / trailers available all good, same at fire TV.

 

So where's the problem in the Apple TV App?

 

Thanks in advance!

 

HI there @@SteveJobs can we please look at an example? Please attach the information requested in how to report a media playback issue. Thanks !

Link to comment
Share on other sites

Hi Luke,

 

attached two pictures, one shows no trailers available to choose also is no theme music playing.

Second picture shows the rainbow color at a 4k movie, sorry tough to take a picture of it.

Also I add the the logs

 

The problem is not 4K, the problem is HDR. Current MPV player does not support HDR.

Link to comment
Share on other sites

Thank you @@vdatanet

 

just see that all my 4k also are HDR content.

Actually I'm also looking to buy the Nvidia Shield TV (2017) to use instead of my Apple TV 4K. I hope this give me a better experience

 

.....the 2019 shield is not available.....nowhere......

 

Yes, with the shield you will get a better experience. I use both Shield and Apple TV. Emby for Android TV is a great application, but whenever I can I use Apple TV.

Link to comment
Share on other sites

  • 1 month later...
plaidstallion

Has this issue been resolved? If so how do I pull the beta release to my AppleTV? I had the issue a week or so ago still and I believe the AppleTV client version was 1.4.4 -- Released 29 Jan 2020.

Link to comment
Share on other sites

Has this issue been resolved? If so how do I pull the beta release to my AppleTV? I had the issue a week or so ago still and I believe the AppleTV client version was 1.4.4 -- Released 29 Jan 2020.

 

Hi.  To exactly what issue are you referring?

 

P.S.  We will have a new release of the app next week.

Link to comment
Share on other sites

P.S. We will have a new release of the app next week.

You mean the release that still has a lot of bugs ?

Link to comment
Share on other sites

plaidstallion

Hi.  To exactly what issue are you referring?

 

P.S.  We will have a new release of the app next week.

 

The OP. That was why I asked here. Corey said on 8 March that it would be fixed in the next beta release. I still have the issue and the same version of the app on my AppleTV though. I'm now running on the latest version of the server on Docker with Fedora 32 and still the same problem on the AppleTV.

 

Hello, I recently installed the trailers plugin and set it to play 2 movies before every movie. That behavior happens sometimes and sometimes not. I am not quite sure why. A bigger issue is that when I go to the "latest trailers" menu and try to play any trailer I get the error "Unable to Fetch Data Line: 37 Message: undefined is not an object (evaluating 'this.boxSet.backgroundImgUrl=o.default.defaultBackgroundImage()')"

 

Trailers work from this menu when I open Emby in a browser on my Windows laptop.

 

I have AppleTV client version 1.4.4 -- Released 29 Jan 2020.

 

If it matters, the server is 4.3.1.0 running from a Podman container on Fedora 31 (emby/embyserver:latest)

 

I'm not sure why this topic became a hot bed of off topic but I sure did get a lot of notification spam from it for awhile.

Edited by plaidstallion
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...