Jump to content

Apple TV app does not connect to server


nedokot
 Share

Recommended Posts

Hello!

 

I have recently installed server app on my home server (windows server 2012 R2, app version 4.3.1.0) and application on my apple TV 4K (version 1.4.4)

 

However the TV app could not connect to the server right from the beginning and does not show any connection options as it is suggested on the support page (see screenshot attached)

 

Both apple TV and the server are in the same network (Plex, for example, works seamlessly)

 

Thanks in advance for any help!

post-589146-0-27388100-1582118582_thumb.jpg

Link to comment
Share on other sites

Hello!

 

I have recently installed server app on my home server (windows server 2012 R2, app version 4.3.1.0) and application on my apple TV 4K (version 1.4.4)

 

However the TV app could not connect to the server right from the beginning and does not show any connection options as it is suggested on the support page (see screenshot attached)

 

Both apple TV and the server are in the same network (Plex, for example, works seamlessly)

 

Thanks in advance for any help!

 Maybe It wasn't able to fetch application JavaScript. Apple TV has internet connection? Internet connection is required for Emby for Apple TV.

Edited by vdatanet
Link to comment
Share on other sites

 Maybe It wasn't able to fetch application JavaScript. Apple TV has internet connection? Internet connection is required for Emby for Apple TV.

Yes it does, and both on the same network

Link to comment
Share on other sites

It's not a login problem, something is blocking application javascript fetch.

Any ideas what might help? My Samsung TV shows emby app icon and could access the server,  plays bluray folders and it is on the same network

Link to comment
Share on other sites

Just found some alerts on the dashboard:

 

Webhooks installation failed

Connection to https://embydata.com/admin/service/packageFiles/Emby.Webhooks.dll_1.0.9.exe timed out

 

Tvdb installation failed

Connection to https://embydata.com/admin/service/packageFiles/Tvdb.dll_1.0.29.exe timed out

 

StudioImages installation failed

Connection to https://embydata.com/admin/service/packageFiles/StudioImages.dll_1.0.3.exe timed out

 

Port Mapper installation failed

Connection to https://embydata.com/admin/service/packageFiles/Emby.PortMapper.dll_1.0.3.exe timed out

Link to comment
Share on other sites

Hi.  Yes, it appears something in your network (or perhaps ISP) is blocking access to our server.  Can you correct this?

Link to comment
Share on other sites

Hi.  Yes, it appears something in your network (or perhaps ISP) is blocking access to our server.  Can you correct this?

Yes, I called ISP, they said they cannot connect to your ip area, was it changed recently?

Link to comment
Share on other sites

Yes, I called ISP, they said they cannot connect to your ip area, was it changed recently?

 

No, it's been the same for many years.

Link to comment
Share on other sites

We're going to be removing this connectivity requirement in an upcoming update so hopefully in the not too distant future it won't matter anymore.

Link to comment
Share on other sites

We're going to be removing this connectivity requirement in an upcoming update so hopefully in the not too distant future it won't matter anymore.

 

Great! And I hope my ISP sorts things out shortly ) From the first look you've got a great product, by far better than plex!

Link to comment
Share on other sites

We're going to be removing this connectivity requirement in an upcoming update so hopefully in the not too distant future it won't matter anymore.

 

Just to be clear, this is just for running the app.  If your ISP continues to block our IP then there will be other problems.  So that will still need to be solved.

Link to comment
Share on other sites

Do you get the same error? Are credentials requested? Note that the Apple TV host name must not contain non-ASCII characters.

Link to comment
Share on other sites

Funny - just learned that your IP 104.27.191.149 was blocked in Russia back in 2018 by request of tax service (kind of our IRS) as it was used by illegal online gambling site new-vulcan-slots.com (https://reestr.rublacklist.net/record/821839/ - it is in Russian, but google translate might help)

 

That's not our IP address...  It belongs to CloudFlare though so something may be getting routed through there.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...