Jump to content


Photo

Kodi mit Emby-Addon Fehler 403 bei Proxy in Kodi - Nur Windows Problem


  • Please log in to reply
3 replies to this topic

#1 vk_digi OFFLINE  

vk_digi

    Advanced Member

  • Members
  • 30 posts
  • Local time: 08:01 AM

Posted 14 February 2020 - 05:15 AM

Guten Tag,

 

ich habe mehrere Installation in der Kombination Kodi (18.5) mit Emby-Addon am laufen. Ich hab zusätzlich noch jeweils das Zattoo-PVR Addon installiert. Damit ich hier aus DE vollen Zugriff habe, hab ich im Kodi einen http Proxy auf einen Server in der Schweiz aktiviert. 

 

Das klappt auf allen Kisten sei es Fire TV Stick oder Pi3. Nur unter Windows gibt es ein Problem beim Zugriff auf die Stream im Emby-Server (der steht in Ger Data-Center).

 

Die Daten und Bilder werden alle korrekt angezeigt. Jedoch kann ich keinen Stream starten. Ich sehe im Logfile einen Fehler 403 - was wohl bedeutet, dass der Zugriff verweigert wurde. Im Logfile vom Emby-Server ist kein Zugriff zu sehen.

 

Als muss also bei Zugriff auf den Proxy mit IP 127.0.0.1 (lokal) abgewiesen werden. 

 

Wenn ich den Proxy im Kodi deaktiviere klappt alles wie es soll. Ich muss jedoch  eine Umleitung auf Schweiz machen wegen Zattoo und den bekannten Gründen.

 

Was kann ich da tun? 

 

Muss ich echt zwei Kodi-Installation auf der Win-Kiste (HTPC) haben einen mit Proxy für Zattoo und einen ohne für Emby? Das wäre nicht was mich wirklich begeistern würde.

 

Gruss 

MeinerEiner



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:01 AM

Posted 14 February 2020 - 12:34 PM

Hi there, sounds like you need to configure the reverse proxy. What reverse proxy are you using? If you are using nginx then I would suggest comparing your nginx configuration to that of @pir8radio.



#3 vk_digi OFFLINE  

vk_digi

    Advanced Member

  • Members
  • 30 posts
  • Local time: 08:01 AM

Posted 14 February 2020 - 03:13 PM

Hallo,

 

nein das ist nicht so. Also nochmals kurz der Weg. 

 

Stick Fire TV:

Kodi,Emby-Addon,Proxy innerhalb von KODI, Router,Proxy in der Schweiz, Emby-Server Data-Center. Das klappt ohne jedes Problem

 

Windows:

Wie oben. Klappt nicht. Da in den Logs vom Emby-Server nichts zu finden ist und im Log vom Proxy in der Schweiz auch nicht, kommt der Fehler 403 aus meiner Sicht vom Proxy im KODI bzw beim Zugriff vom Kodi-Emby-Addon auf den Proxy innerhalb vom Kodi.

 

Sobald ich den Proxy-Zugriff im Kodi ausmache klappt auch der Zugriff in Windows Problem los.

 

Es liegt also an der Kombination Zugriff Emby-Add-On über Kodi-Proxy auf die IP 127.0.0.1....Der Proxy von Kodi bring 403. Warum auch immer.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:01 AM

Posted 19 February 2020 - 01:02 PM

Ok, I don't fully understand this situation so I'm not sure what the answer is yet. Did you figure this out?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users