Jump to content


Photo

Cannot watch during library scan


Best Answer henriquefer , 19 February 2020 - 10:29 AM

Are you still running into this?

 

 

I improved the performance of my samba share, and it solved the issue.

 

I added the following lines to my /etc/samba/smb.conf file

socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
read raw = yes
write raw = yes
max connections = 65535
max open files = 65535
max xmit = 65535

Thank you.

Go to the full post


  • Please log in to reply
5 replies to this topic

#1 henriquefer OFFLINE  

henriquefer

    Advanced Member

  • Members
  • 38 posts
  • Local time: 07:01 AM

Posted 10 February 2020 - 07:14 AM

Hi,

 

I have my server on a Nvidia Shield TV, and it is impossible to stream any type of content without lag when emby server is performing library scan.

Is it normal?

Can the library scan be performed with low priority? 

 

Best regards



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:01 AM

Posted 10 February 2020 - 01:38 PM

Hi there, can we please look at an example? Thanks.



#3 henriquefer OFFLINE  

henriquefer

    Advanced Member

  • Members
  • 38 posts
  • Local time: 07:01 AM

Posted 10 February 2020 - 01:43 PM

Hi there, can we please look at an example? Thanks.

 

 

When the library is being scanned, the interface becomes extremely slow and laggy. Then, if I tried to play something, it is impossible. 

When I stop the library scan, everything becomes fine again.

 

Emby server log sent by PM.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:01 AM

Posted 18 February 2020 - 05:14 PM

Are you still running into this?



#5 henriquefer OFFLINE  

henriquefer

    Advanced Member

  • Members
  • 38 posts
  • Local time: 07:01 AM

Posted 19 February 2020 - 10:29 AM   Best Answer

Are you still running into this?

 

 

I improved the performance of my samba share, and it solved the issue.

 

I added the following lines to my /etc/samba/smb.conf file

socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
read raw = yes
write raw = yes
max connections = 65535
max open files = 65535
max xmit = 65535

Thank you.


  • ebr likes this

#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:01 AM

Posted 19 February 2020 - 12:40 PM

Thanks for the feedback.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users