Jump to content
richwphillips@yahoo.com

Missing Seasons In Some TV Shows

Recommended Posts

Luke

Can you show us the complete folder contents? Thanks.

Share this post


Link to post
Share on other sites
ewer0012
Posted (edited)

Can you show us the complete folder contents? Thanks.

For the Season?

 

I'm in the process of removing all Metadata and redownloading it to see if there was something weird there.

post-82314-0-96814200-1583377087_thumb.png

Edited by ewer0012

Share this post


Link to post
Share on other sites
Luke

For the entire series please. Thanks.

Share this post


Link to post
Share on other sites
ewer0012

Attached

post-82314-0-76131100-1583378074_thumb.png

Share this post


Link to post
Share on other sites
ewer0012

Sorry, somehow ended up posting before I attached the other ones.

post-82314-0-91199100-1583378330_thumb.png

post-82314-0-21406600-1583378335_thumb.png

post-82314-0-54181100-1583378339_thumb.png

post-82314-0-18744000-1583378344_thumb.png

post-82314-0-21911200-1583378349_thumb.png

post-82314-0-79706900-1583378353_thumb.png

post-82314-0-23418500-1583378358_thumb.png

Share this post


Link to post
Share on other sites
Luke

Sorry, somehow ended up posting before I attached the other ones.

 

Hmm, that's strange. Looks good from here. Can you try refreshing the metadata on that series and see if that helps?

Share this post


Link to post
Share on other sites
ewer0012

Yeah, it only started happening after one of the recent patches that came out. Super strange, since it's not with all of the shows I have, just a smattering. It seems to be growing in scale, though. A week or so ago it was only reported to me that one series was doing it. Now it's at least a dozen.

 

I deleted all metadata from the folders last night and then kicked off a refresh before going to bed. Still missing seasons for several shows.

 

I've had things set up to be auto-named with new folder structures created as new shows/seasons come out (through Sonarr) and everything has worked well for years... Pretty much flawlessly. 

Share this post


Link to post
Share on other sites
ewer0012

If I look in the Metadata Manager it doesn't show the seasons. Huh.

Share this post


Link to post
Share on other sites
Happy2Play

If I look in the Metadata Manager it doesn't show the seasons. Huh.

Can you test a portable and see if you get the same results with these series?  

 

https://emby.media/windows-server.html

Share this post


Link to post
Share on other sites
ewer0012

Can you test a portable and see if you get the same results with these series?  

 

https://emby.media/windows-server.html

Yep, I'll give it a go once I get home from work. Thanks for the suggestion! :)

Share this post


Link to post
Share on other sites
chstoll
Posted (edited)

I managed to fix the issue in my case. As I speculated, there where obviously some broken Database-Entrys. Here is what I did (SQL-Knowledge is needed):

 

For example, Ray Donovan Season 7 would not be regonized by emby (tried everything, DB-Scan, delete complete series and added it again and so on)

 

So I took the DB Browser for SQL-Lite, and opened the library-db-file.

 

1. Although Season 7 wouldn't be recognized, there where a few entrys referencing the path in the table MediaItems (select * from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%';)

2 I tried to delete those entrys, but first all entrys in other tables with forein key-constraints (tables AncestorsID2, Chapters3, ItemLinks, ItemPeople, MediaStreams2) had to be deleted (like "delete from ItemPeople where ItemPeople.ItemId in (select ItemID from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%')")

3. Then I finally could delete the entrys in MediaItems (delete from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%';)

4. Restarted Emby, did a library scan and BAZINGA, Season 7 appeared correctly in Emby.

 

And I also managed to fix the annoying "auto-organize-plugin showing the same season multiple times" issue just by doing the similar thing as above, only with the query "select ItemId from MediaItems where parentid is NULL and type = 6" and then "delete from MediaItems where parentid is NULL and type = 6"

 

Maybe the Emby-Team can implement a better cleanup/repair-task, where all paths are verified and broken db-entrys are fixed automatically. The question for sure is, why those entrys appear in the first place.

Edited by chstoll
  • Like 1

Share this post


Link to post
Share on other sites
Happy2Play

They majority of these issues usually come back to a database issue.  So it is a matter of figuring out why as it does not affect everyone.

Share this post


Link to post
Share on other sites
Luke

I managed to fix the issue in my case. As I speculated, there where obviously some broken Database-Entrys. Here is what I did (SQL-Knowledge is needed):

 

For example, Ray Donovan Season 7 would not be regonized by emby (tried everything, DB-Scan, delete complete series and added it again and so on)

 

So I took the DB Browser for SQL-Lite, and opened the library-db-file.

 

1. Although Season 7 wouldn't be recognized, there where a few entrys referencing the path in the table MediaItems (select * from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%';)

2 I tried to delete those entrys, but first all entrys in other tables with forein key-constraints (tables AncestorsID2, Chapters3, ItemLinks, ItemPeople, MediaStreams2) had to be deleted (like "delete from ItemPeople where ItemPeople.ItemId in (select ItemID from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%')")

3. Then I finally could delete the entrys in MediaItems (delete from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%';)

4. Restarted Emby, did a library scan and BAZINGA, Season 7 appeared correctly in Emby.

 

And I also managed to fix the annoying "auto-organize-plugin showing the same season multiple times" issue just by doing the similar thing as above, only with the query "select ItemId from MediaItems where parentid is NULL and type = 6" and then "delete from MediaItems where parentid is NULL and type = 6"

 

Maybe the Emby-Team can implement a better cleanup/repair-task, where all paths are verified and broken db-entrys are fixed automatically. The question for sure is, why those entrys appear in the first place.

 

Hi, you don't by any chance have a copy of the database from before you did that, do you?

Share this post


Link to post
Share on other sites
chstoll

Hi, you don't by any chance have a copy of the database from before you did that, do you?

 

I did a backup from the database before fiddeling around, of course B) 

I send you a link per pm with the db before and after the cleanup having successfully added Season 7.

Share this post


Link to post
Share on other sites
Luke

I did a backup from the database before fiddeling around, of course B)

I send you a link per pm with the db before and after the cleanup having successfully added Season 7.

 

Thanks !

 

Curious, when this happened, was the episode available in global areas such as searching for it by name, or the episodes tab under the tv library?

Share this post


Link to post
Share on other sites
Luke

Also what plugins have you installed?

Share this post


Link to post
Share on other sites
chstoll

The folder Season 7 contained 3 episodes, but the whole season 7 (non of episodes) was not available, neither in MetaData-Manager, nor in TV-Series.

 

Plugins:

Auto Box Sets

Auto Oranize

Blueray Folder Support

Cinema Intros

DLNA

DVD Folder Support

Fanart.tv

IMVDb

Kodi Companion

MovieDB

MusicBrainz

Nfo Metadata

OMDb

Open Subtitles

Port Mapper

Studio Images

Telegram Notifications

TheAudoDB

TheTVDB

Webhooks

 

I did not realize I had so many Plugins, most of them where added automatically I think.

Share this post


Link to post
Share on other sites
Luke

So you don't remember if you could locate the episodes by searching for them?

Share this post


Link to post
Share on other sites
chstoll

I did not use the search. But through TV-Series - Ray Donovan it was not available. If it helps I could load the old DB once again and test the search.

Share this post


Link to post
Share on other sites
Luke

That would be great, thanks !

Share this post


Link to post
Share on other sites
ewer0012

Tried the portable version and things showed up fine. In the process of reimporting my whole TV shows folder (Named differently in the Emby library) after removing it from my Library and running a full scan to clear out the entries. With how much I have in that directory, it'll probably be a day or more before it finishes the import.

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback.

Share this post


Link to post
Share on other sites
ewer0012

Thanks for the feedback.

 

Anytime. If there's something else that you'd like me to try, just let me know and I'll do my best.

 

Preliminary results are that removing the library entry in Emby, performing a full scan, then re-adding the library under a different name (eg: TV -> Television) is showing all seasons. With any luck this will be the quick-ish and easy solution. :)

 

Thank you for all the hard work you put into making Emby great!

Share this post


Link to post
Share on other sites
ewer0012

Preliminary results are that removing the library entry in Emby, performing a full scan, then re-adding the library under a different name (eg: TV -> Television) is showing all seasons. With any luck this will be the quick-ish and easy solution. :)

 

 

Just wanted to report that this fixed the issue. Just had to add the path under a different library name.

 

As an experiment I tried re-adding the path under the same library name as before and ran into the same issue... I haven't gotten a chance to look into the database file to see what it could be, but it seems like removing the original library and doing a full scan didn't get rid of the entries for that library name.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...