Jump to content


Photo

Missing Seasons In Some TV Shows

tv shows seasons misssing

  • Please log in to reply
48 replies to this topic

#21 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152846 posts
  • Local time: 04:08 AM

Posted 22 February 2020 - 02:59 PM

Yes I did, thanks.

#22 ewer0012 OFFLINE  

ewer0012

    Member

  • Members
  • 17 posts
  • Local time: 04:08 AM
  • LocationVirginia

Posted 04 March 2020 - 09:33 PM

All Paths look like this:

"D:\TV-Serien\Ray Donovan\Season 1\Ray Donovan - S01E01 - Vater unser.mkv"

 

As for this series, initially the series folder name was followed by the year of release - Ray Donovan (2013). But after adding season 4 or 5, emby would not recognize the new series. I also noticed, that no metadata (.nfo) was added. So I tried libray scans, deleted the whole series, added it again multiple times. Sometimes, it only recognized the newly added season, but all others where missing, sometimes it recognized all expect the newly added. So I ended up but putting it into a complete new folder (without the year) and then everything was correctly added to the library.

 

And this is reproduceable:

 

-Delete the series with the Metadata-Manager (check that all folders have been removed)

-Do a libray scan

-Add the series again in the folder followed by the year

-Do a library scan

-Series is not added to the library successfully (although a push message is created that states that the episode has been added successfully)

 

My only explanation are some broken database entrys, which are not cleaned up correctly.

 

I'm encountering the same issue with TV seasons not showing up and it seems to be getting worse. A week ago it was 1 TV show, now it's most of them.

 

My folder structure is all set up like this:

 

..\Video\TV Shows\House\Season 1\House - S01E01 - Pilot.mkv

 

If y'all are still offering a support session, I'd be happy to make myself available at some point.

 

Edit:

 

I wanted to note that it'll happen on shows regardless of whether or not it has a year in the show's folder name.

 

Edit 2:

 

For example, Letterkenny's folder structure is attached, along with what the Emby Client shows.

 

Edit 3:

 

I tried a "Scan Media Library," a Vacuum by editing the system.xml and setting VacuumDatabaseOnStartup to "true", as well as using sqlite to run a vacuum, analyze, and reindex of the library.db

 

Edit 4:

 

When I first noticed the issue I removed the "TV Shows" library from the Library list on the Emby Server and recreated it as "TV" after doing a Scan Media Library task. Once I added it, I ran another Scan Media Library task and the shows that were missing episodes before were still missing episodes.

Attached Files


Edited by ewer0012, 04 March 2020 - 09:51 PM.


#23 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18365 posts
  • Local time: 01:08 AM
  • LocationWashington State

Posted 04 March 2020 - 09:52 PM

I'm encountering the same issue with TV seasons not showing up and it seems to be getting worse. A week ago it was 1 TV show, now it's most of them.

 

My folder structure is all set up like this:

 

..\Video\TV Shows\House\Season 1\House - S01E01 - Pilot.mkv

 

If y'all are still offering a support session, I'd be happy to make myself available at some point.

 

Edit:

 

I wanted to note that it'll happen on shows regardless of whether or not it has a year in the show's folder name.

 

Edit 2:

 

For example, Letterkenny's folder structure is attached, along with what the Emby Client shows.

 

Edit 3:

 

I tried a "Scan Media Library," a Vacuum by editing the system.xml and setting VacuumDatabaseOnStartup to "true", as well as using sqlite to run a vacuum, analyze, and reindex of the library.db

First I would check the episode nfo files, do they contain all the right information?  Can you post one.



#24 ewer0012 OFFLINE  

ewer0012

    Member

  • Members
  • 17 posts
  • Local time: 04:08 AM
  • LocationVirginia

Posted 04 March 2020 - 09:59 PM

Hmm... I'm noticing in the tvshow.nfo it has:

 

  </episodeguide>
  <season>-1</season>
  <episode>-1</episode>
 
It wouldn't let me upload the episode NFO file for some reason, so here it is:
 
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<episodedetails>
  <plot>Daryl and Katy try to help Wayne get some action, while Wayne reconnects with his inner fighter.</plot>
  <outline />
  <lockdata>false</lockdata>
  <dateadded>2019-01-16 13:18:53</dateadded>
  <title>Ain't No Reason to Get Excited</title>
  <director>Jacob Tierney</director>
  <rating>9</rating>
  <year>2016</year>
  <imdbid>tt4762044</imdbid>
  <tvdbid>5397918</tvdbid>
  <runtime>23</runtime>
  <art>
    <poster>\\10.0.1.42\Video\TV Shows\Letterkenny\Season 1\Letterkenny - S01E01 - Ain't No Reason to Get Excited-thumb.jpg</poster>
  </art>
  <episode>1</episode>
  <season>1</season>
  <aired>2016-02-07</aired>
  <fileinfo>
    <streamdetails>
      <video>
        <codec>h264</codec>
        <micodec>h264</micodec>
        <bitrate>5502046</bitrate>
        <width>1920</width>
        <height>1080</height>
        <aspect>16:9</aspect>
        <aspectratio>16:9</aspectratio>
        <framerate>23.976025</framerate>
        <scantype>progressive</scantype>
        <default>True</default>
        <forced>False</forced>
        <duration>23</duration>
        <durationinseconds>1380</durationinseconds>
      </video>
      <audio>
        <codec>aac</codec>
        <micodec>aac</micodec>
        <bitrate>192000</bitrate>
        <scantype>progressive</scantype>
        <channels>2</channels>
        <samplingrate>48000</samplingrate>
        <default>True</default>
        <forced>False</forced>
      </audio>
      <subtitle>
        <codec>subrip</codec>
        <micodec>subrip</micodec>
        <language>eng</language>
        <scantype>progressive</scantype>
        <default>False</default>
        <forced>False</forced>
      </subtitle>
    </streamdetails>
  </fileinfo>
</episodedetails>

 

Attached Files



#25 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18365 posts
  • Local time: 01:08 AM
  • LocationWashington State

Posted 04 March 2020 - 10:17 PM

 

Hmm... I'm noticing in the tvshow.nfo it has:

 

  </episodeguide>
  <season>-1</season>
  <episode>-1</episode>
 
It wouldn't let me upload the episode NFO file for some reason, so here it is:
 
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<episodedetails>
  <plot>Daryl and Katy try to help Wayne get some action, while Wayne reconnects with his inner fighter.</plot>
  <outline />
  <lockdata>false</lockdata>
  <dateadded>2019-01-16 13:18:53</dateadded>
  <title>Ain't No Reason to Get Excited</title>
  <director>Jacob Tierney</director>
  <rating>9</rating>
  <year>2016</year>
  <imdbid>tt4762044</imdbid>
  <tvdbid>5397918</tvdbid>
  <runtime>23</runtime>
  <art>
    <poster>\\10.0.1.42\Video\TV Shows\Letterkenny\Season 1\Letterkenny - S01E01 - Ain't No Reason to Get Excited-thumb.jpg</poster>
  </art>
  <episode>1</episode>
  <season>1</season>
  <aired>2016-02-07</aired>
  <fileinfo>
    <streamdetails>
      <video>
        <codec>h264</codec>
        <micodec>h264</micodec>
        <bitrate>5502046</bitrate>
        <width>1920</width>
        <height>1080</height>
        <aspect>16:9</aspect>
        <aspectratio>16:9</aspectratio>
        <framerate>23.976025</framerate>
        <scantype>progressive</scantype>
        <default>True</default>
        <forced>False</forced>
        <duration>23</duration>
        <durationinseconds>1380</durationinseconds>
      </video>
      <audio>
        <codec>aac</codec>
        <micodec>aac</micodec>
        <bitrate>192000</bitrate>
        <scantype>progressive</scantype>
        <channels>2</channels>
        <samplingrate>48000</samplingrate>
        <default>True</default>
        <forced>False</forced>
      </audio>
      <subtitle>
        <codec>subrip</codec>
        <micodec>subrip</micodec>
        <language>eng</language>
        <scantype>progressive</scantype>
        <default>False</default>
        <forced>False</forced>
      </subtitle>
    </streamdetails>
  </fileinfo>
</episodedetails>

 

Not seeing any issue here.  Only other thing would providing a server log after a library scan.



#26 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152846 posts
  • Local time: 04:08 AM

Posted 04 March 2020 - 10:55 PM

Can you show us the complete folder contents? Thanks.

#27 ewer0012 OFFLINE  

ewer0012

    Member

  • Members
  • 17 posts
  • Local time: 04:08 AM
  • LocationVirginia

Posted 04 March 2020 - 10:58 PM

Can you show us the complete folder contents? Thanks.

For the Season?

 

I'm in the process of removing all Metadata and redownloading it to see if there was something weird there.

Attached Files


Edited by ewer0012, 04 March 2020 - 10:59 PM.


#28 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152846 posts
  • Local time: 04:08 AM

Posted 04 March 2020 - 10:58 PM

For the entire series please. Thanks.

#29 ewer0012 OFFLINE  

ewer0012

    Member

  • Members
  • 17 posts
  • Local time: 04:08 AM
  • LocationVirginia

Posted 04 March 2020 - 11:14 PM

Attached

Attached Files



#30 ewer0012 OFFLINE  

ewer0012

    Member

  • Members
  • 17 posts
  • Local time: 04:08 AM
  • LocationVirginia

Posted 04 March 2020 - 11:19 PM

Sorry, somehow ended up posting before I attached the other ones.

Attached Files



#31 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152846 posts
  • Local time: 04:08 AM

Posted 05 March 2020 - 02:34 PM

Sorry, somehow ended up posting before I attached the other ones.

 

Hmm, that's strange. Looks good from here. Can you try refreshing the metadata on that series and see if that helps?



#32 ewer0012 OFFLINE  

ewer0012

    Member

  • Members
  • 17 posts
  • Local time: 04:08 AM
  • LocationVirginia

Posted 05 March 2020 - 02:42 PM

Yeah, it only started happening after one of the recent patches that came out. Super strange, since it's not with all of the shows I have, just a smattering. It seems to be growing in scale, though. A week or so ago it was only reported to me that one series was doing it. Now it's at least a dozen.

 

I deleted all metadata from the folders last night and then kicked off a refresh before going to bed. Still missing seasons for several shows.

 

I've had things set up to be auto-named with new folder structures created as new shows/seasons come out (through Sonarr) and everything has worked well for years... Pretty much flawlessly. 



#33 ewer0012 OFFLINE  

ewer0012

    Member

  • Members
  • 17 posts
  • Local time: 04:08 AM
  • LocationVirginia

Posted 05 March 2020 - 02:46 PM

If I look in the Metadata Manager it doesn't show the seasons. Huh.



#34 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18365 posts
  • Local time: 01:08 AM
  • LocationWashington State

Posted 05 March 2020 - 02:54 PM

If I look in the Metadata Manager it doesn't show the seasons. Huh.

Can you test a portable and see if you get the same results with these series?  

 

https://emby.media/windows-server.html



#35 ewer0012 OFFLINE  

ewer0012

    Member

  • Members
  • 17 posts
  • Local time: 04:08 AM
  • LocationVirginia

Posted 05 March 2020 - 02:56 PM

Can you test a portable and see if you get the same results with these series?  

 

https://emby.media/windows-server.html

Yep, I'll give it a go once I get home from work. Thanks for the suggestion! :)



#36 chstoll OFFLINE  

chstoll

    Member

  • Members
  • 11 posts
  • Local time: 09:08 AM

Posted 05 March 2020 - 06:34 PM

I managed to fix the issue in my case. As I speculated, there where obviously some broken Database-Entrys. Here is what I did (SQL-Knowledge is needed):

 

For example, Ray Donovan Season 7 would not be regonized by emby (tried everything, DB-Scan, delete complete series and added it again and so on)

 

So I took the DB Browser for SQL-Lite, and opened the library-db-file.

 

1. Although Season 7 wouldn't be recognized, there where a few entrys referencing the path in the table MediaItems (select * from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%';)

2 I tried to delete those entrys, but first all entrys in other tables with forein key-constraints (tables AncestorsID2, Chapters3, ItemLinks, ItemPeople, MediaStreams2) had to be deleted (like "delete from ItemPeople where ItemPeople.ItemId in (select ItemID from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%')")

3. Then I finally could delete the entrys in MediaItems (delete from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%';)

4. Restarted Emby, did a library scan and BAZINGA, Season 7 appeared correctly in Emby.

 

And I also managed to fix the annoying "auto-organize-plugin showing the same season multiple times" issue just by doing the similar thing as above, only with the query "select ItemId from MediaItems where parentid is NULL and type = 6" and then "delete from MediaItems where parentid is NULL and type = 6"

 

Maybe the Emby-Team can implement a better cleanup/repair-task, where all paths are verified and broken db-entrys are fixed automatically. The question for sure is, why those entrys appear in the first place.


Edited by chstoll, 05 March 2020 - 06:39 PM.

  • Happy2Play likes this

#37 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18365 posts
  • Local time: 01:08 AM
  • LocationWashington State

Posted 05 March 2020 - 06:44 PM

They majority of these issues usually come back to a database issue.  So it is a matter of figuring out why as it does not affect everyone.



#38 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152846 posts
  • Local time: 04:08 AM

Posted 05 March 2020 - 09:47 PM

I managed to fix the issue in my case. As I speculated, there where obviously some broken Database-Entrys. Here is what I did (SQL-Knowledge is needed):

 

For example, Ray Donovan Season 7 would not be regonized by emby (tried everything, DB-Scan, delete complete series and added it again and so on)

 

So I took the DB Browser for SQL-Lite, and opened the library-db-file.

 

1. Although Season 7 wouldn't be recognized, there where a few entrys referencing the path in the table MediaItems (select * from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%';)

2 I tried to delete those entrys, but first all entrys in other tables with forein key-constraints (tables AncestorsID2, Chapters3, ItemLinks, ItemPeople, MediaStreams2) had to be deleted (like "delete from ItemPeople where ItemPeople.ItemId in (select ItemID from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%')")

3. Then I finally could delete the entrys in MediaItems (delete from MediaItems WHERE Path like '%Ray Donovan (2013)\Season 7%';)

4. Restarted Emby, did a library scan and BAZINGA, Season 7 appeared correctly in Emby.

 

And I also managed to fix the annoying "auto-organize-plugin showing the same season multiple times" issue just by doing the similar thing as above, only with the query "select ItemId from MediaItems where parentid is NULL and type = 6" and then "delete from MediaItems where parentid is NULL and type = 6"

 

Maybe the Emby-Team can implement a better cleanup/repair-task, where all paths are verified and broken db-entrys are fixed automatically. The question for sure is, why those entrys appear in the first place.

 

Hi, you don't by any chance have a copy of the database from before you did that, do you?



#39 chstoll OFFLINE  

chstoll

    Member

  • Members
  • 11 posts
  • Local time: 09:08 AM

Posted 06 March 2020 - 08:00 AM

Hi, you don't by any chance have a copy of the database from before you did that, do you?

 

I did a backup from the database before fiddeling around, of course B) 

I send you a link per pm with the db before and after the cleanup having successfully added Season 7.



#40 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152846 posts
  • Local time: 04:08 AM

Posted 06 March 2020 - 07:22 PM

I did a backup from the database before fiddeling around, of course B)

I send you a link per pm with the db before and after the cleanup having successfully added Season 7.

 

Thanks !

 

Curious, when this happened, was the episode available in global areas such as searching for it by name, or the episodes tab under the tv library?







Also tagged with one or more of these keywords: tv shows, seasons, misssing

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users