Jump to content
Doctor Bob

ANSWERED Episode sort order is out of kilter

Recommended Posts

Doctor Bob

Hello all,

 

I am experiencing a episode sorting issue in Emby for Windows Media Center.

I have attached screenshots here.

 

The 8th episode appears at the top of the list, ascending to the last episode, followed by the first episode ascending the reminder. Very weird.

 

This issue began after Emby Server version 4.3.1.0 was installed.

 

Any ideas as to what is going on here?

 

 

P.S. I tried to force a ascending order using Emby Server Metadata Manger (Sort title: 01 for episode 1, etc). This did not change the order display.

The Metadata Manger shows episodes in ascending order with or without the forced Sort title in place.

 

 

Cheers

post-4778-0-64192600-1580773750_thumb.png

post-4778-0-65323100-1580774134_thumb.png

post-4778-0-94103000-1580775369_thumb.png

Edited by Doctor Bob

Share this post


Link to post
Share on other sites
Luke

Hi there, what theme is that?

Share this post


Link to post
Share on other sites
Doctor Bob

Default theme Chocolate version 3.0.307.0.

Edited by Doctor Bob

Share this post


Link to post
Share on other sites
Luke

I would try the latest beta version of emby for wmc. Please let us know if this helps. Thanks.

Share this post


Link to post
Share on other sites
Doctor Bob

Hello Luke,

 

Thank you for your help.

 

I downloaded and installed emby for wmv version 3.0.317.0

 

I did select the 'Latest Beta' at: https://emby.media/emby-for-windows-media-center.html

 

I then powered down the PC and powered back up again.

No change to the episode order. Oh dear.

Edited by Doctor Bob

Share this post


Link to post
Share on other sites
Luke

Ok yes I think the app will need an update.

Share this post


Link to post
Share on other sites
Doctor Bob

Hello Luke,

 

Not sure if I understand what you mean by, "app will need an update".

Which app are you referring to?

Share this post


Link to post
Share on other sites
Luke

Emby for wmc will need an update. In the meantime have you checked out our emby theater app?

Share this post


Link to post
Share on other sites
Doctor Bob

Oh, I see. I will be sure to update emby wmc when a new beta is released.

Yes, I have had a look at emby theater about six months ago.

I found that it worked alright but just did not match wmc.

I know I will have to move over to emby theater one day, just waiting on a smoother transition.

  • Like 1

Share this post


Link to post
Share on other sites
Doctor Bob

Hello Luke,

 

Sort order is a minor issue that I can live with in comparison to going to emby theater. Sorry about that.

 

I know we are off topic but here are some thoughts on the emby theate.

 

My initial encounter:

https://emby.media/community/index.php?/statuses/user/4778-doctor-bob/?status_id=988

 

Today's encounter:

I downloaded and installed version 3.0.6.

First time launch failed, worked the second time. Since then it usually takes two attempts to start emby theatre.

 

The GUI is much nicer since my last look at it.

However, functionally it is just not there yet.

 

While in the live TV guide I press the record button once on a show to record, that works.

When I press twice to record a series a spinning wheel of wait appears and does not go away and series recording is not activated.

 

In recorded TV I discovered that my latest recording had need converted. When I played the conversion it look horrible.

I discovered that it was converting for mobile devices by default. I found no place to permanently change that setting nor a place to abort the conversion.

But why would it need to convert it in the first place? Does emby theatre not play .wtv files?

I tried to view the original .wtv file but emby theatre would not play it.

.wtv playback would be a good feature. It works in emby wmc.

 

Then I went to play a movie. No go, only black screen with audio.

I went back to live TV and found the same, black screen, audio only.

I restarted emby server a few times, reboot the PC. No change.

 

Suggestion:

As a benchmark, set-up a PC with emby theatre and another with Windows Media Centre.

Compare the two for easy of use and functionality.

When the day comes when you can say that the emby theatre equals or betters the Windows Media Centre, that is when you will have it nailed.

 

 

 

Cheers,

 

Doctor Bob

Share this post


Link to post
Share on other sites
One2Go

I had the same issue every now and then some newly added episodes were not in the correct order. Since I use import from XML file as first choice and NFO as second choice I solved this by making sure that my XML file has the correct data especially representing episodes less then 10 as 07, 08 etc. rather then just 7 or 8.

 

After making sure the XML file is correct restarted the server scanned the TV library. Next I opened the metadata manager and made sure where I have the problems that the sorting entry reflects those values like for episodes I enter 01, 02 and so on.

 

In one case that was stubborn I removed the episode made sure of the correct XML file entries for episode number as well as season number. Restarted the server, then scanned the library and checked the correct metadata manager entry, again restarted the server, fired up EMC with the Throgmorton themes and everything was well in the TV world again.

 

The EMC app is in desperate need for updating but it has a very low priority until then you have to find tricks to get around limitations, it also helps to stay at a server version that has not inadvertently closed any loops that allow you to make unorthodox changes.

  • Like 1

Share this post


Link to post
Share on other sites
Doctor Bob

Good man! One2Go. You steered me in the right direction.

Yes, I do have nfo selected in my TV Shows library. These files appear to be .xml files just with a .nfo extension.

 

After a bit of hunting around inside these files I decided just to deleted all of them along with the metadata folder.

At this point the only files left in the season folder were the video files (.mkv). Then I refreshed the metadata.

 

Presto, sort order is now right!

 

Thank you for your help, most appreciated.

Yes, hopefully one day emby theatre will come into its own.

Edited by Doctor Bob
  • Like 1

Share this post


Link to post
Share on other sites
Luke

Great job guys.

Share this post


Link to post
Share on other sites
MikeyMan

I have the same issue... Will try the fix, but that doesn't explain root cause...

 

Especially since emby has created them itself.

 

Any thoughts?

Edited by MikeyMan

Share this post


Link to post
Share on other sites
Luke

Are you sure? Emby doesn't create xml anymore.

Share this post


Link to post
Share on other sites
One2Go

I have the same issue... Will try the fix, but that doesn't explain root cause...

 

Especially since emby has created them itself.

 

Any thoughts?

When Emby populates the fields in the metadata manager it may not always get it 100% right but it is rare that the episode order it incorrect. However for some obscure and foreign TV shows I have found this to be the case. The good news is that it is easy to sort the TV episodes using the metadata manager. When clicking on the 3 dots for the episode and selecting edit metadata, there is a field called Sort Title normally it is blank. However if there are difficulties with some episodes in a season then just enter numbers in this field that reflect something like 01 for the very first episode 02 for the second and so on until the number for your last episode. This will work UNLESS you have in the season folder either NFO or XML files that contain episode specific data then Emby will take that data from the files and populate the fields in the metadata manager. Therefore in the solution that is sited here you have to make sure of the correct data in any NFO or XML files that are associated with the episodes.

 

I learned this the hard way but the advantage is that this makes Emby very flexible and customizable especially for episodes that are either homegrown or can't be located in the metadata providing sites.

Share this post


Link to post
Share on other sites
MikeyMan

Are you sure? Emby doesn't create xml anymore.

 

Could be that some of them are coming from medusa maybe...

Deleted all nfo's yesterday... No solution. Should i remove all xmls now? 

Has a discrepancy been introduced between medusa (SickBeard) and emby? Never had issues until a couple of weeks before.

 

@One2Go; i don't change the xmls and nfos manually, so i hope we can get back to the right order without manual intervention...

Edited by MikeyMan

Share this post


Link to post
Share on other sites
One2Go

@One2Go; i don't change the xmls and nfos manually, so i hope we can get back to the right order without manual intervention...

However the XMLs or NFOs were created does matter at times since the creation process depends on the metadata sites to have proper data which is not always the case.

 

When you scan a library there is a setting that determines which is being read first XML or NFO files. Whichever file is being read first that is the data that will appear in Emby's metadata manager. So just take the TV shows that have seasons with episodes not in proper order and look at the metadata manager. What is in the Sort Title field? If there is an entry it will effect the sort order.

 

I have corrected in the metadata manager episode sorting only to discover that after the next library scan the episodes were again in incorrect order. I traced it back to incorrect entries in the associated XML file. Ones the XML file was corrected it worked fine.

 

One other way to do this is, again open the metadata manager for the episodes you want to correct and enter in the sort title field the proper numbers for correct sort order then lock the updating of the metadata and it will not change whatever you have done in the metadata manager. This is a onetime work ONLY for those seasons that are incorrect in their episode order.

Edited by One2Go

Share this post


Link to post
Share on other sites
MikeyMan

@@One2Go

 

Strangest thing is that all new seasons are off somehow. And after removing the nfos I can't find any sort order in the series.xml or the episode xmls...

Share this post


Link to post
Share on other sites
One2Go

The series,xml has nothing to do with episode sort orders. In the episode.xml you find entries that will determine the sort orders. For example my episode.xml file has the following entries:

<ID>3</ID>
<EpisodeID>7378442</EpisodeID>
<EpisodeNumber>3</EpisodeNumber>
<SeasonNumber>3</SeasonNumber>

This will be transferred into the metadata manager under season = 3 and episode = 3. It should sort on those values if the field Sort Title in the metadata manager is blank. You have to look in the web browser what is in those fields as that is what Emby uses for sorting episodes. I had to modify those entries for the Special/Extras folder for a TV Series as these extras are sometimes spread over years.
 

Share this post


Link to post
Share on other sites
MikeyMan

Looking at a random show, black-ish, currently episode 8 is at the top. 7 is at the bottom. The xmls look as follows:

 

<?xml version='1.0' encoding='UTF-8'?>

<Item>

<EpisodeName>Daughters for Dummies</EpisodeName>

<EpisodeNumber>7</EpisodeNumber>

<SeasonNumber>6</SeasonNumber>

<FirstAired>2019-11-12</FirstAired>

<Type>Episode</Type>

 

 

 

?xml version='1.0' encoding='UTF-8'?>

<Item>

<EpisodeName>O Mother Where Art Thou?</EpisodeName>

<EpisodeNumber>8</EpisodeNumber>

<SeasonNumber>6</SeasonNumber>

<FirstAired>2019-11-19</FirstAired>

<Type>Episode</Type>

 

Seems to be in order?

Share this post


Link to post
Share on other sites
One2Go

Post some screen shots if you can to show the problem you have.

 

However, what do the metadata manager fields look like? They determines the sort order especially the field "Sort Title".

Share this post


Link to post
Share on other sites
Luke

Is the order in the web app correct?

Share this post


Link to post
Share on other sites
MikeyMan

@@Luke order in the web app is ok.

 

Can't really easily post a screenshot?

Edited by MikeyMan

Share this post


Link to post
Share on other sites
One2Go

Can't really easily post a screenshot?

You got to be kidding on a Windows PC it is Alt + Print Screen and whatever is in the monitor will be copied to the clipboard. Paste it into Paint or your favorite picture editor and you are done.

 

However in each of my posts I asked you what is in the metadata manager and you have yet to answer this. So this is my last reply to help you in this thread as I feel that the problem is between keyboard and chair. Below are screenshots from one of my TV shows and also the areas that I asked you to look at.

 

Bring up Emby in the browser and click on the TV library icon.

5e584efa125b7_Sort1.jpg

 

This brings up the TV shows in the Library

5e584f193985d_Sort2.jpg

 

Select the show that has the problem

5e584f3cdf6e7_Sort3.jpg

 

Select the season that gives you problem and click the 3 dots and select edit meta data

5e584f91e8892_Sort4.jpg

 

Bring up the metadata and see what is in the fields for each episode especially the Sort Title.

5e584ff22766d_Sort5.jpg

 

 

You can force the sorting by entering numbers into the Sort Title field. I feel like I am repeating myself and state that in every post.

 

If the sort order is correct in the metadata manager or the web app then the problem is either with the theme or settings in the theme that you are using. Good luck with getting this problem corrected.

Edited by One2Go

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...