Jump to content

Transcoding Green Screen


feerlessleadr
 Share

Go to solution Solved by softworkz,

Recommended Posts

feerlessleadr

Hi All - similar to another post that I made a few weeks ago, I recently re-installed Windows 10 on my server running Emby. 

 

Prior to the re-install, transcoding worked on my server with Windows 10 (same version, just did a clean install) without problems with harware acceleration enabled. I just noticed that whenever I try to transcode anything after the re-install, I just get a green screen with sound. I used the backup addon to restore all of my settings, etc. after the re-install. 

 

I did a google search and I made sure that I installed the latest intel graphics driver from the intel website. I'm running a 4th gen Haswell Intel Core i7 4770. Just to be sure, I re-downloaded the latest x64 drivers, installed them and rebooted, but am still getting the green screen. See attached for my logs.

 

Thanks

embyserver.txt

ffmpeg-transcode-56fea1c5-824c-44d2-af42-3aeac6398299_1.txt

Link to comment
Share on other sites

feerlessleadr

Just wanted to bump this in case anyone has any ideas. 

 

@@Luke

Edited by feerlessleadr
Link to comment
Share on other sites

feerlessleadr

Turning off hardware transcoding does fix the green screen, however I've had it enabled on the same hardware configuration for over 2 or 3 years (since even before the jump from 3.6 to 4.0) with no green screen.

Link to comment
Share on other sites

Happy2Play

Or just disable h264_qsv decoding.

Edited by Happy2Play
Link to comment
Share on other sites

feerlessleadr

That also works. I'd still like to try and figure out why before my OS reinstall I was able to have all settings enabled vs. now I need to have quick sync h264 decoding disabled for it to work.

Link to comment
Share on other sites

feerlessleadr

So I have no idea what happened, but i re-enabled h264 quick sync decoding, and the green screen hasn't come back. I didn't make any other changes other than enabling and disabling the hardware transcoding settings earlier in this thread. 

 

Here is the hardware detection log though along with a link to the driver that I am running:

 

https://downloadcenter.intel.com/download/29313

 

 

hardware_detection-63716105346.txt

  • Like 1
Link to comment
Share on other sites

So I have no idea what happened, but i re-enabled h264 quick sync decoding, and the green screen hasn't come back. I didn't make any other changes other than enabling and disabling the hardware transcoding settings earlier in this thread. 

 

Here is the hardware detection log though along with a link to the driver that I am running:

 

https://downloadcenter.intel.com/download/29313

 

The driver matches QuickSync SDK version 1.20, which is pretty ok.

 

Do you use remote desktop?

Link to comment
Share on other sites

feerlessleadr

I do use remote desktop, as this is a mostly 'headless' server. I do have a composite cable plugged into my server and plugged into a monitor (the monitor stays on vga for use with my laptop though), since I've seen in the wiki that emby can't be run headless.

Link to comment
Share on other sites

  • Solution

That information is outdated. Your detection log indicates that the server was already running headless because there are only the D3D11 variants visible.

 

Just make sure you enable those QuickSync codecs having 'D3D11' in the name, then you should be fine. No monitor, no user session required.

 

Should you experience hw acceleration problems while logged in via RDP, follow these instructions: https://emby.media/community/index.php?/topic/82035-im-not-getting-hw-transcoding-with-my-j4105-nuc/?p=838313

  • Like 1
Link to comment
Share on other sites

feerlessleadr

I just wanted to update this thread since I figured out why everything just started working randomly after I reported my issue. Even with the hardware transcoding re-enabled, emby was falling back to software decoding, which is why me green screens just disappeared. 

 

@@softworkz I followed the instructions in your linked thread, and I only disabled the one setting (the one highlighted in your screenshot), rebooted my machine, and hardware transcoding works now. 

 

I suspect that even before my Windows 10 re-install, I didn't realize that my server was software transcoding everything, since I had never changed that setting before. I updated the 'best answer' of the thread to your response, as ultimately that is what solved the issue. 

 

Thanks again!

Edited by feerlessleadr
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...