Jump to content


Photo

upgrade from 4.2xx to 4.3.1.0 messed up library


  • Please log in to reply
14 replies to this topic

#1 boardbum OFFLINE  

boardbum

    Newbie

  • Members
  • 8 posts
  • Local time: 02:03 AM

Posted 26 January 2020 - 04:12 PM

So, I upgraded.  Now shows that were visible in my TV library are now not listed.  A bunch of stuff (I haven't been able to figure out all what) is now dumped in a show called "One Piece".  It contains many shows but it's all jumbled up so i can't even sort it.

 

DyW4Fxi.pngcPRNsyE.png

 

 

The show American Housewife (as well as Babylon 5, Star Trek, Delicious and more I; I gave up looking) are all in this One Piece.  As you can see from the images.  The Cast isn't even in any of them!

Searching for American Housewife give no results, but searching for an episode does: 

 

HOCEmHC.png

 

This also happened on my vps, but I was doing quite a bit of maintenance on it and thought I messed something up, so it's happened twice.  Everything was fine immediately before the upgrade. American Housewife was listed as we just watched an episode before I decided to come update.

 

 

Any advice?  I don't know what info is needed so just tell me what else I need.  



#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 17674 posts
  • Local time: 11:03 PM
  • LocationWashington State

Posted 26 January 2020 - 04:16 PM

What is your folder structure and what folder path is added to the library?



#3 boardbum OFFLINE  

boardbum

    Newbie

  • Members
  • 8 posts
  • Local time: 02:03 AM

Posted 26 January 2020 - 04:28 PM

Show Name

   Season #

       Episode (ex. American Housewife - S04E12 - Wildflower Girls SDTV.mkv)

 

 

This shouldn't matter as nothing has changed except the Emby version.  The folder structure was extant; nothing was added or changed and it was working fine until the upgrade.  It was immediate on my home pc, like I mentioned I wasn't paying that close attention to the vps when the problem happened.  I'm not even sure which version I was running, but I KNOW it was newer than the 4.2xxx I had on my home pc since I only installed emby on the vps in Dec 2019.

 

Thanks!



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:03 AM

Posted 26 January 2020 - 04:30 PM

What folder path is added to the library in library setup?

#5 boardbum OFFLINE  

boardbum

    Newbie

  • Members
  • 8 posts
  • Local time: 02:03 AM

Posted 26 January 2020 - 04:33 PM

All TV shows are in the folder /disks/4T/Series 

ITIZ61U.png

 

So for AH we have 

YExBBvh.png

 

 

EDIT: 

Not all have season folders.  some of my older manually added series just have the folder and series under that.

 

jIiQ8Ym.png


Edited by boardbum, 26 January 2020 - 04:35 PM.


#6 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 17674 posts
  • Local time: 11:03 PM
  • LocationWashington State

Posted 26 January 2020 - 04:37 PM

Are all series under /disks/4T/Series or are they nested in additional folders?



#7 boardbum OFFLINE  

boardbum

    Newbie

  • Members
  • 8 posts
  • Local time: 02:03 AM

Posted 26 January 2020 - 04:40 PM

/disks/4T/Series/American Housewife/Season 4

 

/disks/4T/Series  is the path to where series are stored each in their own folder.  Some have series folders (like american housewife) and some like Babylon 5 have all the episodes just under /disks/4T/Series/Babylon 5.



#8 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 17674 posts
  • Local time: 11:03 PM
  • LocationWashington State

Posted 26 January 2020 - 04:54 PM

Everything appears to be correct but the change in 4.3 with the Series detection system is having issues on your setup or it is a database issue in the migration.

 

Can you test moving a couple series out of your /disks/4T/Series folder,doing a library scan, creating a New Library and a New Series folder and adding those removed series to this new folder, do they appear properly?



#9 boardbum OFFLINE  

boardbum

    Newbie

  • Members
  • 8 posts
  • Local time: 02:03 AM

Posted 26 January 2020 - 05:07 PM

Moved the 4 series I could identify to a new folder /disks/4T/Series2.  Made a new library for this folder.  "One Piece" is no longer showing up in the Original library and the new library is displaying all 4 series correctly.



#10 boardbum OFFLINE  

boardbum

    Newbie

  • Members
  • 8 posts
  • Local time: 02:03 AM

Posted 26 January 2020 - 05:19 PM

I take it back.  when I checked again One Piece was back but it looks like it now a single series "Star Trek".  I don't see anything wrong with the file structure do you?

 

 

5eMrm9n.png



#11 boardbum OFFLINE  

boardbum

    Newbie

  • Members
  • 8 posts
  • Local time: 02:03 AM

Posted 27 January 2020 - 05:32 PM

solved



#12 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2958 posts
  • Local time: 02:03 AM
  • LocationLong Island, NY

Posted 28 January 2020 - 10:31 AM

how



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:03 AM

Posted 29 January 2020 - 01:20 AM

@boardbum that's great to hear. What was the solution?



#14 boardbum OFFLINE  

boardbum

    Newbie

  • Members
  • 8 posts
  • Local time: 02:03 AM

Posted 14 February 2020 - 07:02 AM

Deleted all .nfo and .jpg files,  and just kept doing that several times while rescanning and finally it cleared itself out.



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:03 AM

Posted 14 February 2020 - 10:16 AM

Thanks for the feedback.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users