Jump to content


Photo

URGENT- Emby Server can't connect to localhost. Cant get to dashboard

localhost dashboard

Best Answer k.easton@charter.net , 20 January 2020 - 11:53 AM

Hey where did everyone go?. I guess this one was a little much. Looks like windows update did something with the .net framework 3.5/4.8 update and the cumulative update for windows that threw things out of wack. I deleted all traces and reinstalled Emby Server from scratch. A bit time consuming but seemed to be the only option.

Go to the full post


  • Please log in to reply
12 replies to this topic

#1 k.easton@charter.net OFFLINE  

k.easton@charter.net

    Member

  • Members
  • 19 posts
  • Local time: 11:03 PM

Posted 18 January 2020 - 10:51 PM

Team,

 

Need Help. Windows 10. Dell 8910. 

 

Used Emby Theater last night fine watched my recorded shows etc... no issues.

Went to open Emby Theater this morning and I get a "connection failure". So I go to the server machine and discover 2 things I have not had issue with before

 

1. Emby all the sudden can't connect to localhost and wont open the Emby dashboard (on the server machine)

2. There were 6 or 7 instance of Emby Server showing up in the system tray for some reason

 

I have since tried everything in my limited repertoire to troubleshoot the problem

 

Restarting

Reinstalling Emby

Checked firewall Ports open

Flushed DNS

Checked the hosts folder seems fine

 

Can someone please help me out on this as I have not made any changes that should have caused this to happen

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:03 AM

Posted 18 January 2020 - 10:53 PM

Hi, did you try rebooting the machine?



#3 k.easton@charter.net OFFLINE  

k.easton@charter.net

    Member

  • Members
  • 19 posts
  • Local time: 11:03 PM

Posted 19 January 2020 - 01:09 PM

Hey Luke

 

Yes 1st in my list of things I tried. 



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50059 posts
  • Local time: 02:03 AM

Posted 19 January 2020 - 01:19 PM

So, the server is probably crashing for some reason.  I would start by looking at any plug-ins you recently installed.

 

Please post a log from when you start the server and then it isn't reachable.

 

Thanks.

 

How to Report a Problem



#5 k.easton@charter.net OFFLINE  

k.easton@charter.net

    Member

  • Members
  • 19 posts
  • Local time: 11:03 PM

Posted 19 January 2020 - 01:33 PM

Thanks CBW

 

Have not installed any new plugins

 

Here are the log files

Attached Files



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:03 AM

Posted 19 January 2020 - 01:51 PM

Is there anything in windows event viewer about it?

#7 k.easton@charter.net OFFLINE  

k.easton@charter.net

    Member

  • Members
  • 19 posts
  • Local time: 11:03 PM

Posted 19 January 2020 - 02:36 PM

Bingo! Lots of .Net Runtime errors. (Event ID 1026)

 

Saw another post below from Aug 3rd also no Access to Dashboard after Update to 4.2.0 (Started by lonnieb554)

 

Here are the details from Event Viewer

 

+ System
    - Provider
      [ Name] .NET Runtime
    - EventID 1026
      [ Qualifiers] 0
      Level 2       Task 0       Keywords 0x80000000000000     - TimeCreated
      [ SystemTime] 2020-01-19T17:53:05.849275100Z
      EventRecordID 3760       Channel Application       Computer Family-PCW10       Security
- EventData
      Application: EmbyServer.exe CoreCLR Version: 4.700.19.51502 .NET Core Version: 3.0.1 Description: The process was terminated due to an unhandled exception. Exception Info: System.ArgumentNullException: Value cannot be null. (Parameter 'key') at System.Collections.Concurrent.ConcurrentDictionary`2.ThrowKeyNullException() at System.Collections.Concurrent.ConcurrentDictionary`2.TryRemove(TKey key, TValue& value) at Emby.LiveTV.TimerManager.StopTimer(TimerInfo item) at Emby.LiveTV.TimerManager.AddOrUpdateSystemTimer(TimerInfo item, Boolean scheduleSystemWakeTimer) at Emby.LiveTV.TimerManager.RestartTimers() at Emby.LiveTV.EmbyTV.Start() at System.Threading.Tasks.Task.<>c.<ThrowAsync>b__139_0(Object state) at System.Threading.SynchronizationContext.<>c.<Post>b__12_0(ValueTuple`2 s) at System.Threading.QueueUserWorkItemCallbackDefaultContext`1.Execute() at System.Threading.ThreadPoolWorkQueue.Dispatch() at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()


#8 k.easton@charter.net OFFLINE  

k.easton@charter.net

    Member

  • Members
  • 19 posts
  • Local time: 11:03 PM

Posted 20 January 2020 - 11:53 AM   Best Answer

Hey where did everyone go?. I guess this one was a little much. Looks like windows update did something with the .net framework 3.5/4.8 update and the cumulative update for windows that threw things out of wack. I deleted all traces and reinstalled Emby Server from scratch. A bit time consuming but seemed to be the only option.



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:03 AM

Posted 20 January 2020 - 02:13 PM

Sorry, I am actually going to look at this. Your event viewer snippet does contain an error trace that we can catch and handle to prevent crashing.



#10 k.easton@charter.net OFFLINE  

k.easton@charter.net

    Member

  • Members
  • 19 posts
  • Local time: 11:03 PM

Posted 20 January 2020 - 02:53 PM

No worries. Sent you the Logs and Event Viewer info before wiping it. Hope it helps in your development. Great things came of it though. A clean install once in a while is a good thing. I was able to get the latest versions of Emby Server and Theater setting them up from scratch. Lots of improvements great job team! 

 

Heads up I think one of the factors is that I record and watch a bunch of news shows daily. Sometimes I watch and delete several days worth of shows due to my lifestyle. Felt like Emby didn't like that too much. started getting stutter, audio sync issues and degraded performance in general from all the watching and deleting.

 

Emby is back up now and better than ever!



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:03 AM

Posted 20 January 2020 - 02:53 PM

Thanks for the feedback !



#12 Lighthammer OFFLINE  

Lighthammer

    Advanced Member

  • Members
  • 304 posts
  • Local time: 12:03 AM

Posted 20 January 2020 - 10:47 PM

The latest Windows "Emergency" Update actually broke my server too. I had to restore from my backup and then redownload the update to fix the issue.

 

There's something that the Windows Update seemed to mess up with folder permissions and it was a REALLY big mess. I'm hearing from my Microsoft Contacts a lot of people had the problem but it was minimized by the fact they caught it after a few reports and reposted the update.

 

If you dont have a backup but can get into the Windows Machine, you might consider trying to uninstall that update, then redownload and install it again. You'll probably have to reinstall Emby too. Just do that from the web installer, but dont change anything about the install. Just let it install to where it goes by default.


Edited by Lighthammer, 20 January 2020 - 10:47 PM.

  • k.easton@charter.net likes this

#13 k.easton@charter.net OFFLINE  

k.easton@charter.net

    Member

  • Members
  • 19 posts
  • Local time: 11:03 PM

Posted 21 January 2020 - 11:58 AM

Thanks Lighthammer,

 

Do you have the Microsoft "K" numbers for the updates that you are referring to?

 

Can you please post them.

 

I think I have resolved the issue but have quite a few computers I would like to check and help others with.







Also tagged with one or more of these keywords: localhost, dashboard

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users