Jump to content
Allehaderos

ANSWERED Emby - sound problems - Sonos

Recommended Posts

Allehaderos

Hi guys,

 

I got my emby server on my synology, and i just bought a sonos playbar and a sub.

 

When I try to start my movies with DTS sound, no sound comes, I've read that sonos have problems with dts. 

 

I have also read that people using PLEX may well make DTS work, does anyone know if I can get the emby the same?

 

Hope someone can help me

Share this post


Link to post
Share on other sites
Guest asrequested

What app are you using?

Share this post


Link to post
Share on other sites
Allehaderos

Emby on my Nvidia shield 

My Emby server is on my synology

My sonos playbar is connected with a optical cable

Share this post


Link to post
Share on other sites
Guest asrequested

Shield doesn't have an optical output, so are you using the optical output from your TV?

Share this post


Link to post
Share on other sites
Allehaderos

Yes, HDMI from sheild to TV and optical from tv to sonos... 

Share this post


Link to post
Share on other sites
Guest asrequested

So the issue will be with what your TV supports. If your TV supports DTS, the shield will send that to the TV, and then your TV is responsible for the rest. So, more questions. Is your TV configured correctly? Does the Sonos support multi channel audio?

Share this post


Link to post
Share on other sites
Allehaderos

The last question I dont understand/know

I just set up my sonos to day, without my sonos my DTS movie played fine :/

 

Share this post


Link to post
Share on other sites
Guest asrequested

Looking at it, it does.

 

So you need to make sure your TV audio is configured correctly, to let AC3 and DTS passthrough.

Share this post


Link to post
Share on other sites
Allehaderos

my tv is a SONY KD55XE8096 4K TV

Share this post


Link to post
Share on other sites
Allehaderos

I found some settings on my shield where I could select audio formats, so now it works.. 

 

Thank you very much for your help

  • Like 1

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...