Jump to content
Louis6677

Slow access to Emby via ROKU

Recommended Posts

Louis6677

Hi, I need some advice on the following please.

 

I use the EMBY App on my Roku 4 and have a 600mb internet line.

 

To access movies or TV shows via the Roku takes forever to load and most of the time the content never plays.

 

Any advice will be highly appreciated.

 

Thanks

Share this post


Link to post
Share on other sites
Louis6677

Thank you for your prompt response. I will provide an example soonest. Many thanks

Share this post


Link to post
Share on other sites
Luke

Great, thanks !

Share this post


Link to post
Share on other sites
TheClaus

I have noticed this as well.  It is slow bringing up the shows page and movies page.  I can play the media I just have to wait a bit.  I will provide the logs and a video here tonight.  I have tried both the normal channel and beta channel and both respond similar.

Share this post


Link to post
Share on other sites
ebr

I have noticed this as well.  It is slow bringing up the shows page and movies page.  I can play the media I just have to wait a bit.  I will provide the logs and a video here tonight.  I have tried both the normal channel and beta channel and both respond similar.

 

Hi.  Can you define "slow"?  Are we talking 3-5 seconds or 30 seconds and at exactly what point?  I think this may just be the app gathering media information and defaults before displaying the detail screen.

 

Also, FYI, you can play your item by just hitting the "Play" button on the remote without bringing up the detail screen.

Share this post


Link to post
Share on other sites
TheClaus

Hi.  Can you define "slow"?  Are we talking 3-5 seconds or 30 seconds and at exactly what point?  I think this may just be the app gathering media information and defaults before displaying the detail screen.

 

Also, FYI, you can play your item by just hitting the "Play" button on the remote without bringing up the detail screen.

Slow as in it takes 30 seconds or more for it to display the shows  or movies.  It also happens between libraries.  So I have a TV shows library for my wife and one for my shows and one for our shows.  When I get out of one and go into another it takes 30 seconds or longer to show the library.  As for your 2nd question.  I have never done that.  I normally go into the details page and then press play.  Especially for TV Shows since it shows Play All for several seconds before showing the correct episode.

Share this post


Link to post
Share on other sites
ebr

Okay, so you are talking about the library views themselves not the detail screen taking a while.  How many movies and TV shows do you have?  How does the performance compare to the web app from the same location/network?  Is it local or remote?

Share this post


Link to post
Share on other sites
speechles

Is it your "Next Up" row that is slowing it all down?

 

You say it winds up on "Play All" for awhile before moving to the correct episode. This too me would mean it is the Next Up having the performance issue. We can look into this and see what the times wind up.

 

 

You can also use this program below:

 

https://sqlitebrowser.org/

DB Browser for SQLite (DB4S) is a high quality, visual, open source tool to create, design, and edit database files compatible with SQLite.

 

Open your library.db from within Emby-Server/data/ and then choose "compact database" from the menu. It may look like the app hung or isn't responding while it does its thing. Just let it finish. After this it should load much faster. Try this and let me know what you think. Thanks. :)

 

You must stop Emby server before you can compact the library.db.

Edited by speechles

Share this post


Link to post
Share on other sites
mikeraburn

This is odd.

 

This WAS happening to me the past week.

Slow loading.

 

When this happens to me, I reboot my Synology Server, reboot my router, and reboot the Roku Ultra. Even though I am wifi on the Roku Ultra.

I took the time to perform the above colonic last night and I am clean as a whistle for a few months.

It other words....I am back to normal....

Share this post


Link to post
Share on other sites
les ismore

Wow, waiting only 30 seconds to get to movies on my Windows desktop server, from Roku  Express via wi-fi cable modem/router, would seem like a nanosecond! I've tried everything I can find, think about, or guess just to (someday) get past the little "wheels on the bus" mind-f___. It never gets past that point lately. Emby server (beta) is up to date. I've reinstalled it several times using Opera browser. I've deleted server, added server, restarted server, added new users, changed usernames, allowed remote connections, preferred but not required secured connections, enabled automatic port mapping, tried signing in with Emby Connect and connecting with server manually, etc., etc., etc., blah, blah, blah. It is the free beta version but still...REALLY? Any questions? Any answers? Thank you please.

Share this post


Link to post
Share on other sites
ebr

Wow, waiting only 30 seconds to get to movies on my Windows desktop server, from Roku  Express via wi-fi cable modem/router, would seem like a nanosecond! I've tried everything I can find, think about, or guess just to (someday) get past the little "wheels on the bus" mind-f___. It never gets past that point lately. Emby server (beta) is up to date. I've reinstalled it several times using Opera browser. I've deleted server, added server, restarted server, added new users, changed usernames, allowed remote connections, preferred but not required secured connections, enabled automatic port mapping, tried signing in with Emby Connect and connecting with server manually, etc., etc., etc., blah, blah, blah. It is the free beta version but still...REALLY? Any questions? Any answers? Thank you please.

 

Hi.  Can we please look at an example?

 

Thanks.

 

How to Report a Problem

Share this post


Link to post
Share on other sites
les ismore

I'm a noobie, how can I show you?

Share this post


Link to post
Share on other sites
Luke

I'm a noobie, how can I show you?

 

Hi, instructions are in the link he provided above. Please let us know if this helps. Thanks !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...