Jump to content
Sign in to follow this  
Brad303

Upgraded from 2x to 3 - MBC is sluggish

Recommended Posts

Brad303

Hi guys,

 

I've loved MB2 for years and was excited to see the new version and the cool features. Unfortunately, MBS & MBC 3 on the same dedicated HTPC is very sluggish.

 

Browsing my movie library with background images was unusable. Turning them off at least allows to to navigate, but it's still slow compared to MB2. Switching to the MB2 theme seemed to help a bit too, but I've only been running it a couple of weeks, so I'm not fully up to speed.

 

Did I miss something in the config, or does version 3 require more horsepower / resources?

 

Thanks.

 

 

Share this post


Link to post
Share on other sites
Deihmos

MB2 was slow to me but MBC is fast and smooth.

 

Sent from my HTC One_M8 using Tapatalk

Share this post


Link to post
Share on other sites
Cheesegeezer

I was running MB3 and MBC on 5yr old 2.1ghz dual core amd processor with only 4gb of ram and a Ati 6450 gfx card for about a yr and found it fine for the same use as you, however i did upgrade recently to help transcoding to devices as i use this feature alot when i'm away.

 

Can you please post up logs from both the server and mbc. Details can be found in my signature.

 

It will give us a good starting point to trouble shoot your lagginess.

Share this post


Link to post
Share on other sites
Brad303

Sorry for the lag - just not got a chance to fetch the log and related into.

 

Log: http://pastebin.com/yHftUe5i

MBC 3.0.163.0 5-3.2

MBS: 3.0.5238.39498

 

Both MBS and MBC are running on a Win 7-64, 2.4 GHz Core 2, 8 GB RAM, integrated Intel X3500 w/HDMI. Media is stored on a network share. Primary control is remote with iMon VFD+sensor.

 

Everything seems to work as expected, but it's really slow. It sometimes takes a full 1 - 2 seconds to navigate to the next item. When backdrops are enabled, you can see it fade in in steps. When playing media, it can take an extra few seconds before it starts.

 

Under MB2, the exact same setup was smooth as silk. Instant response to navigation, rarely a delay when playing media.

 

Does MB3 handle indexing differently than MB2? I turned off index caching because new items wouldn't show up in MB2 with it enabled.

 

Thanks for the great (and quick) response! Hopefully we can get this licked and get back to enjoying the MB3 awesomeness!

Share this post


Link to post
Share on other sites
techywarrior

I think you are going to need to wait for a response from ebr but I can tell you a few things.

 

The server portion of the code (that used to be part of MB2) has been completely rewritten so I would turn on index caching as I haven't heard of anyone having a problem with items not showing up with it on.

 

Are the images for the movies the ones automatically pulled or custom images you added via another meta data manager?

 

Do you have the Rotten Tomatoes plugin installed?

Share this post


Link to post
Share on other sites
ebr

There is now a new release of MBC.  That is probably not related to your issue but you should upgrade.

 

Your server, however, is too old.  You need to update that to the latest release (5271).

 

What theme are you using?  MBC should be faster than the same setup with MB 2.

Share this post


Link to post
Share on other sites
Brad303

@@techywarrior

 

IIRC, the caching issue was only on network shares, but I'll try enabling it.

 

The images are the ones pulled automatically. They may have been there from the previous MB2.

 

I do have RT plugin installed. Has that been known to cause issues?

 

@@ebr

 

I'll upgrade to the latest version of both, although when I checked yesterday one of the two said I was on the latest version. Or are you talking about upgrading to the latest beta?

 

I'm currently running Chocolate, although I've used the Classis (?) theme, too. The latter seemed a bit faster than the former, but still much slower than MB2.

Share this post


Link to post
Share on other sites
techywarrior

 

I do have RT plugin installed. Has that been known to cause issues?

I haven't heard of reports of it causing problems but I noticed a lot of errors in the log pertaining to it. As a test I'd try uninstalling the RT plugin and see if it improves the responsiveness. MBC just had a new release pushed last night so you should see an upgrade available now.

 

The RT plugin requires that you have a RT account and/or key (I don't use it but I seem to recall that) so if you didn't put in your RT info that may have been why the errors showed up from RT as well. Or it could just be there is some limit of requests per day.

 

Of course, I don't know if that is causing the sluggishness or not. Just trying to reduce the errors in the log and see what works.

Share this post


Link to post
Share on other sites
bigjohn

The RT plugin requires that you have a RT account and/or key (I don't use it but I seem to recall that) so if you didn't put in your RT info that may have been why the errors showed up from RT as well. Or it could just be there is some limit of requests per day.

 

No key required, there isn't even any configuration available for the plugin. You got it right with the second part though, limit of 100 titles per day.

Share this post


Link to post
Share on other sites
techywarrior

No key required, there isn't even any configuration available for the plugin. You got it right with the second part though, limit of 100 titles per day.

Hm, I thought there used to be something about it requiring your own account. Maybe I'm mixing it up with something else.

 

If that's not the case tho then I doubt those requests would be slowing down navigation (otherwise lots of people would have mentioned the slowness).

 

I guess someone else will need to read the logs and see what they find.

Share this post


Link to post
Share on other sites
Brad303

No key required, there isn't even any configuration available for the plugin. You got it right with the second part though, limit of 100 titles per day.

 

Are the results cached? And if so, when are they updated if at all?

Share this post


Link to post
Share on other sites
bigjohn

Sorry, I don't know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...