Jump to content

Android client


Redshirt
 Share

Recommended Posts

Hi Redshirt.

 

Another Request, or maybe i just can't work it out.

Is it possible to have access to the remote at all times, a lot of times i start a movie, but then want to control it with the phone app instead, but it seems that isn't possible if you dont start the movie with the app.

Also when using the remote and you click back to look at details, is there a way to return to the remote?

 

Keep up the great work!

Link to comment
Share on other sites

it would be awesome to port this to smart tv's LG, Samsung (not talking for Goolge TV), I have LG 42LA961S that is basically android TV but does not allow to install external apk only the one provided from LG store

Link to comment
Share on other sites

Hi, just wanted to say thanks for the great program and development.  Iv'e discovered an issues with 4:3 tv shows. it's streaching them to take the whole screen.  I'm running in on  a samsung note 10.1.   beta 15.  it doesn't do this on the web client though, so i believe it's on andriod side.

here is the detail of the video file

===================== General =====================
Complete name              
Format                      : AVI
Format info                 : Audio Video Interleave
File size                   : 351 MB
Duration (ms)               : 45mn 29s
OverallBitRate_Mode/String  : Variable
Total bitrate               : 1 078 Kbps
Encoded application         : Nandub v1.0rc2
Encoded library             : Nandub build 1852/release

===================== Video =====================
Id                          : 0
Format                      : MPEG-4 Visual
Codec Id                    : DIV3
Codec                       : DivX 3 Low
Duration (ms)               : 45mn 29s
Bitrate                     : 906 Kbps
Width                       : 512 pixels
Height                      : 384 pixels
Aspect ratio                : 4:3
Framerate                   : 23.976 fps
Colorimetry                 : YUV
Colos space                 : 4:2:0
Bit depth                   : 8 bits
Compression_Mode/String     : Lossy
Bits/(Pixel*Frame)          : 0.192
Stream size                 : 295 MB (84%)

===================== Audio =====================
Id                          : 1
Format                      : MPEG Audio
Format version              : Version 1
Format profile              : Layer 3
Format settings mode        : Joint stereo
Format settings mode extens : MS Stereo
Codec Id                    : 55
Codec                       : MP3
Duration (ms)               : 45mn 29s
Bitrate mode                : Variable
Bitrate                     : 160 Kbps
Channel(s)                  : 2 channels
Sampling rate               : 48.0 KHz
Compression_Mode/String     : Lossy
Stream size                 : 51.9 MB (15%)
Alignement                  : Aligned on interleaves
Interleave duration         : 24 ms (0.58 video frame)
Interleave preload          : 110 ms
Encoded library             : LAME3.92 
Encoded library settings    : -m j -V 4 -q 2 -lowpass 18 --abr 160

Link to comment
Share on other sites

@@snake98

What does the media info say when you go to that item in the WebUI. 

do you mean this?

 

Details
Video:msmpeg4 • 512x384 • 1078 kbps • 23.976
Audio:mp3 • 159 kbps • 2 ch • 48000 khz
Link to comment
Share on other sites

Redshirt

Yeah that's what I wanted to see. The media info is missing the aspect ratio. In that text it should also have 4:3

 

So it means the client isn't doing a proper job of guessing based on the physical dimensions. I'll look into it.

Link to comment
Share on other sites

Red, you can remove your guessing because the server will be normalizing it beginning with the next release.

Link to comment
Share on other sites

Redshirt

that's good, but in this situation the aspect ratio is blank, not just an odd number.

Link to comment
Share on other sites

Thanks Mark - working now :)

Just tried on my Nexus 5 (15.6) and I am unable to play any files back. Player comes up for a second then closes back to the last screen.

 

Works fine on my Nexus 10

 

Using internal player on both

Edited by jmelan
Link to comment
Share on other sites

Redshirt

they are saved to \Mb3AndroidData\Logs You may need to install a file manager to access them.

Link to comment
Share on other sites

Redshirt

I've had a look and it's reporting that the server aborted the playback. Can I see your server log for the same timeframe

Link to comment
Share on other sites

Think I found what you need. Log sent.

 

...Same action and result. Just a few minutes later. Did not have debug log enabled on server at first.

Edited by jmelan
Link to comment
Share on other sites

Redshirt

Yeah the snippit you sent doesn't appear to have debug logging. I need to see a log with debug enabled and more of it so I can see the accompanying http traffic.

Link to comment
Share on other sites

Redshirt

just a new server log of you trying to play that same movie/episode on the Nexus 5

Link to comment
Share on other sites

Redshirt

It might be best if you delete all the existing logs first just to make sure you get the right server and ffmpeg logs.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...