Jump to content
hygorfragas

Help Ombi

Recommended Posts

Happy2Play

Guess i found the file that i causing the problem:

https://github.com/tidusjar/Ombi/blob/master/src/Ombi.Helpers/EmbyHelper.cs

Pretty sure it is do to serverid as I know EmbyStats server uses old url item/item but has serverid and still works.

 

 

From browser console

connectionmanager.js?v=4.4.0.40:1 Uncaught Error: item or serverId cannot be null
    at ConnectionManager.getApiClient (connectionmanager.js?v=4.4.0.40:1)
    at startDataLoad (item.js?v=4.4.0.40:1)
    at Object.<anonymous> (item.js?v=4.4.0.40:1)
    at dispatchViewEvent (viewmanager.js?v=4.4.0.40:1)
    at viewmanager.js?v=4.4.0.40:1
    at viewcontainer-lite.js?v=4.4.0.40:1

@@Luke Have they been contacted?

Share this post


Link to post
Share on other sites
Happy2Play

I made a code change request. From what i understand the code needs to be changed as follows to generate a valid emby URL:

 

https://github.com/didusee/Ombi/commit/10bb22639bc880f59b7bf6b472f33f517accaf3e

 

 

Please correct if you feel like that is nonsense

 

Luke will have to comment more, but the url is fine if you add the serverid.

http://localhost:8096/web/index.html#!/item/item.html?id={mediaId}&serverId={serverId}

Share this post


Link to post
Share on other sites
hi2hello
Posted (edited)

If i just add the Server ID to Ombi‘s generated URL with an "&serverID" such as follows:

https://myserveraddress.com/web/index.html#!/item/item.html?id=467687&serverId=…

emby is still just showing a black screen! So that does not seem to work.

 

 

The URL is supposed to be:

https://myserveraddress.com/web/index.html#!/item?id=467687&serverId=…

PS: As I already stated you than could also drop the server ID to get a valid link to the media you are looking for.

Edited by hi2hello

Share this post


Link to post
Share on other sites
Happy2Play

If i just add the Server ID to Ombi‘s generated URL with an "&serverID" such as follows:

https://myserveraddress.com/web/index.html#!/item/item.html?id=467687&serverId=…

emby is still just showing a black screen! So that does not seem to work.

 

 

The URL is supposed to be:

https://myserveraddress.com/web/index.html#!/item?id=467687&serverId=…

PS: As I already stated you than could also drop the server ID to get a valid link to the media you are looking for.

 

Must be a local vs Remote thing, as all local original urls work for me with serverid addition.

Share this post


Link to post
Share on other sites
hi2hello
Posted (edited)

For me, both URLs such as proposed are not working, neither local nor remote.
Running latest Emby (4.4.0.40) under unRaid in a Docker.

123.456.0.10:port/web/index.html#!/item/item.html?id=467687&serverId=serverId=…

Result: black Screen

https://myserveraddress.com/web/index.html#!/item/item.html?id=467687&serverId=serverId=…

Result: black Screen

123.456.0.10:port/web/index.html#!/item?id=467687&serverId=…

Result: correct media shown

https://myserveraddress.com/web/index.html#!/item?id=467687&serverId=…

Result: correct media shown

123.456.0.10:port/web/index.html#!/item?id=467687

Result: correct media shown

https://myserveraddress.com/web/index.html#!/item?id=467687

Result: correct media shown

Edited by hi2hello

Share this post


Link to post
Share on other sites
Pyro2577

If i just add the Server ID to Ombi‘s generated URL with an "&serverID" such as follows:

https://myserveraddress.com/web/index.html#!/item/item.html?id=467687&serverId=…

emby is still just showing a black screen! So that does not seem to work.

 

 

The URL is supposed to be:

https://myserveraddress.com/web/index.html#!/item?id=467687&serverId=…

PS: As I already stated you than could also drop the server ID to get a valid link to the media you are looking for.

Yeah using your link also works and also adding &serverId=xxxxxxxxxxxxxxxxxxxx to the end works also. I hope he fixes it either way.

Share this post


Link to post
Share on other sites
hi2hello
Posted (edited)

as my suggested code change does not seem to work for both emby and jellyfin users (which is, by the way, not really surprising) I posted test results with several URL options in github under issues and hope the maintainer will fix it …

 

Once more, concerning to my tests, adding the ServerID to the URL does not make any difference at all

 

https://github.com/tidusjar/Ombi/issues/3455

Edited by hi2hello

Share this post


Link to post
Share on other sites
hi2hello

Update: the bug is fixed by the maintainer and will be released with V4 of Ombi.

 

@@Luke and the emby crew: It would be incredibly awesome if you could comment such changes made on your side in the future a bit more visible to those who contribute with plugins and API connected apps. 

Thanks in andvance!

 

Cheers!

Share this post


Link to post
Share on other sites
Luke

Update: the bug is fixed by the maintainer and will be released with V4 of Ombi.

 

@@Luke and the emby crew: It would be incredibly awesome if you could comment such changes made on your side in the future a bit more visible to those who contribute with plugins and API connected apps. 

Thanks in andvance!

 

Cheers!

 

Will do, for this one I just didn't realize it at the time. Thanks for the feedback.

Share this post


Link to post
Share on other sites
halkx

I am on Ombi v4 atm and cannot seem to find the location of the "view on emby" button that existed on v3...any help here?

Share this post


Link to post
Share on other sites
samuelqwe

I am on Ombi v4 atm and cannot seem to find the location of the "view on emby" button that existed on v3...any help here?

On the detail page for whatever movie/show is available on Emby, there should be a green play button that serves as the view on Emby button.

Share this post


Link to post
Share on other sites
halkx

On v3 there was albeit the link was broken.... I thought t was fixed on v4 but on the details page the only green button displayed is the available one which does nothing.... maybe I should try another browser? I am on opera

Share this post


Link to post
Share on other sites
samuelqwe
Posted (edited)

On v3 there was albeit the link was broken.... I thought t was fixed on v4 but on the details page the only green button displayed is the available one which does nothing.... maybe I should try another browser? I am on opera

The button should show right below the other social media icons. Perhaps another browser would work.

 

EDIT: Here is the green play button I am referring to.

5ecb8246c4cce_ScreenShot20200525at32247A

Edited by samuelqwe

Share this post


Link to post
Share on other sites
halkx

Nope... doesn’t show on mine....maybe a settings issue? Or is it because I upgraded from v3? Maybe a clean install would fix this?

Share this post


Link to post
Share on other sites
halkx

5ecb89debe7fb_Screenshot.png

Share this post


Link to post
Share on other sites
samuelqwe

Nope... doesn’t show on mine....maybe a settings issue? Or is it because I upgraded from v3? Maybe a clean install would fix this?

Before trying a clean install, I would check to see if you are on the latest version of Ombi, then verify that the Emby server settings are correct in Ombi.

Share this post


Link to post
Share on other sites
halkx

thanks for trying to help....I assume I am running the latest version from github.... What Emby server settings in particular should I check to see if they are correct? I have input the servers IP and port and pressed the discover server information button...then some fields populated automatically...I haven't entered anything in the externally facing hostname field because I don't have the server setup yet for outside access. Also the Base URL field is empty.

Share this post


Link to post
Share on other sites
samuelqwe

thanks for trying to help....I assume I am running the latest version from github.... What Emby server settings in particular should I check to see if they are correct? I have input the servers IP and port and pressed the discover server information button...then some fields populated automatically...I haven't entered anything in the externally facing hostname field because I don't have the server setup yet for outside access. Also the Base URL field is empty.

If you’re able to discover the server, it should be good enough. Just curious, what version are running? I am on version 4.0.339.0, so if that’s different it may be why the button isn’t showing up.

Share this post


Link to post
Share on other sites
halkx
Posted (edited)

If you’re able to discover the server, it should be good enough. Just curious, what version are running? I am on version 4.0.339.0, so if that’s different it may be why the button isn’t showing up.

 

5ecc4cbf8d7b9_Screenshot26_5_20201_53_41

 

same here...

 

Have filed an issue on github...let's see how it goes...

Edited by halkx

Share this post


Link to post
Share on other sites
samuelqwe
Posted (edited)

5ecc4cbf8d7b9_Screenshot26_5_20201_53_41

 

same here...

 

Have filed an issue on github...let's see how it goes...

That’s really strange. The only thing I can think of is if you didn’t check the Enable checkbox at the top of the Emby Media Server configuration page in Ombi, or if the API key is incorrectly entered. However, since you were able to test the server connection, everything should be good. Perhaps manually running the cacher could help, but hopefully GitHub can help resolve the issue. Edited by samuelqwe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...