Jump to content


Photo

Playback Issue - .MKV files

mkv seek playback transcode

  • Please log in to reply
7 replies to this topic

#1 sundevil67 OFFLINE  

sundevil67

    Advanced Member

  • Members
  • 103 posts
  • Local time: 10:07 PM

Posted 09 December 2019 - 08:10 AM

Forgive me if this is related to transcoding & has been discussed in another thread. I'm not completely sure it has anything to do with the file format, but it does seem to be an issue I've noticed (so far) to be affecting only .mkv files. I'm not able to start watching a video from the middle or anywhere other than the beginning, and pretty much any hopping around will cause the video to crap out. Is this just a limitation of the format, a bug somewhere in Emby Mac OS server, or perhaps connected to some kind of corruption or defect in some of the individual .mkv files I've collected or converted.

 

Any guidance appreciated!

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157111 posts
  • Local time: 01:07 AM

Posted 09 December 2019 - 01:34 PM

Hi there @sundevil67, let's look at an example. Please attach the information requested in how to report a media playback issue. thanks !



#3 sundevil67 OFFLINE  

sundevil67

    Advanced Member

  • Members
  • 103 posts
  • Local time: 10:07 PM

Posted 14 December 2019 - 01:23 PM

Apologies for the delay...I'm afraid I can't seem to remember which file it was, and I've since been unable to duplicate the issue with any of the other .mkv files I've tested. I'd experienced the same problem previously with more than one video, but it doesn't appear to be a blanket concern covering all movies in that format. I did notice around the same time that the FFMPEG 'process' was eating up an enormous % of CPU cycles in my Activity Monitor & a few instances of "ContainerNotSupported" in the log. From what I can tell it looks like some kind of transcoding issue but I don't know enough about the file format to say much more about it... I can PM you the log if you still think it might help troubleshoot for other users who might have experienced something similar, but I'm no longer concerned about the issue. Thanks for your help



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157111 posts
  • Local time: 01:07 AM

Posted 15 December 2019 - 02:58 PM

Container not supported is just telling you the reason why it isn't direct playing and requires conversion. Does that clear that up?

#5 sundevil67 OFFLINE  

sundevil67

    Advanced Member

  • Members
  • 103 posts
  • Local time: 10:07 PM

Posted 16 December 2019 - 08:29 PM

I suppose I won't really be able to get to the bottom of it completely until I figure out which file was involved. Now that I know it's likely limited to just 1 or 2 files and is not affecting all of the .MKV files in my library, I'm much less concerned about it. If I stumble upon it again at some point, I'll certainly come back & find this thread again. Thanks for your help!



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157111 posts
  • Local time: 01:07 AM

Posted 16 December 2019 - 08:57 PM

Thanks for the feedback.



#7 sundevil67 OFFLINE  

sundevil67

    Advanced Member

  • Members
  • 103 posts
  • Local time: 10:07 PM

Posted 17 December 2019 - 05:28 AM

Well, that didn't take long. When trying to watch this one .mkv tonight, I noticed a very long delay if I tried to skip to another part of the video, and also experienced some scattered freezing during playback. I was going to try to convert it to a different format, but before I did I wanted to pass it along. I think I found the error in the log (attached), but I'm not sure there's much that can be done about it. Thanks.

Attached Files



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157111 posts
  • Local time: 01:07 AM

Posted 24 December 2019 - 03:50 AM

Have you tried emby server 4.3.1?





Also tagged with one or more of these keywords: mkv, seek, playback, transcode

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users