Jump to content


Photo

Choppy Playback on Apple TV


  • Please log in to reply
33 replies to this topic

#1 BoneBoxer OFFLINE  

BoneBoxer

    Member

  • Members
  • 12 posts
  • Local time: 05:40 AM

Posted 07 December 2019 - 08:20 PM

Forgive me if this is the wrong subforum, but I did not see one specifically for Apple TV.

 

On my current generation Apple TV, and ONLY on my Apple TV, playback is very choppy/jerky, with any file. When I play through the LG TV Emby app it doesn't happen, but I really dislike the LG app's UI and the TV remote. I actually quit using Plex a while back because they would not address problems like this on the Apple TV. And now this same issue has cropped up in Emby, so I sure hope there is some hope for a fix or I'm just out of luck.

 

A log file is attached to this post. 



#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 17134 posts
  • Local time: 03:40 AM
  • LocationWashington State

Posted 07 December 2019 - 08:25 PM

Moved topic to Apple TV



#3 BoneBoxer OFFLINE  

BoneBoxer

    Member

  • Members
  • 12 posts
  • Local time: 05:40 AM

Posted 07 December 2019 - 08:44 PM

Moved topic to Apple TV

Thanks! Sorry about that, I couldn't find it myself.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146173 posts
  • Local time: 06:40 AM

Posted 07 December 2019 - 10:31 PM

Hi there, can we look at an example? Please attach the information requested in how to report a media playback issue. thanks !



#5 atrpm OFFLINE  

atrpm

    Advanced Member

  • Members
  • 44 posts
  • Local time: 07:40 AM

Posted 07 December 2019 - 11:54 PM

I’m experiencing the same issue. This is happening after the latest Apple TV app update. I will upload some logs tomorrow.

#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146173 posts
  • Local time: 06:40 AM

Posted 08 December 2019 - 01:00 AM

I’m experiencing the same issue. This is happening after the latest Apple TV app update. I will upload some logs tomorrow.

 

Great, thanks !



#7 BoneBoxer OFFLINE  

BoneBoxer

    Member

  • Members
  • 12 posts
  • Local time: 05:40 AM

Posted 08 December 2019 - 11:05 AM

Hi there, can we look at an example? Please attach the information requested in how to report a media playback issue. thanks !

 

Sorry, I thought I attached a log file to the original post but I guess it didn't work. Trying again in this reply.

Attached Files



#8 vdatanet ONLINE  

vdatanet

    Advanced Member

  • Members
  • 1542 posts
  • Local time: 12:40 PM
  • LocationCalafell, Spain

Posted 08 December 2019 - 04:01 PM

Are you playing 4k HDR items? What are your Apple TV video settings? Can you post media information of the problematic item?



#9 BoneBoxer OFFLINE  

BoneBoxer

    Member

  • Members
  • 12 posts
  • Local time: 05:40 AM

Posted 08 December 2019 - 04:56 PM

Are you playing 4k HDR items? What are your Apple TV video settings? Can you post media information of the problematic item?

 

It is happening with any video I try to play, which has been about 5-10 since I started having the problem.

 

Here are stats for the last video I tried to play:

 

Title1080p H264
CodecH264
AVCYes
ProfileHigh
Level41
Resolution1920x1040
Aspect ratio1.85:1
AnamorphicNo
InterlacedNo
Framerate23.976
Bitrate6,437 kbps
Bit depth8 bit
Pixel formatyuv420p
Ref frames1
NAL4
Audio
TitleEnglish Dolby Digital 5.1 (Default)
LanguageEnglish
CodecAC3
Layout5.1
Channels6 ch
Bitrate640 kbps
Sample rate48,000 Hz
DefaultYes
Subtitle
TitleUnd (SUB)
CodecSUB
DefaultNo
ForcedNo
ExternalYes
Containermkv

Size4476 MB

 

Which Apple TV settings are relevant to share?                   

Edited by BoneBoxer, 08 December 2019 - 04:58 PM.


#10 vdatanet ONLINE  

vdatanet

    Advanced Member

  • Members
  • 1542 posts
  • Local time: 12:40 PM
  • LocationCalafell, Spain

Posted 08 December 2019 - 04:58 PM

4K SDR, 4K HDR... What's your video mode?



#11 BoneBoxer OFFLINE  

BoneBoxer

    Member

  • Members
  • 12 posts
  • Local time: 05:40 AM

Posted 08 December 2019 - 05:02 PM

Under "Video and Audio" in Apple TV settings, here's what I've got:

 

Format: 4k HDR.

Chroma: 4:2:0

Match Content: Range & Frame Rate

 

And to answer your other question, both 4k and HD videos have had the same problem when I try to play them. And again, just to be clear, this is ONLY happening on the Apple TV client. From the same server, playing to my LG TV Emby app, everything is fine on any of the videos I've tried to play. Same thing using the web player on my laptop.



#12 vdatanet ONLINE  

vdatanet

    Advanced Member

  • Members
  • 1542 posts
  • Local time: 12:40 PM
  • LocationCalafell, Spain

Posted 08 December 2019 - 05:07 PM

That's the issue. If you want Emby to Apple TV to work, you have to set 4K SDR, because match content frame rate and dynamic range, does not work for Emby for Apple TV player.



#13 BoneBoxer OFFLINE  

BoneBoxer

    Member

  • Members
  • 12 posts
  • Local time: 05:40 AM

Posted 08 December 2019 - 07:30 PM

That's the issue. If you want Emby to Apple TV to work, you have to set 4K SDR, because match content frame rate and dynamic range, does not work for Emby for Apple TV player.

 

Okay, I tried to switching to 4k SDR in Apple TV settings, however this had no affect. Video playback still has the exact same choppy playback. Something like every half second it seems to suddenly jump a few frames or something. Which is exactly what it has been doing.



#14 vdatanet ONLINE  

vdatanet

    Advanced Member

  • Members
  • 1542 posts
  • Local time: 12:40 PM
  • LocationCalafell, Spain

Posted 09 December 2019 - 03:37 AM

Is it transcoding or Direct Play? Where's is your media located? I see you are using Google Drive. You are in sync with Google Drive or you stream directly from Google Drive? 

 

If you stream directly from Google Drive, try to play a local file to see if there are differences.

2019-12-07 17:48:44.387 Info LibraryMonitor: Abominable (/Volumes/GoogleDrive/My Drive/Media/Video/Film/Abominable.2019.1080p.BluRay.x264-SPARKS[rarbg]/abominable.2019.1080p.bluray.x264-sparks.mkv) will be refreshed.

Edited by vdatanet, 09 December 2019 - 05:12 AM.


#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146173 posts
  • Local time: 06:40 AM

Posted 11 December 2019 - 04:37 PM

@BoneBoxer are you able to answer the above question? Thanks !



#16 BoneBoxer OFFLINE  

BoneBoxer

    Member

  • Members
  • 12 posts
  • Local time: 05:40 AM

Posted 11 December 2019 - 06:44 PM

Sorry, haven't been at home much at all the past couple of days. i will be able to check those things tonight.



#17 BoneBoxer OFFLINE  

BoneBoxer

    Member

  • Members
  • 12 posts
  • Local time: 05:40 AM

Posted 11 December 2019 - 06:46 PM

I can answer the one right now, though. Those files are not in the google drive cloud, but set to be in sync on the server's hard drive. It is a powered USB external. (And, keep in mind, they play fine to the LG tv client without any issues. It's only Apple TV that has these problems, and it always has them on any file I try to play). They are on a hard drive on a Mac Pro that is my emby server on my local network at home.

 

As far as transcoding, I don't know. I will have to look at the server when I get home.


Edited by BoneBoxer, 11 December 2019 - 06:47 PM.


#18 atrpm OFFLINE  

atrpm

    Advanced Member

  • Members
  • 44 posts
  • Local time: 07:40 AM

Posted 13 December 2019 - 07:05 PM

Sorry I was suppose to upload some logs and forgot about this topic. I’m now in vacation for the holidays and won’t be able to provide logs any time soon.

Following the conversation, with my setup I have the media in google drive and use rClone to make it available to Emby.

It doesn’t matter what type of media I play on the Apple TV, SD, 720 or 1080 even live tv is choppy on the new version of the app.

I have try the same media on the iPhone, shield tv and firestick 4K and I don’t get any of the choppy playback that I see on the Apple TV.

#19 sfatula OFFLINE  

sfatula

    Advanced Member

  • Members
  • 525 posts
  • Local time: 05:40 AM
  • LocationCalera, OK

Posted 14 December 2019 - 12:50 AM

I find they almost all look bad in the no longer so new app. None of the settings matter for that. A 1080p/60 is the only video that looks good, anything else is clearly a mismatched framerate on my Samsung TV. In the "old" version using the Apple player, they all looked great. Don't even talk about interlaced, even worse. 



#20 BoneBoxer OFFLINE  

BoneBoxer

    Member

  • Members
  • 12 posts
  • Local time: 05:40 AM

Posted 14 December 2019 - 04:11 PM

Sorry for the delay. It's been a very busy week for me. But I now have the answer to the second question; videos I tried are direct playing from the Emby server to my Apple TV. No transcoding. But still, there is this frame-jumpy kind of choppiness.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users