Jump to content

Background blur


arrbee99
 Share

Recommended Posts

Hi, thanks for replying.

I understand your information, but I didn't understand where to change it to "1" in the code.

backdrop.style.backdropFilter = "saturate(0) blur(0px)";

 

With saturate 0 will give it a washout look

 

backdrop.style.backdropFilter = "saturate(1) blur(0px)";

 

Will make the backdrop look normal

 

backdrop.style.backdropFilter = "saturate(1.8) blur(0px)";

 

Will bring out the color substantially.

  • Like 1
Link to comment
Share on other sites

arrbee99

Well this should do what you want @@arrbee99 with css

.overflowYScroll.withSectionTabs div.backgroundContainer.withBackdrop {
    background: rgba(0,0,0,.10); backdrop-filter: saturate(1.8) blur(1.5em)
}

.overflowYScroll div.backgroundContainer.withBackdrop {
    background: rgba(0,0,0,.10);
}
Might need to add the "-webkit-backdrop-filter" for other browsers as shown in post 7.

 

 

So I should add this to the css I have, while keeping chefs other code, and they kind of work in conjunction with each other ?

 

I tried doing that and changing say, blur in the above to 0 and nothing seemed to change.

Link to comment
Share on other sites

Happy2Play

Well chefs code has to be done with every update, this css only only once.  I would not use both as I would assume chefs script would override css (guessing).

  • Like 1
Link to comment
Share on other sites

arrbee99

Well chefs code has to be done with every update, this css only only once.  I would not use both as I would assume chefs script would override css (guessing).

 

Ah ok, its an either/or thing. Thank you. I shall have another quick play.

Link to comment
Share on other sites

arrbee99

Ah ok, its an either/or thing. Thank you. I shall have another quick play.

 

Tried with just the Happy2play version enabled and adjusting blur does work now. Thanks again.

 

On a general note, if you guys have had a play with the backdrops on the home page enabled, and then you go to a movie detail screen or something, do you find you get a quick view of the previous blurred image being shown (though its actually not blurred at all any more) on the movie details page before the proper movie details page appears ?

Link to comment
Share on other sites

CarlosLima

Found by four clients, an issue that forced me to remove the code entirely. When playing, the videos and subtitles were blurred. By testing, I confirmed the problem.

post-26813-0-65938100-1575240381_thumb.png

Edited by CarlosLima
Link to comment
Share on other sites

Happy2Play

Tried with just the Happy2play version enabled and adjusting blur does work now. Thanks again.

 

On a general note, if you guys have had a play with the backdrops on the home page enabled, and then you go to a movie detail screen or something, do you find you get a quick view of the previous blurred image being shown (though its actually not blurred at all any more) on the movie details page before the proper movie details page appears ?

 

Pretty sure that is the ".backdropImageFadeIn" animation in the backdropcontainer backdropimages.  If you disable them in the console you see a instant change right?

Edited by Happy2Play
Link to comment
Share on other sites

Happy2Play

Found by four clients, an issue that forced me to remove the code entirely. When playing, the videos and subtitles were blurred. By testing, I confirmed the problem.

Was just going to say I didn't have any issue playing media with srt subtitles with my code.

Link to comment
Share on other sites

arrbee99

Pretty sure that is the ".backdropImageFadeIn" animation in the backdropcontainer backdropimages.  If you disable them in the console you see a instant change right?

 

It might well be except I have no idea how to disable anything in Console.

Link to comment
Share on other sites

Happy2Play

It might well be except I have no idea how to disable anything in Console.

 

Like this uncheck the code, then navigate to itemdetails.

 

5de44af8eb29c_console.jpg

Link to comment
Share on other sites

I had subs enabled but the media was blurred also.

Looks like maybe the backdrop container is always on top.

 

Using background-filter would do that.

 

Still very interesting.

Edited by chef
Link to comment
Share on other sites

Happy2Play

Looks like maybe the backdrop container is always on top.

 

Using background-filter would do that.

 

Still very interesting.

I don't understand how it is being added to "class="backgroundContainer backgroundContainer-transparent"" though.  But clearly removing your code resolves the issue.

Link to comment
Share on other sites

arrbee99

Like this uncheck the code, then navigate to itemdetails.

 

5de44af8eb29c_console.jpg

 

I've looked, but can't find anything under Elements that mentioned ImageFadeIn. Not sure if its worth bothering about.

Link to comment
Share on other sites

I don't understand how it is being added to "class="backgroundContainer backgroundContainer-transparent"" though. But clearly removing your code resolves the issue.

Did you start playback from the home screen or library without first going to the itemdetails page?

 

Because if the user press the play button from the card, then the effect wouldn't have been removed from backgroundContainer since the itemsDetails page wasn't viewed (which is the only time the effect is lifted).

 

Maybe.

Edited by chef
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...