Jump to content
cochize1

Back arrow on login page

Recommended Posts

cochize1

Is there any way to remove the back arrow on the login screen so just there is MyDomain logo showing (without affecting the arrow on any other page). I think it obsolete there.

Share this post


Link to post
Share on other sites
Happy2Play

Something like this, not positive if other areas are affected.

html.layout-desktop.noScrollY div.headerLeft [title="Back"] {display: none;}

Share this post


Link to post
Share on other sites
cochize1

No change on the login page with that code, the arrow is still there.

The selector I refer to is this:

body > div.skinHeader.focuscontainer-x > div > div.headerLeft > button.headerBackButton.headerButton.hide-mouse-idle-tv.paper-icon-button-light > i

But removing that also removes it from the main page and all sub-pages where it has a value. SO I was thinking that adding an id to the login page (as you suggested in some previous posts) could do the trick, am I right? But maybe there is some other way.

Share this post


Link to post
Share on other sites
Happy2Play

Looks like it may be browser specific as it works for Chrome and FireFox, but not Edge for me.  Without unique page id it can almost be impossible.

 

Try.

.noScrollY div.headerLeft [title="Back"] {display: none;}

Share this post


Link to post
Share on other sites
cochize1

ok, so I looked into the code again using dev tools and it seems that it is language specific. The title "Back" part is translated into my native language that the Emby is set to. So after changing that, it worked. Thank you. Now just to figure out how to move the logo back to the original position since it shifted to the very edge of the page without that arrow (but will try to work this out on my own).

 

Kudos my friend

Share this post


Link to post
Share on other sites
Happy2Play

ok, so I looked into the code again using dev tools and it seems that it is language specific. The title "Back" part is translated into my native language that the Emby is set to. So after changing that, it worked. Thank you. Now just to figure out how to move the logo back to the original position since it shifted to the very edge of the page without that arrow (but will try to work this out on my own).

 

Kudos my friend

Yes translation would play a factor here.

 

Well you can use "visibility: hidden;" instead of "display: none;" to keep logo in the original position.

Edited by Happy2Play

Share this post


Link to post
Share on other sites
cochize1

worked perfectly... again:)

So just the follow up since that's such a piece of cake for you, what is the code the place the logo in in the middle of the header and make it slightly bigger?

Share this post


Link to post
Share on other sites
Happy2Play

Not very easily as it exists in the headerLeft.  So you would have to manipulate the padding, height, and width.

.noScrollY div.headerLeft {
    padding-left: 45%;
}
.noScrollY h3.pageTitleWithDefaultLogo {
    width: 8em;
    height: 3em;
}

Note all the .noScrollY code affects User Preferences also (your user icon menu)

Share this post


Link to post
Share on other sites
cochize1

I have just noticed that both:

html.layout-desktop.noScrollY div.headerLeft [title="Back"] {display: none;}

and

.noScrollY div.headerLeft [title="Back"] {display: none;}

affect the 'back' arrow also in the playback section (or whatever it is called - when you play the video) so it is a no go. Same for the position and resizing the logo, it affects login page and playback section as well.

 

So the only option left is the id tag?

Edited by cochize1

Share this post


Link to post
Share on other sites
Happy2Play

I have just noticed that both:

html.layout-desktop.noScrollY div.headerLeft [title="Back"] {display: none;}

and

.noScrollY div.headerLeft [title="Back"] {display: none;}

affect the 'back' arrow also in the playback section (or whatever it is called - when you play the video) so it is a no go. Same for the position and resizing the logo, it affects login page and playback section as well.

 

So the only option left is the id tag?

 

 

Correct you will need to add the pageid, then target your elements with the pageid.

Share this post


Link to post
Share on other sites
cochize1

Not sure what am I missing here. I added id=loginPage to login.html file

5de1c0cd9a4fb_hhh.jpg

 

and used this code:

#loginPage html.layout-desktop.noScrollY div.headerLeft [title="Back"] {display: none;}

but the back arrow is still there on the login screen, no change at all. Any hints?

Edited by cochize1

Share this post


Link to post
Share on other sites
Happy2Play

Not sure what am I missing here. I added id=loginPage to login.html file

5de1c0cd9a4fb_hhh.jpg

 

and used this code:

#loginPage html.layout-desktop.noScrollY div.headerLeft [title="Back"] {display: none;}
but the back arrow is still there on the login screen, no change at all. Any hints?

 

 

Actually the header is loaded before the page.

 

 

I think it falls in the appheader.js.  Since we ran into a similar issue with TV and Movies page tabs in the header.  So it really can't be done via css that I can see.

Share this post


Link to post
Share on other sites
cochize1

Ok, thanks for clearing that out. Maybe devs will think of something in the future releases as I see no point in the back arrow being there on the login page.

Share this post


Link to post
Share on other sites
chef

Not sure what am I missing here. I added id=loginPage to login.html file

5de1c0cd9a4fb_hhh.jpg

 

and used this code:

#loginPage html.layout-desktop.noScrollY div.headerLeft [title="Back"] {display: none;}
but the back arrow is still there on the login screen, no change at all. Any hints?
Make sure loginPage is in Quotations eh.

 

id="loginPage"

 

I just noticed in your dev tools snippet you had miss it.

Edited by chef

Share this post


Link to post
Share on other sites
cochize1

I have tested both options with and without quotations and the result is the same.

Share this post


Link to post
Share on other sites
CarlosLima

In short, a solution has not been found yet ?!

Share this post


Link to post
Share on other sites
cochize1

Not for me. It seems as the page id does not work. When I remove just the #loginPage part the arrows disappears but it also disappears from the playback section where it is actually useful

  • Like 1

Share this post


Link to post
Share on other sites
Happy2Play

 

#loginPage html.layout-desktop.noScrollY div.headerLeft [title=Back] {display: none;}

 

 

This can't work because the page is actually after the header.  So "html.layout-desktop.noScrollY div.headerLeft" exists before "#loginPage".  So you can't target the page when the element doesn't exist there.

 

5de5a43d5f46d_target.jpg

Share this post


Link to post
Share on other sites
cochize1

So I assume the same goes with 

.noScrollY div.headerLeft [title="Back"] {display: none;}

and there is no real way to handle that annoying arrow on the login screen?

  • Thanks 1

Share this post


Link to post
Share on other sites
Moisés Oliveira

Funcionou perfeitamente 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...