Jump to content


Photo

Subtitles not saved to media folder, cannot be deleted


  • Please log in to reply
12 replies to this topic

#1 huoc OFFLINE  

huoc

    Newbie

  • Members
  • 7 posts
  • Local time: 09:34 AM

Posted 29 November 2019 - 07:19 AM

Hello,

I have the opensubtitles plugin installed, and checked the save subtitles to media folder.

However it saves srt into /home/emby/metadata/library/e8/e8ca709bc07ee2ff... This does not happen to all tv shows, but for some. For some, srt is saved to the media folder.

Also, it is impossible for me to delete any subtitles. I click the trash icon and nothing happens. It does not matter where the subtitle is, I cannot delete any subtitle from /home/emby/metadata/library/e8/e8c... neither from the actual media folder.

I would appreciate your help. Thank you.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:34 AM

Posted 29 November 2019 - 11:25 AM

Sounds like the server is being denied write access to your media folder. If you can resolve that then you should start seeing be new downloads saved there, as well as being able to delete them.

#3 huoc OFFLINE  

huoc

    Newbie

  • Members
  • 7 posts
  • Local time: 09:34 AM

Posted 29 November 2019 - 01:33 PM

Thank you for your answer.

All tv shows are in /Video/TV Shows and what is strange to me is that emby is able to save the subtitle to /Video/TV Shows/Series1 and not able to save to /Video/TV Shows/Series2. Also, if emby had write access to save the file either to home/emby/metadata or /Video/TV Shows/Series1, then why am I not able to delete the subtitle from the same folder? I wonder how I should start investigating the access rights.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:34 AM

Posted 29 November 2019 - 02:13 PM

Why do you feel it can't save the subtitles in Series2? What exactly happened? Let's look at an example. Please see how to report a problem. Thanks.



#5 huoc OFFLINE  

huoc

    Newbie

  • Members
  • 7 posts
  • Local time: 09:34 AM

Posted 29 November 2019 - 04:32 PM

Thanks.

I restarted the server. I clicked the series and clicked edit subtitles for episode 1. I searched for subtitles and tried to download one. I tried to delete the one already downloaded. Then I went to settings.

When I click on any of the Paths in emby settings (cache, logs, metadata, transcoding), none are opened, nothing happens.

I went to the expert settings and clicked embyserver.txt and it opened the log. I attached the file. Thanks again.

Attached File  embyserver.txt   121.21KB   3 downloads

 

 



#6 huoc OFFLINE  

huoc

    Newbie

  • Members
  • 7 posts
  • Local time: 09:34 AM

Posted 07 December 2019 - 06:58 PM

Hi. Did you have a chance to review my problem? Should I provide anything else to help investigation?

Thank you.



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:34 AM

Posted 10 December 2019 - 03:35 PM

The subtitles were deleted and then immediately automatically re-downloaded based on your automatic subtitle download settings.

 

So that's something we can stop from happening, although the re-download will still end up happening later with the subtitle download scheduled task.



#8 huoc OFFLINE  

huoc

    Newbie

  • Members
  • 7 posts
  • Local time: 09:34 AM

Posted 10 December 2019 - 04:22 PM

Oh, I see :) Thank you.

And do you see the reason why it did not download the srt into the series folder but rather to /home/emby/metadata/library/e8/e8ca709bc07ee2ff... ?



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:34 AM

Posted 10 December 2019 - 04:32 PM

It tried, but was denied write access and therefore saved it to the metadata folder:

2019-11-29 21:26:46.304 Info SubtitleManager: Saving subtitles to /share/Video/TV Shows/Watchmen/Watchmen.S01E01.It's Summer and We're Running Out of Ice.hu.srt
2019-11-29 21:26:46.304 Info SubtitleManager: Saving subtitles to /home/emby/metadata/library/e8/e8ca709bc07ee2ff284e14655f1cf2c3/Watchmen.S01E01.It's Summer and We're Running Out of Ice.hu.srt

So please check the folder permissions and then try again.



#10 huoc OFFLINE  

huoc

    Newbie

  • Members
  • 7 posts
  • Local time: 09:34 AM

Posted 10 December 2019 - 05:40 PM

Thanks. I could not find an "emby" user on the Asustor NAS but I have refreshed the access permissions and it seems to have solved the problem. I do not know why one folder within TV Shows was OK and another was not OK. Whatever... So thanks for solving this.

Is there a way to delete all srt-s from /home/emby/metadata/library/e8/e8ca709bc07ee2ff... ? So that the the srt-s would be re-downloaded into the media folders? I cannot seem to find this folder on the NAS, my Home folder does not have an emby fodler inside, just

.cache

.config

.dbus

.local

.mono.oracle_jre

.pki



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:34 AM

Posted 10 December 2019 - 08:56 PM

Thanks for the feedback. I would use the file system to directly delete those files, then run a library scan.

#12 huoc OFFLINE  

huoc

    Newbie

  • Members
  • 7 posts
  • Local time: 09:34 AM

Posted 13 December 2019 - 05:12 PM

I contacted Asustor support. By default, user home directory access is disabled. You have to:

got to ADM - Access Control - Shared Folders, and disable the option "disable file access to this shared folder" for /User Homes folder then you should be able to see it in /User Homes.

:o

So thanks for your help, I believe this is solved :)

And I am almost sure that the subfolders created by sonarr are the ones that emby does not have write access to. I have to manually "apply the same access permissions on all subfolders" on the "TV Shows" folder to add write access.



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146246 posts
  • Local time: 03:34 AM

Posted 14 December 2019 - 12:25 PM

Thanks for the feedback.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users