Jump to content


Photo

Play/pause on remote do not work, when opening Emby on TV over DLNA

DLNA Remote Pause

Best Answer oleshkev , 30 January 2020 - 01:53 PM

Just FYI.

 

The problem is resolved for me with one of the next versions.

Current version I use, that has the problem fixed:

Emby (4.3.1.0) and DLNA plugin (1.0.33.0).

 

So the topic may be marked as solved/closed.

Go to the full post


  • Please log in to reply
16 replies to this topic

#1 oleshkev OFFLINE  

oleshkev

    Member

  • Members
  • 14 posts
  • Local time: 07:38 PM

Posted 24 November 2019 - 08:12 PM

Hello everybody.

 

Recently I have moved my Emby server from local install on DietPi (Emby version was 4.2.0.40) to Docker (Emby version is 4.3.0.26 now).

 

After this change, I cannot pause video, fast forward, rewind or continue watching.

Before the switch to docker the functionality was present.

 

I am using Samsung TV to open Emby over DLNA.

 

Does anybody have an idea why this is happened and how to fix it?

 

I have tried to run Emby in Docker with host network and with bridged network options. Result is the same.

 

Thanks,

Aleks.



#2 oleshkev OFFLINE  

oleshkev

    Member

  • Members
  • 14 posts
  • Local time: 07:38 PM

Posted 24 November 2019 - 08:55 PM

UPDATE:

 

I have just installed Emby version 4.2.0.40 in Docker.

And required functionality is WORKING!

 

So the difference is in versions.

Working: Emby 4.2.0.40. DLNA plugin 1.0.23.0

NOT working: Emby 4.3.0.26. DLNA plugin 1.0.31.0

 

This looks like a bug somewhere.


  • Q-Droid likes this

#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153341 posts
  • Local time: 01:38 PM

Posted 24 November 2019 - 10:19 PM

Hi, what are you trying to pause from, the web app?



#4 oleshkev OFFLINE  

oleshkev

    Member

  • Members
  • 14 posts
  • Local time: 07:38 PM

Posted 25 November 2019 - 05:50 AM

Hi, what are you trying to pause from, the web app?

 

No.

 

I select Emby from Source selection screen (see attached). As I understand, some DLNA browser starts.

When I select video, built in player starts (see attached).

And then I control video with buttons on remote (see attached).

 

But in the original problem, built-in player does not show me the controls of pausing/playing etc. As a result it does not allow continue watching, but it always start video from beginning.

 

Attached Files



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153341 posts
  • Local time: 01:38 PM

Posted 26 November 2019 - 12:36 PM

Can you please attach the emby server log? Thanks.

#6 oleshkev OFFLINE  

oleshkev

    Member

  • Members
  • 14 posts
  • Local time: 07:38 PM

Posted 27 November 2019 - 02:42 PM

Can you please attach the emby server log? Thanks.

Luke hello,

Please find attached (two files. one - older version but working. another - newer version, but not working).

 

I have removed several lines with keys (not sure how sensitive they are).

You are interested in communication between 192.168.17.22 (emby server) and 192.168.17.107 (TV).

 

I see the difference. In working version there is the section (marked bold) is present:

2019-11-25 00:49:13.783 Info HttpServer: HTTP POST http://192.168.17.22...rectory/control. UserAgent: DLNADOC/1.50 SEC_HHP_[TV] Samsung 48/1.0 UPnP/1.0
 

Attached Files


Edited by oleshkev, 27 November 2019 - 02:44 PM.


#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153341 posts
  • Local time: 01:38 PM

Posted 27 November 2019 - 05:27 PM

And how does the other one compare?



#8 oleshkev OFFLINE  

oleshkev

    Member

  • Members
  • 14 posts
  • Local time: 07:38 PM

Posted 27 November 2019 - 05:47 PM

And how does the other one compare?

Working is like this:

2019-11-25 00:49:37.110 Info HttpServer: HTTP POST http://192.168.17.22...rectory/control. UserAgent: DLNADOC/1.50 SEC_HHP_[TV] Samsung 48/1.0 UPnP/1.0
 

And it looks like Not working one does not have lines with "control" at all.



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153341 posts
  • Local time: 01:38 PM

Posted 28 November 2019 - 12:38 AM

Right but those are incoming requests from tv to server, not server to tv.

#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153341 posts
  • Local time: 01:38 PM

Posted 28 November 2019 - 12:39 AM

What about emby server 4.2.1?

#11 oleshkev OFFLINE  

oleshkev

    Member

  • Members
  • 14 posts
  • Local time: 07:38 PM

Posted 29 November 2019 - 07:16 PM

Right but those are incoming requests from tv to server, not server to tv.

I understand it. But it looks like emby represent itself differently. And as a result TV do not even try to do it. Or emby detects TV incorrectly and does not offer that type of control to it.

But this is just my guessing.

 

 

 

What about emby server 4.2.1?

 

I tried 4.2.1.0. It works.

Find attached log.

Attached Files



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153341 posts
  • Local time: 01:38 PM

Posted 29 November 2019 - 07:19 PM

Is the media playing the same way in both cases? e.g. direct playing/transcoding.



#13 oleshkev OFFLINE  

oleshkev

    Member

  • Members
  • 14 posts
  • Local time: 07:38 PM

Posted 29 November 2019 - 07:24 PM

Is the media playing the same way in both cases? e.g. direct playing/transcoding.

I expected it is direct playing.

What is the proper way to determine it? I was just checking cpu utilization.

 

Do you want me to compare all 3 versions?



#14 oleshkev OFFLINE  

oleshkev

    Member

  • Members
  • 14 posts
  • Local time: 07:38 PM

Posted 29 November 2019 - 07:35 PM

I expected it is direct playing.

What is the proper way to determine it? I was just checking cpu utilization.

 

Do you want me to compare all 3 versions?

Based on CPU utilization, it is direct playing in both versions:

4.3.0.26 (which does not allow to control video) and 4.2.0.40 (which allows to control video)


Edited by oleshkev, 29 November 2019 - 07:36 PM.


#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153341 posts
  • Local time: 01:38 PM

Posted 29 November 2019 - 09:37 PM

Thanks for the info.

#16 oleshkev OFFLINE  

oleshkev

    Member

  • Members
  • 14 posts
  • Local time: 07:38 PM

Posted 30 January 2020 - 01:53 PM   Best Answer

Just FYI.

 

The problem is resolved for me with one of the next versions.

Current version I use, that has the problem fixed:

Emby (4.3.1.0) and DLNA plugin (1.0.33.0).

 

So the topic may be marked as solved/closed.


Edited by oleshkev, 30 January 2020 - 06:03 PM.

  • Luke likes this

#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153341 posts
  • Local time: 01:38 PM

Posted 30 January 2020 - 05:46 PM

Thanks for the feedback !







Also tagged with one or more of these keywords: DLNA, Remote, Pause

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users