Jump to content


Photo

No Cursor in "Search for Subtitles" menu

menu

  • Please log in to reply
4 replies to this topic

#1 Gibber OFFLINE  

Gibber

    Newbie

  • Members
  • 9 posts
  • Local time: 08:53 AM

Posted 20 November 2019 - 04:05 PM

I am enjoying the updated user interface and new on screen menu options but I have come across an interface issue.

 

If I have selected an episode or movie, and click the "More" button, then select "Edit Subtitles" it brings up the "search for Subtitles" page but there is no cursor (ie. no highlighted selection) that I can move with the scroll keys. Sometimes the cursor will show up after a few seconds, and sometimes it never shows up. In all cases so far I have been able to use the back button to return to the higher menu. And the cursor works fine in all other "More" sub menus.

 

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156770 posts
  • Local time: 04:53 AM

Posted 20 November 2019 - 04:08 PM

Hi, you're saying the language dropdown isn't focused? After that dialog opens, what happens if you just click enter on the remote?



#3 Gibber OFFLINE  

Gibber

    Newbie

  • Members
  • 9 posts
  • Local time: 08:53 AM

Posted 20 November 2019 - 04:58 PM

If the cursor has not shown up yet pressing enter on the remote has no effect on the "Search for Subtitles" screen but when I go back to a higher menu it seems that the enter has been recognized on the previous menu page. So yes, the focus seems to remain back on the higher menu until the cursor shows up in "Search for Subtitles".

 

I tried this several more times and the delay for the cursor to show up seems to average about 20 seconds. I cannot tell if scrolling or pressing enter on the remote has any affect on the delay. I am running the Emby app on an LG OLED55B6P with WebOS 3.

 

I also realized it may be related to the fact that I normally use a Harmony remote control which does not replicate the pointing cursor that is available on the LG remote. With the LG remote you can control the TV's on screen cursor just by pointing the remote control rather than hitting U/D/L/R scroll buttons, just like a PC mouse cursor. If I use the LG remote and place the LG cursor on a field or check box on the "Search for Subtitles" page and hit enter it highlights immediately. If I go to the page and the Emby highlight has not appeared yet and I try to used the U/D/L/R scroll buttons on the LG remote it reacts the same as for the Harmony remote which is no response until the highlight appears.

 

Note this was the same before installing 1.0.20 which does not seem to have had any affect.



#4 SamES OFFLINE  

SamES

    Advanced Member

  • Members
  • 1275 posts
  • Local time: 06:53 PM

Posted 25 November 2019 - 08:10 AM

Hi, you're saying the language dropdown isn't focused? After that dialog opens, what happens if you just click enter on the remote?

 

 

@Luke, I can confirm this is an issue on LG, but not Tizen.   document.activeElement == btnMoreCommands, so it looks like focus is with the '...' button.  Pressing enter on the remote does bring up the '...' submenu.  Checking the css, btnMoreCommands is definitely the focused element.

 

When the 'Edit Subtitles' menu is selected, I can visually see the more commands dialog close, then the '...' button is focused, then the Edit Subtitles dialog loads.  It looks like there is a race condition of some sorts with the nested dialogs.

 

Not sure if that helps.



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156770 posts
  • Local time: 04:53 AM

Posted 27 November 2019 - 06:27 AM

OK I see what's going on. Thanks for reporting.







Also tagged with one or more of these keywords: menu

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users