Jump to content

Tags and Playlists with Emby for Kodi


zomboided
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

Hello, I'm trying to tag a bunch of films for my kids to watch over Christmas so I can display them all in one place using an addon I've built which uses Kodi smart playlists.

 

Any tagging that I apply on the Emby server doesn't appear to sync with Kodi.  If I look at the tags available to me in Kodi, it's just the "Movies" tag that's used to build the Emby Movie playlist.

 

I can create an Emby playlist, which I can access through Emby for Kodi, but I can't appear to use this grouping as the basis for a Kodi smart playlist.

 

Any easy way I can achieve what I want to do here?  Is it right that tags don't get synced? (I've tried rebuilding my library).

 

Link to comment
Share on other sites

Tags get synced fine on my end.

 

Regarding your  christmas list:

Even if you don't use my Embuary skin you can install the Embuary Helper addon. It provides a widget for christmas related content. 

Link to comment
Share on other sites

Thanks for the reply sualfred...the Christmas thing is just the start, I want to try and tag the library and use playlists to help the kids find groups of things they want to see generally.

 

When you say tags get synced, you're seeing them as options when you create a playlist?  And when you look at the list of tags in the movie menu, you see them there?  Or is there somewhere else I should be looking?

Link to comment
Share on other sites

Yep, working very well on my end. 

What happens if you manually refresh the metadata of item that has added a tag? Maybe a new tag isn't triggering a update.

Link to comment
Share on other sites

Hmmmm, running latest 4.2.1.0 server, with 4.0.5 addon, and have just updated my Windows install to Kodi 18.4 (think the Raspberry Pis might be slightly behind).

Cleared the library and rebuilt it.  Also tried manually updating an individual item.  And moved back to Estuary skin.  And still I have no tags being sucked out of the Emby metadata and into Kodi.

 

Am I changing the tags in the right way?  I'm going in the server, finding an item, selecting edit metadata and adding a tag in the section just under the Studios.  I'm then unchecking the Tags in the Enabled Fields to stop it from being changed.

 

I can't see any tag replication options on the server or the addon...are there any?  Or do I need to fetch debug logs?

Edited by zomboided
Link to comment
Share on other sites

I’m assuming in this situation, it’s because the emby repository was likely out of date as well, so it couldn’t see the latest updates until you updated the repository first.

 

Glad it is sorted.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...