Jump to content


Photo

Xbox One no Live TV buffer


  • Please log in to reply
4 replies to this topic

#1 FordGT90Concept OFFLINE  

FordGT90Concept

    Advanced Member

  • Members
  • 663 posts
  • Local time: 11:46 AM

Posted 12 November 2019 - 08:59 PM

This issue has been present for a long time.

The live TV stream is sourced from a Hauppauge QuadHD tuner. When watching live TV you can literally open the OSD and see that the gray bar is being shortened as the green bar advances. This is confirmed in practice as well because you can hit back 10 times in a row and it will only go back by maybe 10 seconds and no more--then it forces you to play. I believe only the Xbox One app has this issue and it's across many accounts.

Considering how WinTV works (accumulating gigabyte files), there has to be a whole lot more data than that sitting on the server but the Xbox One app refuses to acknowledge it exists.

Version of the Xbox One app is 1.1.272.70
Version of Emby Server is 4.3.0.21 beta

Edited by FordGT90Concept, 12 November 2019 - 09:00 PM.


#2 FordGT90Concept OFFLINE  

FordGT90Concept

    Advanced Member

  • Members
  • 663 posts
  • Local time: 11:46 AM

Posted 14 November 2019 - 01:18 AM

I've noticed two more things by using live TV via Emby/Edge browser:

1) What was described in the post above doesn't just apply to the Xbox One app, I can't back up via watching live TV through the web either on Edge. It's the same thing: there's more or less only what you're seeing in the buffer and only a tiny bit more (seconds).

2) Android TV and Xbox One apps, when streaming live TV from the QuadHD, it periodically hangs (maybe every 15-60 minutes) and during this hang. By hang, I mean that the video/audio stops and then picks up (not resumes) a few seconds later. You miss what is in between (not a pause like the HDHRs do). The important thing: I'm not seeing this same behavior via Emby/Edge browser. It's unique to the apps.

Edited by FordGT90Concept, 14 November 2019 - 01:20 AM.


#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142520 posts
  • Local time: 12:46 PM

Posted 15 November 2019 - 12:05 PM

We are working on improving this. Thanks for the feedback.
  • FordGT90Concept likes this

#4 mchammer OFFLINE  

mchammer

    Newbie

  • Members
  • 1 posts
  • Local time: 12:46 PM

Posted 16 November 2019 - 08:15 PM

This issue has been present for a long time.

The live TV stream is sourced from a Hauppauge QuadHD tuner. When watching live TV you can literally open the OSD and see that the gray bar is being shortened as the green bar advances. This is confirmed in practice as well because you can hit back 10 times in a row and it will only go back by maybe 10 seconds and no more--then it forces you to play. I believe only the Xbox One app has this issue and it's across many accounts.

Considering how WinTV works (accumulating gigabyte files), there has to be a whole lot more data than that sitting on the server but the Xbox One app refuses to acknowledge it exists.

Version of the Xbox One app is 1.1.272.70
Version of Emby Server is 4.3.0.21 beta

 

Also experiencing this issue with the Xbox One app, can't skip back the stream.



#5 FordGT90Concept OFFLINE  

FordGT90Concept

    Advanced Member

  • Members
  • 663 posts
  • Local time: 11:46 AM

Posted 20 November 2019 - 10:41 AM

Emby via Edge and Emby via Windows Store app, both transcode when playing a MPEG2 recording. Using MPC-HC, streaming over the network, the GPU in my computer (RX 590) hardware decodes it using only 6% of the decoder's resources. Can Edge/Windows Store apps truly not handle MPEG2 GPU decoding?

Edited by FordGT90Concept, 20 November 2019 - 10:42 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users