Jump to content
jhonata2050

problems installing debian

Recommended Posts

jhonata2050

Hello, I am trying to install emby on a debian machine, and it is not installed and says that some files could not be found or could not be executed, as shown in the image below.

Can anyone help me with this problem

post-537605-0-62038600-1573494659_thumb.png

Share this post


Link to post
Share on other sites
riothamus

From what it looks like, you are missing 'ldconfig' and the command/script 'start-stop-deamon' from your PATH environment variable.  This is odd, since you are running the install command as the root user.

 

As the root user, what do you get when you run: 

which ldconfig

On Debian, it should be located at /usr/sbin/ldconfig (it's provided by the libc-bin package)

 

 

Wait, my bad, you just ran the 'su' command by itself, that's why you don't have root's PATH.  Instead, if you are going to switch to the root user, run:

su -i

or, better yet, just do this as a regular user:

sudo dpkg -i emby-server-deb_4.2.1.0_amd64.deb
Edited by riothamus

Share this post


Link to post
Share on other sites
jhonata2050

 

Pelo que parece, você está perdendo 'ldconfig' e o comando / script 'start-stop-deamon' da sua variável de ambiente PATH. Isso é estranho, já que você está executando o comando install como o usuário root.

 

Como usuário root, o que você obtém ao executar: 

qual ldconfig

No Debian, ele deve estar localizado em / usr / sbin / ldconfig (é fornecido pelo pacote libc-bin)

 

 

Espere, meu mal, você acabou de executar o comando 'su' por si só, é por isso que você não tem o PATH do root. Em vez disso, se você estiver indo para o usuário root, execute:

su -i

ou, melhor ainda, faça isso como um usuário comum:

sudo dpkg -i emby-server-deb_4.2.1.0_amd64.deb

 

 

 

 

 

 

OLÁ AMIGO, consegui instalar aqui, mas adicionar o usuário no modo raiz, pode adicionar o local onde encontrar o emby, por exemplo:

 

sudo dpkg -i / home / logonet / transferencias / emby-server-deb_4.2.1.0_amd64.deb - eu embro - servidor - deb_4 . 2.1 . 0 _amd64 . deb

 

após isso, consegui fazer a instalação, obrigado pelas dicas ;)

Edited by jhonata2050

Share this post


Link to post
Share on other sites
riothamus

No problem, glad you got it sorted out!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...