Jump to content

Cannot delete recordings - Shield


Recommended Posts

HI,

In the Emby App on NVidia Shield, I have noticed that I now cannot delete TV recordings by holding down the select button (on the main poster) on the remote, the subsequent list only displays, Play first unwatched, Play All etc, but no delete media option. I can drill down to each playable media entry (show) and delete individually, but this leaves the poster under recordings which I cannot delete.

 

If however I log into the server via a web page, using the same account, I can select 'Delete Media' as an option on the main poster, which deletes everything under it too.

 

Anyone else experience this?  bug with the Emby app on Android TV ?

Edited by PristDean
Link to post
Share on other sites

Hi.  I don't believe this is new (simply an oversight on that menu that has always existed).  Where, exactly, are you navigating to your recordings and trying this?

Link to post
Share on other sites

Hi, On the initial shield screen, there are 3 options... 'On Now' 'Live TV Guide' &'Recordings'. I do not enter recordings from there as the layout is ectremely poor and cannot be changed as far as I can see.

 

So, I enter 'Live TV Guide', which takes me directly into the TV Guide, then drop back to the Emby server dash layout / menu. Which contains 'Live TV' 'Recordings' 'Movies' etc.  It is there I enter 'Recordings', layout is good and configurable, but you just cannot delete anything from there.

 

End result is you have to drill down to the media, delete individual shows, but the top level poster remains, un-deletable via Shield Emby app. 

Link to post
Share on other sites

I have just worked out that you have to enter a title then mark it as 'Played' which sets all content within as played. You can then select 'Delete' from the main poster.

Can this be updated, so even if content is unplayed, the 'Delete' option is available ?  

Link to post
Share on other sites

I have just worked out that you have to enter a title then mark it as 'Played' which sets all content within as played. You can then select 'Delete' from the main poster.

Can this be updated, so even if content is unplayed, the 'Delete' option is available ?  

 

There should be no relationship between those two things.

 

Exactly what are you trying to delete?  A single recording or an entire show?

Link to post
Share on other sites

As mentioned, this at the top level... an entire series, so multiple shows within. There is obviously a relationship between being allowed to delete played and unplayed shows. This is the exact behaviour on the Emby app on Shield.

A series with an unplayed count (some shows played, some unplayed or all unplayed) cannot be deleted at the top level, no 'Delete' shown.

A series with all shows marked as played will show the 'Delete' option at the top level.

Link to post
Share on other sites

Hi.  There is no restriction on played/unplayed so something else is going on there.  Here is me bringing up the menu on a series with unplayed items.

 

Are you scrolling down in the menu...?

 

5dc9731988eca_deleteseries.png

Link to post
Share on other sites

Hi, Yep, definitely, there is nothing after 'Add Favourite' at the foot of the menu when the poster displays an unread count.  As said, If I mark it as played, then the delete option appears.

Is there a 'Protect unplayed' setting somewhere ?

Link to post
Share on other sites

No, there is no such setting.

 

Try this.  Just go into one of the items that shows an unplayed count.  Don't mark it as played - but play it for just a few seconds and then back out of it again.  Now, is the delete option in the menu for you?

Link to post
Share on other sites

That works, played it for a few seconds,  I now have 3 selections when top level poster selected... Mark Played, Add Favourite & Delete. The unread mark still shows.

 

So.... does that give you any clues as to what is going on ?

Link to post
Share on other sites

No, all other entries remain the same. What we achieved above was purely a test which hopefully sheds some light from your end, but not mine, I am no further forward with the issue.

Link to post
Share on other sites

@@ebr Delete button deletes successfully.... But.. the delete button is not visible unless:

  1. You play the recorded prog for a few seconds, then go back out.
  2. You mark the content as played, then go back out

The delete button should be visible whether the content is played or not without going through points 1 & 2

Link to post
Share on other sites

The only thing that would explain that behavior would be the "CanDelete" field not being delivered by the list retrieval but, that field is requested and I cannot reproduce this with the 4.2.1 release of the server.

 

Can you please post a server log from when you just go into the screen where you want to delete the item and tell me what time you did that?

 

Thanks.

Link to post
Share on other sites

As requested.  1st is on the first menu after entering the Emby app.  2nd is after entering 'Recordings' and attempting to delete an unplayed entry, there is no delete option

 

post-344476-0-64862300-1573673686_thumb.jpg

post-344476-0-89038700-1573673688_thumb.jpg

Link to post
Share on other sites

Okay, so this library is not the automatic "Recordings" library setup by Emby because, it appears, it is defined as a TV library and then, on top of that, you're browsing by folders.

 

How did you setup this library and why are you browsing by folders if it is a TV library?

 

Thanks.

Link to post
Share on other sites

I'll tell you why I am not using the default 'Recordings' library, because it is unusable.  Either shows no icon on a recording, or just a snapshot of the content, does not group a series, plus, the same issue, cannot select 'Delete' I could go on.

 

I set up that library to take recordings and organise them nicely. Are you saying that the 'Delete' option is not available in a library created by a user that stores or has recorded media saved into it?

Edited by PristDean
Link to post
Share on other sites

Hi.  No, I'm just trying to determine exactly what your setup is so that I can define the issue.

 

If you've set it up as a TV library, why use the Folder browsing for it?  Does it not show as series properly?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...