Jump to content


Photo

Dual audio - one track not working

Dual Audio Issue

  • Please log in to reply
6 replies to this topic

#1 ertagon2 OFFLINE  

ertagon2

    Advanced Member

  • Members
  • 30 posts
  • Local time: 12:12 AM

Posted 07 November 2019 - 08:27 PM

So I have some anime movies with dual audio and both audio tracks work fine when played locally on VLC but when played from the emby app one of the tracks (so far only English) would play with no sound.
Any fixes ?



#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 49818 posts
  • Local time: 07:12 PM

Posted 07 November 2019 - 08:52 PM

Hi.  Please provide specifics for the example.

 

Thanks.

 

How to Report a Problem



#3 ertagon2 OFFLINE  

ertagon2

    Advanced Member

  • Members
  • 30 posts
  • Local time: 12:12 AM

Posted 08 November 2019 - 04:08 PM

I have a .mkv anime movie with dual audio track English and Japanese. The Japanese track works fine but when I switch over the English track, there is nothing, it dead silent, the movie plays alright tho.
It works fine when played from VLC from my PC.

Stream Log
https://pastebin.com/Tpci0PSP
 

Server log
https://pastebin.com/ZdVF0KAm



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148763 posts
  • Local time: 07:12 PM

Posted 08 November 2019 - 06:55 PM

Can you check the mkc container and see if the track has a large audio delay set? If yes then this is currently a known issue as we haven't added support for that when transcoding.



#5 ertagon2 OFFLINE  

ertagon2

    Advanced Member

  • Members
  • 30 posts
  • Local time: 12:12 AM

Posted 08 November 2019 - 07:57 PM

It's got 3.6s.

Is that a lot ?
5dc600afc5240_temp.png

I checked another one and it has 25s.

Is there something I can do to fix it? Are you guys planning on fixing it since it's "known issue"?


Edited by ertagon2, 08 November 2019 - 08:00 PM.


#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148763 posts
  • Local time: 07:12 PM

Posted 08 November 2019 - 09:43 PM

Yes it's planned for the future. Immediate workaround would be to remux the file and remove the delays.

#7 ertagon2 OFFLINE  

ertagon2

    Advanced Member

  • Members
  • 30 posts
  • Local time: 12:12 AM

Posted 08 November 2019 - 09:56 PM

Yes it's planned for the future. Immediate workaround would be to remux the file and remove the delays.

Okay thank you for your help.

Do you have an opened GitHub issue about this? I can't find anything.







Also tagged with one or more of these keywords: Dual Audio, Issue

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users